Elite indicators :) - page 160

Mladen Rakic
151105
Mladen Rakic  

Ray

In the call to vortex indicator you are missing the first parameter (the time frame parameter - the indicator is a bit specific compared to others regarding that parameter) So, instead of writing this :

double VotexC=iCustom (NULL, 0,"RK-vortexmtf",VortexPeriod,ShowD,Itp,0,ShiftV+0);

[/php]you should use something like this :

[php] double VotexC=iCustom (NULL, 0,"RK-vortexmtf","whatever",VortexPeriod,ShowD,Itp,0,ShiftV+0);

if you want it to calculate the current time frame (the time frame you are testing) If you want to use other time frame you can do it through the usual time frame parameter (the 2nd parameter in the iCustom()) or you can specify it in the first parameter (instead of "whatever" that I wrote there you can use time frame - just make sure to pass it as string not number (so "15" and not 15))

That parameter is a bit of a mystery, isn't it (you are not the first to overlook it, I did it a couple of times when I forgot what am I using it for It is used, among the obvious, to call recursively the indicator itself to calculate or to get the number of bars changed in the target time frame, hence, if the first parameter is omitted, it falls into a large number of recursive call ) After setting the parameters as described, you are going to get this after visual testing (just tested vortex, that is why non lag ma is missing from the picture)
As you can see,the show difference issue is solved in this case too

Hope this helps

And, keep up the good work. Did not test thoroughly the EA itself but was rather looking for the cause of error, but will as soon as I grab a bit more time (later tonight I guess)

regards

mladen

traderduke:
mladen

Many thanks for the training you have bestowed on me. I'm trying to write an EA using your Voltex indicator. I appear to have fallen into a lucky setup but its rearly into the testing. I am using it with Renko bricks but the problem also happens for all other TFs.

1. When backtesting at the conclusion of the test when the indicator is poped on the screen, it turns horizonal, see attached. If you list the indicators on the visual screen you will find several hundred vortex indicators listed???

2. I was trying to show levels for the "ShowDifference = True;" but it won't show if "True".

Any help would be appreciated. You might even find the EA interesting!

Ray
Files:
vortex.jpg 263 kb
casaliss
109
casaliss  

Mtf

Hi Mladen

MTF

Thanks

umeshkathuria
30
umeshkathuria  

Pls add alerts to RSI EMA MTF

Hi,

Attached is the RSI_EMA_MTF indicator. I request you to kindly add alerts and arrows at the crossover of RSI and EMA on the main chart window.

Thanks,

Umesh

Files:
traderduke
531
traderduke  

MLaden

Thats for the responce, "whatever" fixed the visualat the end of the backtest, see attached, but the Indicator seems to be dancing to a different timeframe. My guess would be the regular 5min and not the Renko 5min, like you said leaving the NULL, 0, usually makes the indicator revert to the 5 min renko. Is there any way to get this indicator to use the Renko 5 min also is there any way to get the levels to show with ShowD = True ?? The backtest is still running according to the parameters, see attached, thats good.

Appreciate your help, I love this indicator, it mirrors DMI/ADX to some extent but much better.

Ray

Mladen Rakic
151105
Mladen Rakic  

umeshkathuria

Try this one out

Changed some things (added interpolate and some different mtf handling in order to avoid the some usual traps of mtf - as I remember we had some issue with version 1.0 which cause to make 1.1, but can not remember now what exactly was the issue)
regards

mladen

umeshkathuria:
Hi,

Attached is the RSI_EMA_MTF indicator. I request you to kindly add alerts and arrows at the crossover of RSI and EMA on the main chart window.

Thanks,

Umesh
Files:
Mladen Rakic
151105
Mladen Rakic  

traderduke

If I am right, renko charts are usually made as offline charts and usually are having a "custom" time frame when saved. Meaning : if it is saved as 2 minute chart (the ones I saw are usually doing that or you can specify the "time frame" (time frame being simply an addition to the name which is then used to save the file) then you should use 2 in the time frame (the regular time frame parameter in call to the iCustom(NULL,timeFrame,...) - So iCustom(NULL,2,...))

If, on other hand, it is just drawn on the chart then you can not apply the indicator to it, since it is going to use the real time frame and real data it is attached to (so, in your case, it is using 5 minute data and not the data displayed on the chart, since those are objects. Also, as far as I know, renko can not be bound to time (so there is no such thing as a 5 minute renko - it is range (or better told, a change in price) bound and no one can tell when it will be reached)

regards

mladen

traderduke:
Thats for the responce, "whatever" fixed the visualat the end of the backtest, see attached, but the Indicator seems to be dancing to a different timeframe. My guess would be the regular 5min and not the Renko 5min, like you said leaving the NULL, 0, usually makes the indicator revert to the 5 min renko. Is there any way to get this indicator to use the Renko 5 min also is there any way to get the levels to show with ShowD = True ?? The backtest is still running according to the parameters, see attached, thats good.

Appreciate your help, I love this indicator, it mirrors DMI/ADX to some extent but much better.

Ray
Hercs
2970
Hercs  
traderduke
531
traderduke  

Vortex

mladen,

Your correct, I am running a 1min chart with Renkscript using 7 pips & 5min chart, then retrieve 5min offline chart need to use 5min for testing or live because my broker only has 1m,5m,15m etc,

If I do NULL,0, in the EA the vortex indicator doesn't works and at the end of the backtest I get what I showed you.

If I do NULL,5, in the EA the vortex indicator doesn't have any influence on the EA but is visable at the end of the test but it's on a regulare 5 min chart.

If I doNULL,0,"whatever" in the EA the vortex indicator doesn't have any influence on the EA but is visable at the end of the test but it's on a regulare 5 min chart.

The interesting part is if I set up the 5min offline chart & load the vortex it works correctly which is what lead me to use it.

I haven't traded it live so I guess there is only one way to find out WHAT IS REAL. Thats the only reliable test anyway.

If you come up with any suggestions let me know. Tomorrow I'll let you know how it does. The funny thing is the EA Program and its settings are a fluke. I was just trying to get the EA working with the vortex. BLIND LUCK!

Ray

Mladen Rakic
151105
Mladen Rakic  

Ray

I am reading the manual for renko script that I found on the net. It is saying : "TimeFrame should be set to 2 by default." So you should use iCustom(NULL,2,...)or whatever number you are entering in that parameter of renko script (do not enter it in the TimeFrame parameter of vortex since it will be ignored)

regards

mladen

Mladen Rakic
151105
Mladen Rakic  

...

casaliss

Multi time frame TVI (rewritten completely - results are the same) Renamed it too to just TVI , since there is nothing related to "ticks" in its calculation (best description would be a "kind of a double smoothed volume modified close to open momentum calculation")

Updated version posted here : https://www.mql5.com/en/forum/general

regards

mladen

casaliss:
Hi Mladen

MTF

Thanks
Files:
tvi.gif 21 kb
tvi.mq4 6 kb