Ошибки, баги, вопросы - страница 3596
Вы упускаете торговые возможности:
- Бесплатные приложения для трейдинга
- 8 000+ сигналов для копирования
- Экономические новости для анализа финансовых рынков
Регистрация
Вход
Вы принимаете политику сайта и условия использования
Если у вас нет учетной записи, зарегистрируйтесь
Подскажите, вылазит мне: 2024.12.02 17:20:22.903opening at market sl: 0.00 tp: 0.00 failed [Trade is disabled]
Английский не знаете? Переводчика нет?
А терминал тоже не знает аглицкий? Сам не может включить…)))
В тестере, в спецификации инструмента (Золото) торговля запрещена.
Запускаю отладку, останавливаю на точке останова и вижу, что торговля разрешена.
Советник пытается открыть позицию и получает
Что я делаю не так?
Как определить, что торговля по этому символу запрещена?
всем доброго вечера! Возникла вот такая ситуация
В метатрейдере 4 в меню сервис в разделе графики исправил параметр загрузки истории побольше, чтобы загрузилось побольше истории котировок. Потом перезагрузил МТ 4 .
И после этого МТ 4 запустить не получается. Может кто знает как исправить этот параметр на прежний ,не устанавливая заново МТ 4?
Вопрос к знатокам WebSocket.

Тестирую на PostMan незащищенный websocket ws://.... с аутентификацией доступа через ACCESS_KEY, прописанный в Headers. Все работает корректно.
но при попытке запустить соединение сокета в MQL5 вылетает ошибка 4014. Код запускается с советника, а не с индикатора.
ERR_FUNCTION_NOT_ALLOWED
4014
Function is not allowed for call
Причем GET WebRequest работает нормально, так как в нем во входном параметре headers я передаю ACCESS_KEY.
Но с вебсокетом даже не понятно как передавать данный ключ.
В чем причина?
Вопрос к знатокам WebSocket.
Тестирую на PostMan незащищенный websocket ws://.... с аутентификацией доступа через ACCESS_KEY, прописанный в Headers. Все работает корректно.
но при попытке запустить соединение сокета в MQL5 вылетает ошибка 4014. Код запускается с советника, а не с индикатора.
ERR_FUNCTION_NOT_ALLOWED
4014
Function is not allowed for call
Причем GET WebRequest работает нормально, так как в нем во входном параметре headers я передаю ACCESS_KEY.
Но с вебсокетом даже не понятно как передавать данный ключ.
В чем причина?
нашел ошибку. В настройках разрешенных url адресов указал номер порта, чего делать не надо было. ))
Аномальное поведение текущего билда с хэндлами индикатора.
Скринкаст прилагаю. Все три хэндла одинаковым номером инициализировались, что считается за баг. В результате три индикатора как 1 видит.
Аномальное поведение текущего билда с хэндлами индикатора.
Скринкаст прилагаю. Все три хэндла одинаковым номером инициализировались, что считается за баг. В результате три индикатора как 1 видит.
Если параметры расчёта (не рисования) у индикаторов одного типа одинаковы, то для расчёта используется один индикатор.