New metatrader 4 compatible indicators - page 39

secretcode
898
secretcode  

Dear Mladen

Would you please make attached indicator compatible with new build

Thank you in advance

secretcode

Mladen Rakic
160095
Mladen Rakic  
secretcode:
Dear Mladen

Would you please make attached indicator compatible with new build

Thank you in advance

secretcode

secretcode

Here you go

secretcode
898
secretcode  
mladen:
secretcode Here you go

Thank you so much Mladen for quick response and great indicator

Respectfully

secretcode

Brad
5
Brad  

Dear Mladen,

These scripts don't play well with build 610. Will you help, please?

Thanks,

Brad

Mladen Rakic
160095
Mladen Rakic  
DIRdiver:
Dear Mladen,

These scripts don't play well with build 610. Will you help, please?

Thanks,

Brad

Brad

As far as I see there is no compatibility problem with those scripts

Some (like Buy wit SL and TP or Sell with SL and TP) will not work on ECN type brokers, but that is a problem of the code (it wasn't working OK on build 509 either if the broker was ECN type) and the others have some logical errors (it will close only one order when you activate it, nut I am not sure if that was the intention or not), but other than that all the scripts are working as expected

Brad
5
Brad  
mladen:
Brad

As far as I see there is no compatibility problem with those scripts

Some (like Buy wit SL and TP or Sell with SL and TP) will not work on ECN type brokers, but that is a problem of the code (it wasn't working OK on build 509 either if the broker was ECN type) and the others have some logical errors (it will close only one order when you activate it, nut I am not sure if that was the intention or not), but other than that all the scripts are working as expected

Mladen,

First, thank you for taking the time to look into this. However, these did all work on 509 w/a ECN (MBT). The buy and sell scripts had to have a zero SL and TP in order to work with an ECN. Then they would place a market order or limit order by hotkey without confirmation. It was convenient. And you're right close.mq4 was only supposed to close a trade per a specific pair whereas the other close script was for all open orders regardless of pair. The response from 610 now for these scripts is 'trade operations not allowed by settings'.

Thanks again for your time,

Brad

-IXI-
44
-IXI-  

Dear Mladen

Can you briefly explain how an EA or script have to be modified to work on ECN brokers?

Any reference?

Best,

Mladen Rakic
160095
Mladen Rakic  
DIRdiver:
Mladen,

First, thank you for taking the time to look into this. However, these did all work on 509 w/a ECN (MBT). The buy and sell scripts had to have a zero SL and TP in order to work with an ECN. Then they would place a market order or limit order by hotkey without confirmation. It was convenient. And you're right close.mq4 was only supposed to close a trade per a specific pair whereas the other close script was for all open orders regardless of pair. The response from 610 now for these scripts is 'trade operations not allowed by settings'.

Thanks again for your time,

Brad

Brad

See what the close script (I renamed it to close 1 since I already had one named close in the same folder) did when I executed it :

Check the settings if somewhere you have trading disabled (for example in the options->experts advisors-> allow live trading option

Files:
closeing.gif 84 kb
Mladen Rakic
160095
Mladen Rakic  
-IXI-:
Dear Mladen

Can you briefly explain how an EA or script have to be modified to work on ECN brokers?

Any reference?

Best,

IXI

On ECN broker you can not place an order with stop loss and/or take profit set to a price different than 0. So, for ECN brokers it is done in two steps : first an order with sl and tp set to 0 is opened and when the order is successfully opened then the sl and/or tp are modified (if necessary)

Mladen Rakic
160095
Mladen Rakic  

Kaufman AMA - pre filtered

they are "changing" something in the coding language each and every day for this new metatrader 4. It is a thing that we are used to already (metatrader 5 has stunts like that all the time). So here is one version that is strictly new metatrader 4 compatible (current build 613 that I am using) and let see how long it will last before we have to change the code of this indicator too (even though it is 100% compatible with the current build)