New metatrader 4 compatible indicators - page 16

Arecibo
114
Arecibo  

Hi Mladen,

thanks for your assistance. The problem I have is that when the update happened all my original custom indicators remained in place and I can use them on the platform, but I am unable to add any new ones at all. So I installed an entirely new MT4 off Alpari and had the same issue, any new indicators, including the newly coded ones in this thread, I added to my MQL4>Indicators folder simply don't appear in the custom indicators folder at all when I open the MT4. So I've tried the shortcut link above and it has worked in the sense that the added indicators are appearing in the custom indicators folder but they are all grey and unable to attached to chart. These include the indicators supplied with the MT4 as standard. When following the 'modify' route they all, including your Angle of T3 & alerts indicator all give the error as follows in the picture below. Also below is a screen of what the custom indicators folder looks like. I've been battling to find a solution to this everywhere but to no avail. I think this may be a similar problem to jomatk in #50 and onwards in this thread.

Files:
capture.jpg 115 kb
capture2.jpg 91 kb
Mladen Rakic
160098
Mladen Rakic  
Arecibo:
Hi Mladen, thanks for your assistance. The problem I have is that when the update happened all my original custom indicators remained in place and I can use them on the platform, but I am unable to add any new ones at all. So I installed an entirely new MT4 off Alpari and had the same issue, any new indicators, including the newly coded ones in this thread, I added to my MQL4>Indicators folder simply don't appear in the custom indicators folder at all when I open the MT4. So I've tried the shortcut link above and it has worked in the sense that the added indicators are appearing in the custom indicators folder but they are all grey and unable to attached to chart. These include the indicators supplied with the MT4 as standard. When following the 'modify' route they all, including your Angle of T3 & alerts indicator all give the error as follows in the picture below. Also below is a screen of what the custom indicators folder looks like. I've been battling to find a solution to this everywhere but to no avail. I think this may be a similar problem to jomatk in #50 and onwards in this thread.

Arecibo

Install the metatrader to any other folder but "Program files". The best would be that you install it to a different partition (I, for example, am having metatraders always on my E: partition, never on C:)

"Program files" folder in windows 7 have a special (it is a windows 7 protection mechanism) status and it prevents you from compiling sources that you have in that metatrader

PaulOgunmola
9
PaulOgunmola  
mladen:
Paul

Which version of windows are you using? If it is windows 7 or windows 8, your custom indicators are not stored in your metatrader\mql4\indicators folder but somewhere in c:\Documents and Settings\user name\Application Data\Metaquotes\...

Add /portable switch top your shortcut (as on the picture) and then you can use folders the same way as you are used to with current build 509 of metatrader

Hi Mladen,

Apologies I've to bother you again. I'm not sure I know exactly how to go about this task. I searched through my metatrader platform , I don't seem to know where to get the 'beta test properties window'. If it won't be too much for you, could you please detail the steps involved for me. Many thanks.

Mladen Rakic
160098
Mladen Rakic  
Paul Ogunmola:
Hi Mladen, Apologies I've to bother you again. I'm not sure I know exactly how to go about this task. I searched through my metatrader platform , I don't seem to know where to get the 'beta test properties window'. If it won't be too much for you, could you please detail the steps involved for me. Many thanks.

Paul

When you installed metatrader a shortcut to it has been made. Right click on it and in the shortcut properties simply add that /potrable part to whatever is written in the target

Mladen Rakic
160098
Mladen Rakic  
mladen:
Including this one for one simple reason : it is using old rates passing ways to dll. Dll was changed in only one part (it is described here https://www.mql5.com/en/forum/183353/page65 what was the change) and in the mql code nothing (not a single letter) was changed and it works properly again

It turned out that the ArrayCopyRates() does not work exactly the same way as in previous version of metatader 4 so the mq4 file has to be changed too. This is the correct code showing how it can be done. Guess that the change came with build 602 since tests in build 600 were working OK in cases when new bars were formed too (that is the case that must be taken into account now)

_________________

PS: the dll from this post https://www.mql5.com/en/forum/183798/page7 needed for this indicator to work correctly

Arecibo
114
Arecibo  

sorry meant to attach a quote to post as below

Arecibo
114
Arecibo  
mladen:
Arecibo

Install the metatrader to any other folder but "Program files". The best would be that you install it to a different partition (I, for example, am having metatraders always on my E: partition, never on C:)

"Program files" folder in windows 7 have a special (it is a windows 7 protection mechanism) status and it prevents you from compiling sources that you have in that metatrader

Thanks Mladen, I have followed your instructions and now have a working MT4 build 600 in a new folder, still in C: as I unfortunately don't have any other partitions, but it is working. However, my base problem still remains...when I place new indicators in the MQL4>Indicators folder of my newly created MT4, when I open the charts none of them appear in the custom indicators folder. The standard supplied indicators are there and yellow in colour, but none of my added ones appear at all.

Mladen Rakic
160098
Mladen Rakic  
Arecibo:
Thanks Mladen, I have followed your instructions and now have a working MT4 build 600 in a new folder, still in C: as I unfortunately don't have any other partitions, but it is working. However, my base problem still remains...when I place new indicators in the MQL4>Indicators folder of my newly created MT4, when I open the charts none of them appear in the custom indicators folder. The standard supplied indicators are there and yellow in colour, but none of my added ones appear at all.

Arecibo

Did you add the /portable switch to the shortcut?

Otherwise you will have to copy the indicators to something like Documents and Settings\user nanme\AppData\Roaming\Metaquotes\Ter minal\....... some crazy name like DC23F91B23CA16\MQL4\Indicators

Mladen Rakic
160098
Mladen Rakic  

Guys,

Some very good, in detail explanations how to set up the new metatrader 4 you can find here : https://www.forex-tsd.com/forum/commercial-talks/9092-fxcm/page46#comment_736746

Demibara Kurniawan
4
Demibara Kurniawan  

Sorry about my english. I'm not too fluently in english.

I just wanna ask one thing.

What about backtesting Renko on new mt4 (upgraded MQL4)?

Is someone has a script for that?