Indicators with alerts/signal - page 888

Mladen Rakic
154384
Mladen Rakic  
rplust:
Hi,

But could you please add an alert to the following Indicator. Thank you!

simplebars_matf_nmc.mq4

rplust

Here is a version that has alerts added to it : simplebars_mtf_amp_alerts_nmc.mq4

dmnik
132
dmnik  

Hello! Please correct alert does not work. Thank you!

Files:
andrich
33
andrich  
mrtools:
Hi Zefx, added the alerts, with a changeable level

Mrtools, thank you, helps a lot!

rplust
244
rplust  
mladen:
rplust Here is a version that has alerts added to it : simplebars_mtf_amp_alerts_nmc.mq4

Thank you mladen...I did not know that my request was moved here. I appreciate your help!

William Snyder
9492
William Snyder  
DMNIK:
Hello! Please correct alert does not work. Thank you!

Hello DMNIK, that is a decompiled indicator, would need the original non decompiled source code to be able to fix it.

rpasupathy
108
rpasupathy  
mrtools:
Hi Rpasupathy, combined them with alerts, with an option for arrows or both lines and the arrows.

Thanks a lot

rplust
244
rplust  

rplust

Here is a version that has alerts added to it :

HI,

trying to understand why I do not get an alert. Attached is a 30m chart with MTF H1 setting.

The alert should have popped up once the first bar is red. It did not. Now is the second red bar in progress, there's still no alert. Anything to do with MTF?

Files:
Mladen Rakic
154384
Mladen Rakic  
mladen:
rplust

Here is a version that has alerts added to it :

HI,

trying to understand why I do not get an alert. Attached is a 30m chart with MTF H1 setting.

The alert should have popped up once the first bar is red. It did not. Now is the second red bar in progress, there's still no alert. Anything to do with MTF?

rplust

If you want to get alerts on a still opened bar, set the alerts on current parameter to true (even in mtf it has to be set to true in order to get alerts on the higher time frame current bar)

rplust
244
rplust  
mladen:
rplust

Here is a version that has alerts added to it :

HI,

trying to understand why I do not get an alert. Attached is a 30m chart with MTF H1 setting.

The alert should have popped up once the first bar is red. It did not. Now is the second red bar in progress, there's still no alert. Anything to do with MTF?

Ok, I guess I understand the issue. I have set the Indicator on the 1 H to "Current Bar" and the alert window did pop up once the H1 candle turned red and it had closed. But then, the advantage I thought to have when using the 30 min with MTF H1 is not there after the first red candle close on the 30 min, as it has to wait for the H1. But by then the train is long gone.

Mladen Rakic
154384
Mladen Rakic  
rplust:
Ok, I guess I understand the issue. I have set the Indicator on the 1 H to "Current Bar" and the alert window did pop up once the H1 candle turned red and it had closed. But then, the advantage I thought to have when using the 30 min with MTF H1 is not there after the first red candle close on the 30 min, as it has to wait for the H1. But by then the train is long gone.

rplust

Please read this post : https://www.mql5.com/en/forum/180648/page592