Indicators with alerts/signal - page 704

john jacob
135
john jacob  
mladen:
johnjacob

In the code where you changed the vertical position, simply adjust to the values you need (for example you have added 80 to all vertical position that are now having that gap. Replace TextOffSetFromTop + nn + 80 with TextOffSetFromTop + nn and it will be OK). Instead of changig the positions in the code, when you remove those "+80" from the code, use TextOffSetFromTop parameter to adjust vertical position

As of the line : find in the code something that goes like this :

"--------------------------------------------------",

and replace it with a string of the length you need

Thank you very much mladen...I got one more quick question... How do i take those label words thats on the indicator off? Thank you

Mladen Rakic
154658
Mladen Rakic  
johnjacob:
Thank you very much mladen...I got one more quick question... How do i take those label words thats on the indicator off? Thank you

Delete all the lines of code that have "txt1D_1" for object name

john jacob
135
john jacob  

Thank you very much mladen for helping me out..You Take care now and enjoy the rest of the day..And thanks again

secretcode
898
secretcode  

Dear Mladen / Mrtools

Is it possible to add color on OB/OS zone (OB=Red, OS=Green) in attached indicator ?

Thanks for any help

secretcode

Files:
Mladen Rakic
154658
Mladen Rakic  
secretcode:
Dear Mladen / Mrtools

Is it possible to add color on OB/OS zone (OB=Red, OS=Green) in attached indicator ?

Thanks for any help

secretcode

secretcode

Here you go

Files:
secretcode
898
secretcode  
mladen:
secretcode Here you go

Nice indicator, Thank you very much Mladen

Respects

secretcode

Trader54
10
Trader54  
mladen:
Seems that with build 509 of metatrader IndicatorCounted() function always returns 0 when called from the offline chart - as a result it causes all the bars of the offline chart recalculated. Same thing happens with the new metatrader 4 (ested it with 3 different types of offline generating code and in all the cases the same thing happens). So it seems that you have found a bug in the metatrader 4 What you can do is to limit the maximal number of bars on chart (tools->options->max bars on chart) to 5000 (that should be enough for 99.99% of cases

Would the newer build 574 solve my problem?

Mladen Rakic
154658
Mladen Rakic  
Trader54:
Would the newer build 574 solve my problem?

Trader54

Did you see this post : https://www.mql5.com/en/forum/180648/page470 ? That issue is solved (for metatrader 4 build 509 as well as for build 574). Simply the way how offline charts (in the case of multiple offline charts) are treated by coders has to be changed

panchovillas
85
panchovillas  

Dear Masters,

When two or more of your coded alerts indicators are triggered at the same time (new 4h candle), just one pushnotification is sent but the pop up alert message bord still shows all the alerts. In this case is the same indicator in different pairs triggered at the exactly same time

This have happen before but I wasn't sure if it was my fault by messing with on/off settings so this time when turning on the alerts (early in the morning) I have done it by change values in editor and compile, so the same indicator in different pairs has the same settings, but it still just push one notification, last time I got one notification when I should have 4,tree of them where successful trades but I just grab one because was the only one I got at the work where I then go to a PC and load that chart, home PC is the one who is scanning the 17 pairs I trade,

Because the alert works ok on the message board I think this is related with my platform and not with indicators, am I right? There's anything I can do to turnaround this problem? Installing several instances or have multiples Pc's is my only solution?

Thank you by your replay in advance,

William Snyder
9492
William Snyder  
panchito:
Dear Masters,

When two or more of your coded alerts indicators are triggered at the same time (new 4h candle), just one pushnotification is sent but the pop up alert message bord still shows all the alerts. In this case is the same indicator in different pairs triggered at the exactly same time

This have happen before but I wasn't sure if it was my fault by messing with on/off settings so this time when turning on the alerts (early in the morning) I have done it by change values in editor and compile, so the same indicator in different pairs has the same settings, but it still just push one notification, last time I got one notification when I should have 4,tree of them where successful trades but I just grab one because was the only one I got at the work where I then go to a PC and load that chart, home PC is the one who is scanning the 17 pairs I trade,

Because the alert works ok on the message board I think this is related with my platform and not with indicators, am I right? There's anything I can do to turnaround this problem? Installing several instances or have multiples Pc's is my only solution?

Thank you by your replay in advance,

Wonder if it possibly could be your mobile provider.