Mladen Rakic
200846
Mladen Rakic  
dasssi:
i dont like log file its always a file that you forget to delete but dear sir the problem still there

Man

I do not know what this new metaeditor does. I change the line press F7 (which should save the file and compile it) and it still keeps the old version. Updated the source at the original post and downloaded it (to make sure that that line is commented) and it seems to be OK now

[Deleted]  

Dear Mladen,

Last for the day: are marney_volume_indicator_-_extended.ex4 and chaikins_volatility.ex4 new metatrader buddies

Best regards

Rosalieone

Mladen Rakic
200846
Mladen Rakic  
dasssi:
Perhaps this is an innovative method from mq to test the level of nervous of humans .. in visual mode it does not open any trade

You mean how long will shall take before we kill someone? :):)

dasssi, here is my visual test (1 minute EURUSD tested) and it opened a couple of orders (it opened some short orders too after that snapshot)

Files:
poohguo
232
poohguo  

Hi Mladen,

Attached is a script I coded to place long orders. It is meant to work this way:

You input the stop loss, buy price in the case of stop/limit orders, and risk percentage, the script will automatically calculate the lot size and place the order.

The risk % is based on equity of the account. For example, if you input “ 1” in Risk, the risk will be 1% of your account equity.

This is a simple script. It used to work. However, recently it doesn’t work properly. The order size it generates is much smaller than the right one. For example, if I have $50,000 in the account and I risk 1%, for the EU pair, my stop loss is 1.35900 and my buy price is 1.36000, so I risk 10 pips (4-digit), the correct lot size should be around 5, however, the lot size generated by the script is only 0.32. Can you please take a look for me and fix it ?

Thanks in advance

pooh

Files:
[Deleted]  

Perhaps this is an innovative method from mq to test the level of nervous of humans ..

in visual mode it does not open any trade

i use it on 3 terminals no trade...

Mladen Rakic
200846
Mladen Rakic  
pooh123:
Hi Mladen,

Attached is a script I coded to place long orders. It is meant to work this way:

You input the stop loss, buy price in the case of stop/limit orders, and risk percentage, the script will automatically calculate the lot size and place the order.

The risk % is based on equity of the account. For example, if you input “ 1” in Risk, the risk will be 1% of your account equity.

This is a simple script. It used to work. However, recently it doesn’t work properly. The order size it generates is much smaller than the right one. For example, if I have $50,000 in the account and I risk 1%, for the EU pair, my stop loss is 1.35900 and my buy price is 1.36000, so I risk 10 pips (4-digit), the correct lot size should be around 5, however, the lot size generated by the script is only 0.32. Can you please take a look for me and fix it ?

Thanks in advance

pooh

pooh

Use the calculation way from this indicator (it calculates correct lot sizes from your example)

Files:
lot_size.mq4 2 kb
William Snyder
9549
William Snyder  
rosalieone:
Dear Mladen,

Last for the day: are marney_volume_indicator_-_extended.ex4 and chaikins_volatility.ex4 new metatrader buddies

Best regards

Rosalieone

Rosalieone, both are working on build 610 for me.

[Deleted]  

Dear Mrtools,

THanks a lot !

mandagozu81
182
mandagozu81  
mladen:
mandagozu81

Here is this version

A couple of explanations. First of all, this version will not work on older metatrader builds (it must be used on newer metatrader 4). Also the parameters are the same as for the indicator itself (meaning : there is a phase and the risk parameter included too in the list of parameters, that way all the parameters of the indicators can be customized). The order of parameters is the same as in the indicators parameters. And, finally, I decided to use the external indicator for one reason : this way there is no limit whatsoever how many indicators you can use to combine

________________

PS: volty channel stop indicator from this post must be used, otherwise it will not work

PPS: I tested it (build 610) but please test it too - on these new builds of metatrader 4 we never know what can happen

Thank you very much i downloaded them and at first glance they seem to work ok in the new built mt4.

I have a question though. I use previous built mt4 on one of my brokers cause i have indis that i currently use that doesn't work in the new built mt4.

Is it possible to have these indicators work on both the new and the old mt4 versions? If it is too complicated and a big hassle nevermind my question. Thank you!

Mladen Rakic
200846
Mladen Rakic  
mandagozu81:
Thank you very much i downloaded them and at first glance they seem to work ok in the new built mt4.

I have a question though. I use previous built mt4 on one of my brokers cause i have indis that i currently use that doesn't work in the new built mt4.

Is it possible to have these indicators work on both the new and the old mt4 versions? If it is too complicated and a big hassle nevermind my question. Thank you!

They can not be made to work on both builds without one having some issues with the compiler