Скачать MetaTrader 5
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Зарабатывай на сервисах MQL5. Это просто!
George Merts
3525
George Merts 2015.01.25 12:34 

Всех приветствую.

Сегодня у меня обновился терминал, и, какая радость, когда я запустил ТС в МТ5 на оптимизацию, у меня вместо моих привычных нескольких десятков потоков оптимизации - имеется только два на моих локальных ядрах.

Я понимаю, "необходимость следования развитию IT-индустрии", но, парк старых компьютеров еще очень широк, использовать их очень разумно, а так, получается, меня  "обрезали" по самое нехочу, и предлагают "переходить на 64х" ???

Вот, у меня мой компьютер (Core 2Duo, Win7, x32), и сеть, в которой только один компьютер немного мощнее, а остальная куча компьютеров, в основном на "четвертых" пнях и ВинХП. Раньше этот кластер неплохо справлялся с оптимизацией. Теперь же, получается, у меня только два моих ядра.

Хочется спросить у разработчиков - как они мне предлагают быть ? Как мне использовать имеющиеся вычислительные мощности ?

Как я понимаю, предлагается все компьютеры - скинуть в утиль ?

Не слишком ли смелое решение так резко отказаться от x32-архитектуры, когда еще в работе огромная куча x32-компьютеров ?

MetaQuotes
Админ
24884
Renat Fatkhullin 2015.01.25 13:09  
Да, мы отказываемся в удаленных и mql5 сети от 32 битных агентов.

32 битные тестеры можно использовать только в локальных расчетах.
George Merts
3525
George Merts 2015.01.25 13:16  
Renat:
Да, мы отказываемся в удаленных и mql5 сети от 32 битных агентов.

32 битные тестеры можно использовать только в локальных расчетах.

То есть, таким как я - вы ничего не предлагаете взамен ?

Очень жаль.

А где скачать старый терминал и как выключить автообновление в терминале ?

Vladimir Karputov
Модератор
42242
Vladimir Karputov 2015.01.25 13:19  
Laryx:

...

А как выключить автообновление в терминале ?

Уже ни один раз говорили - нет и не будет возможности отключить автообновление. В том числе связано это и с безопасностью.
George Merts
3525
George Merts 2015.01.25 13:25  
barabashkakvn:
Уже ни один говорили - нет и не будет возможности отключить автообновление. В том числе связано это и с безопасностью.


Хорошо, ну так, получается, что еще вчера прекрасно работающая система у меня враз перестала работать, и я никак не могу ее использовать !

Я не против прогресса, но  у меня нет возможности переходить на x64, и еще долго не будет, а главное - я не могу перевести на эту платформу компьютеры сети !

Блин, хоть предупредили бы... А так теперь - у меня, считай, на порядок уменьшилась скорость оптимизации... То, что я оптимизировал в течении пары часов - теперь потребует недели, при этом мой комп будет ужасно все это время тормозить...

Как, блин, некстати... До WLD я еще "не дорос", было так замечательно работать в МТ5... Эх...

Vadim Pyankov
276
Vadim Pyankov 2015.01.25 13:44  
Laryx:

То есть, таким как я - вы ничего не предлагаете взамен ?

Очень жаль.

А где скачать старый терминал и как выключить автообновление в терминале ?

Так локалка же работает, у меня основной 64 бит, на ноуте 32, норм он конектится и помогает, терминал 1060
Dmitriy Parfenovich
7643
Dmitriy Parfenovich 2015.01.25 13:45  
Laryx:

Всех приветствую. 

Вот сейчас проверил, если терминал х64, а агент(ы) х86, то все прекрасно работает.
Агент "не выпускал в сеть" (убрал все галочки клауда), чтоб не обновился и не отказался работать (возможно).

Значит Вам нужно обновить систему только под терминал х64. И будет счастье.

Victor Nikolaev
Модератор
14351
Victor Nikolaev 2015.01.25 14:07  
fyords:

Вот сейчас проверил, если терминал х64, а агент(ы) х86, то все прекрасно работает.
Агент "не выпускал в сеть" (убрал все галочки клауда), чтоб не обновился и не отказался работать (возможно).

Значит Вам нужно обновить систему только под терминал х64. И будет счастье.

Решение не совсем удачное.

Я например переустанавливаю систему раз в полгода. Сейчас стоит х32. До этого стояла х64.

И то что разработчики отказываются от 32-разрядной системы не есть хорошо, точнее очень, очень плохо. 

George Merts
3525
George Merts 2015.01.25 14:22  
fyords:
 

Значит Вам нужно обновить систему только под терминал х64. И будет счастье.

Да, придется так и сделать.

Но, судя по всему, разработчики и агенты собираются переводить на x64 - а это уже плохо.

Предлагаю набрать хоть какую-то статистику, много ли пользователей используют исключительно x64 ?

Я не вижу особых проблем с переносимым кодом. Еще в конце 90х годов я работал в одной конторе, и требования к коду совершенно четко требовали работы как на 16-разрядных так и на 32 разрядных системах. Все нормально писалось, там где системы были слишком разными - использовались дефайны...  Сейчас я пишу код, который совершенно без изменений компилируется как под МТ5, так и под МТ4... Неужели у разработчиков возникла настолько серьезная необходимость перейти на x64 ?

Какие преимущества получают при этом пользователи ?

George Merts
3525
George Merts 2015.01.25 15:05  

Не собирался обновлять систему, но, по идее, я могу это сделать.

Однако, на сетевых компьютерах - еще долго останется ВинХП x32.  Не хотелось бы лишиться их мощности в вычислениях.

Поэтому такой вопрос разработчикам - сколько примерно еще будут актуальны x32 агенты ?

MetaQuotes
Админ
24884
Renat Fatkhullin 2015.01.25 22:27  

К сожалению, поддержка 32 битных тестеров явным образом ограничивает наше(разработчиков) будущее из-за обеспечения совместимости.

На текущий момент смысла поддерживать 32 битные платформы нет. Да, 32 клиентские терминалы все равно будут поддерживаться, но продвинутые сервисы будут только на современных платформах.

В 2015 году нужно переходить на x64 операционки и тем более забыть про XP. Если речь идет о серьезной работе.

/ /12345678...11
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий