Discussão do artigo "MetaTrader 5 no Linux"

Para adicionar comentários, por favor Faça o login ou registrar
MetaQuotes
Moderador
221010
MetaQuotes  

Novo artigo MetaTrader 5 no Linux foi publicado:

O Linux é um sistema operacional de computador parecido com o Unix, instalado com base em um modelo de desenvolvimento e distribuição de software gratuito e de fonte aberta. Os sistemas Linux são amplamente utilizados em smartphones e hardware de servidores. Muitos usuários de computadores preferem Linux à série MS Windows. Neste artigo, você descobrirá como trabalhar no MetaTrader 5 através de uma das versões do Linux - Ubuntu.

MetaTrader 5 no Ubuntu

Autor: MetaQuotes Software Corp.

Rodrigo Otavio Passos Ferreira
673
Rodrigo Otavio Passos Ferreira  
MetaQuotes:

Novo artigo MetaTrader 5 no Linux foi publicado:

Autor: MetaQuotes Software Corp.

Desde a ultima atualização, o metatrader parou de funcionar no meu linux (com wine), ao abrir o editor de código, aparece uma mensagem informando que ocorreu um erro inesperado e terá que ser fechado. Não estou mais conseguindo utilizar ele, uso o ubuntu 14.04 e Wine 1.6.2 sempre funcionou mas parou de funcionar.. alguem teve esse tipo de problema. 

Salomão Ferreira
106
Salomão Ferreira  
Rodrigo Otavio Passos Ferreira:

Desde a ultima atualização, o metatrader parou de funcionar no meu linux (com wine), ao abrir o editor de código, aparece uma mensagem informando que ocorreu um erro inesperado e terá que ser fechado. Não estou mais conseguindo utilizar ele, uso o ubuntu 14.04 e Wine 1.6.2 sempre funcionou mas parou de funcionar.. alguem teve esse tipo de problema. 

Ele não para necessariamente de funcionar, continua funcionando mas com a mensagem de erro em aberto.

Percebi que o metatrader apresenta esse erro quando o linux é 64bits, mesmo sendo emulado pelo wine num ambiente o instalador identifica o ambiente 64bits e baixa a versão para a arquitetura, basicamente o meta de 64bits dá esse problema.

 

Instale om metatrader em um ambiente windows de 32bits (xp, win7, win8, win10) depois de instalado vá em arquivos de programas 32bits, copie e cole toda a pasta no linux com o wine já instalado, execute o terminal.exe (sem precisar refazer a instalação do metatrader no wine).

Ele irá executar normalmente sem erros.

Thiago Ferreira
2233
Thiago Ferreira  
Eu acredito que já esteja na hora de ser feito a MT5 também para Linux, pelo menos para Ubuntu, sem precisar a recorrer a gambiarras. Eu já estou cansado dos travamentos do Windows, e pensando em migrar para o Linux. Dará mais trabalho mas poderá ser uma boa opção.
Thiago Ferreira
2233
Thiago Ferreira  

Olá novamente a todos!

Para mim eu deu certo a instalação. Esta funcionando corretamente pelo Wine. Instalei a ultima versão do Wine como instruído pelo site oficial, através do Terminal de comandos, e não pela "Central de Aplicativo" Ubuntu.

Mas estou tendo um pequeno problema: Não consigo adicionar os meus EAs na pasta Expert, dentro da "Pasta de Dados" aberta através da plataforma. Pesquisei em "Arquivos" mas não consigo localizar a pasta Wine onde se localiza os dados da MT5.

Alguém saberia me dizer como eu faço para adicionar os meus EAs e indicadores dentro do MT5?

Thiago Ferreira
2233
Thiago Ferreira  
Thiago Ferreira:

Olá novamente a todos!

Para mim eu deu certo a instalação. Esta funcionando corretamente pelo Wine. Instalei a ultima versão do Wine como instruído pelo site oficial, através do Terminal de comandos, e não pela "Central de Aplicativo" Ubuntu.

Mas estou tendo um pequeno problema: Não consigo adicionar os meus EAs na pasta Expert, dentro da "Pasta de Dados" aberta através da plataforma. Pesquisei em "Arquivos" mas não consigo localizar a pasta Wine onde se localiza os dados da MT5.

Alguém saberia me dizer como eu faço para adicionar os meus EAs e indicadores dentro do MT5?

RESOLVIDO!

Consegui!

Basta ir em Arquivos, apertar ctrl+H para mostrar arquivos ocultos. Depois basta acessar a pasta .wine/drive_c/Program Files/MetaTrader 5 - ActivTrades/MQL5/Experts/Advisors e adicionar os experts.

Somente por ai que eu consegui instalar os EAs. Pela plataforma MT5, através de Abrir Pastas de Dados não é possível, infelizmente.

Thiago Ferreira
2233
Thiago Ferreira  
Vejo também que os testes através do "Testador de Estratégias" só vai até H12.
Thiago Ferreira
2233
Thiago Ferreira  
Thiago Ferreira:
Vejo também que os testes através do "Testador de Estratégias" só vai até H12.
Descobri que Isso não é um problema. Agora apareceu. Apenas rolei o botão do meio do mouse clicando em cima da seleção do TimeFrame que me apareceu todos.
rafaelceschini
5
rafaelceschini  
Olá, possuo o Mint 17.3, com Wine 1.6, e não consegui instalar nem o MT 4 e nem o 5. Aparece uma mensagem pedindo o servidor, nome de, e contra senha. Sem estas informações não consigo terminar de instalá-los. Alguém sabe o que falta eu fazer? Obrigado.
Thiago Ferreira
2233
Thiago Ferreira  
rafaelceschini:
Olá, possuo o Mint 17.3, com Wine 1.6, e não consegui instalar nem o MT 4 e nem o 5. Aparece uma mensagem pedindo o servidor, nome de, e contra senha. Sem estas informações não consigo terminar de instalá-los. Alguém sabe o que falta eu fazer? Obrigado.

Olá Rafael. Também estou com o mesmo problema!

Hoje eu formatei e instalei o Ubuntu 15.10, instalei o Wine da Central de Programas do Ubuntu e me apareceu esta mensagem. Será devido a arquitetura 64 bits.?

Thiago Ferreira
2233
Thiago Ferreira  
Bom... tentei instalar a MT4, que é para arquitetura 32 bits, mas mesmo assim aparece a seguinte mensagem pedindo o servidor.
12
Para adicionar comentários, por favor Faça o login ou registrar