Indicators with alerts/signal - page 580

zilliq
352
zilliq  

Thanks a lot Mr Tools

But sorry there is always the same problem as you can see on the picture

I just put the indicator on a graph and change nothing else the cross arrow in the OB/OS zone (all other parameters are by default)

Perhaps you can try : DAX in 1 minute STO 5,3,3 (JMA len8)

Some arrows appear but some not

Thanks for your help

Regards and have a nice day

Zilliq

Ps: I will try with the cross arrows between the OB/OS zone

Files:
zilliq
352
zilliq  

Yes same problems between the OB/OS zone

DAX ut1minute STO 5,3,3

Thanks Mr Tools

Zilliq

Files:
zilliq
352
zilliq  

I don't find any problem with the cross who show when the %K leave the OB/OS zone

Thanks a lot

Zilliq

zilliq
352
zilliq  

One idea,

Perhaps it can help you Mr Tools

When I test the indicator in the test mode (DAX 1 minute 8,3,3 (to try),

The arrows on the graph with price appear, and some candle after, they diseappear, and appear and so on, like a repainting, but the graph of the STO doesn't change at any time

Thanks

Zilliq

Mladen Rakic
154594
Mladen Rakic  
zilliq:
One idea,

Perhaps it can help you Mr Tools

When I test the indicator in the test mode (DAX 1 minute 8,3,3 (to try),

The arrows on the graph with price appear, and some candle after, they diseappear, and appear and so on, like a repainting, but the graph of the STO doesn't change at any time

Thanks

Zilliq

That (that some candles back the arrows appear and disappear) is usually a sign of repainting. I am not sure, but if the jurik calculation used in that indicator is a starlight version, as far as I remember that version was repainting. Will check it too but maybe the better idea would be to use the JMA Nikolay Kositsin wrote (at this thread https://www.mql5.com/en/forum/173010 ) or some other one

William Snyder
9492
William Snyder  
zilliq:
One idea,

Perhaps it can help you Mr Tools

When I test the indicator in the test mode (DAX 1 minute 8,3,3 (to try),

The arrows on the graph with price appear, and some candle after, they diseappear, and appear and so on, like a repainting, but the graph of the STO doesn't change at any time

Thanks

Zilliq

Zilliq, like Mladen said that version repaints badly, worked on adding the alerts and arrows on the other version, and looks like the same problem.

zilliq
352
zilliq  

Hi Mladen and Mr Tools,

I will try later when I will be back from my work, but if I remember this STO JMA doesn't repaint, the graph of the STO JMA never change/repaint in the test mode in one minute. In 15 minutes that I use I never see a change of the STO JMA. And the arrow appear and disappear many many candle before and not all arrows, may be one or two. I think it's more a problem with the test mode (I see different bugs with the test mode with different indicator), than a problem of repainting

One other thing : If this STO JMA repaints (I don't think so, but I'm not 100 % sure ), we should see a "repainted" arrow on the price graph but there are no arrows at all.

See you later and I will try, thanks to you masters of indicators

Zilliq

Ps: I find the sto JMA on this post

https://www.mql5.com/en/forum/177239

William Snyder
9492
William Snyder  
zilliq:
Hi Mladen and Mr Tools,

I will try later when I will be back from my work, but if I remember this STO JMA doesn't repaint, the graph of the STO JMA never change/repaint in the test mode in one minute. In 15 minutes that I use I never see a change of the STO JMA. And the arrow appear and disappear many many candle before and not all arrows, may be one or two. I think it's more a problem with the test mode (I see different bugs with the test mode with different indicator), than a problem of repainting

One other thing : If this STO JMA repaints (I don't think so, but I'm not 100 % sure ), we should see a "repainted" arrow on the price graph but there are no arrows at all.

See you later and I will try, thanks to you masters of indicators

Zilliq

Ps: I find the sto JMA on this post

https://www.mql5.com/en/forum/177239

Zilliq, when you get a chance to test, this version of the indicator will draw all your signals where you want them, the Analyzer indicator will take a picture of every bar, so if your on a 1 minute chart it will take a picture every minute and place them in experts/files, hopefully that will help, in your testing.

zilliq
352
zilliq  

Thanks a lot Mr Tools

I will try it,

I think I find (a piece of) the solution: This is the bar close (I think)

I confirm that in test/visual mode the indicator doesn't repaint and the arrows doesn't too.

The arrow appear and disappear only in the last candle (it's normal because the signals/arrows are in real time), because during the frame (1 minute for example), at one moment the signal can be good (cross of % K and % D in the OB/OS for example), but some seconds after it could'nt be good (there is no cross) (sorry for my french/english...). And so, when there is different change appear/disappear/ different signals/ sometimes at the close there is no more signals. Perhaps there is some interaction between signals (if there are 2 signals all disappear). So I think that if the arrows/signals ppear only on bar close it could be good.

I let my template for the visual mode if you want to see

Thanks a lot (we will succeed )

Zilliq

https://mon-partage.fr/f/PP1kQvMI/

zilliq
352
zilliq  

Another think I see (I use your last version 1.03),

It seems there are effectively some conflicts between the arrows/signals

And notably some problem with the arrows/signal between the OB/OS zone

As you see, sometimes there is a point/signal but not cross on the STO JMA graph, and so there is no cross OBOS signal

=Instead of seeing 2 signals there are no signals/arrows

May it can help you

Thanks a lot

Zilliq

Files: