Elite indicators :) - page 692

Mladen Rakic
151107
Mladen Rakic  
traderduke:
Mladen

I guess I'm going to push my luck and ask another question. I'm unable to backtest renko. The steps are:

1. I run a script that changes 1M data to 5M Renko data

2. I retrieve the 5M offline chart and by some miracle

3. placing the Strategy Tester period on 5M it uses the 5M renko chart for the test.

Well that don't work any more. Steps 1 & 2 seem OK but 3 is not working, any ideas the script that has worked in 509 is below.

Thanks

Ray

Ray

That script is writing old history file format. Did you try producing renko charts with some of the indicators from this thread : https://www.mql5.com/en/forum/183798 and then using it for that kind of backtest?

Hercs
2970
Hercs  
mladen:
ValeoFX Separate gap (displacement) added for lower and upper arrows. Try it out

=============

Mladen, sorry to be a nuisance, but this indicator does not have the adjustments on it?

traderduke
531
traderduke  
mladen:
Ray That script is writing old history file format. Did you try producing renko charts with some of the indicators from this thread : https://www.mql5.com/en/forum/183798 and then using it for that kind of backtest?

Mladen

The above script is working on M5 and it backtest with no trouble ???????

The only change I made to the process is the "/portable" addition. The indicators load on the M1 but no comment on the M1 chart & no M5 offline available. When I change it to M4 or any other non standard chart , it works?? The rules are getting a little fuzzy.

Bottom line is that the only renko that can be backtested is still SCRIPTS ONLY.

Thanks

Ray

Mladen Rakic
151107
Mladen Rakic  
ValeoFX:
============= Mladen, sorry to be a nuisance, but this indicator does not have the adjustments on it?

Don't know how it happened (working with this new metatrader and new metaeditor seems to have some rules of its own). Here is a version with those gaps

Files:
Mladen Rakic
151107
Mladen Rakic  
traderduke:
Mladen

The above script is working on M5 and it backtest with no trouble ???????

The only change I made to the process is the "/portable" addition. The indicators load on the M1 but no comment on the M1 chart & no M5 offline available. When I change it to M4 or any other non standard chart , it works?? The rules are getting a little fuzzy.

Bottom line is that the only renko that can be backtested is still SCRIPTS ONLY.

Thanks

Ray

Ray

What I think is the following : when you run that script it will run in a "compatibility mode" but when you try to back-test, back test will expect a new history file format not the old one (that is produced by that script) and that is why you can not use it any more in that way

Mladen Rakic
151107
Mladen Rakic  

Ray

Did you try that kind of a back-test with renko mean live chart (one posted here : https://www.mql5.com/en/forum/183798/page12 ) ? Renko mean allows generating of a 5 minute offline data (unlike the renko live chart) so it could be a possible solution to test if the back test will work using the data generated by renko mean (and if the problem is in the old format of offline data generated by that script

Hercs
2970
Hercs  
mladen:
Don't know how it happened (working with this new metatrader and new metaeditor seems to have some rules of its own). Here is a version with those gaps

Good morning Mladen,

Thank you again very much.

Continued success to you.

Hercs
2970
Hercs  
mladen:
Don't know how it happened (working with this new metatrader and new metaeditor seems to have some rules of its own). Here is a version with those gaps

Sorry to be an absolute annoyance by now Mladen, but it is still not the indicator with your changes.

Mladen Rakic
151107
Mladen Rakic  
ValeoFX:
Sorry to be an absolute annoyance by now Mladen, but it is still not the indicator with your changes.

This is becoming ridiculous : I make changes in the code and then they are lost somewhere. And now this bloody thing will not work in build 604. Must see what the hell is going on

Mladen Rakic
151107
Mladen Rakic  

Here is a version with gaps. It does not work with new builds of metatrader 4 - I have no idea why does it not work with build 604 - no error messages, no compile errors, nothing. Simply : new metatrader 4. It works with build 509