Скачать MetaTrader 5

Будем отключать с 1 апреля 2015 года старый движок виртуальной машины MQL4, использовавшийся для билдов старее 600?

Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Все статьи доступны из MetaTrader 5. Поделись и ты своей!
MetaQuotes
Админ
24946
Renat Fatkhullin 2015.02.05 14:24 
  • 49%
    (72)
  • 10%
    (15)
  • 8%
    (12)
  • 33%
    (48)
Всего проголосовало: 147
MetaQuotes
Админ
24946
Renat Fatkhullin 2015.02.05 14:30  

В текущих билдах MetaTrader 4 у нас используются два разных движка виртуальной машины MQL4:

  1. Старый движок для билдов ниже 600, с медленным исполнением. Только для совместимости
  2. Новый движок для 600+ билдов, с новой защитой, новым функционалом из MQL5, поддержкой маркета и быстрее старого в 4 и более раз

Прошел год с выпуска 600 билда, мы хорошо справились с поддержкой совместимости старых программ и сейчас пришла пора отказаться от старого движка.

Просим всех высказать свое мнение по опросу.

MetaQuotes
Админ
24946
Renat Fatkhullin 2015.02.05 14:33  

Мы продолжаем разработки компилятора MQL5 и уже в тестах новая версия, которая еще в несколько раз быстрее текущей реализации за счет нового оптимизатора кода.

Этот компилятор будет доступен в MetaTrader 5.

Roman Busarov
5936
Roman Busarov 2015.02.05 14:34  
тоесть, все кто работает на терминалах МТ4 ниже 600 билда, использование программ станет не возможным? (просто не много не понял, уточняю )
Andrei Fandeev
18176
Andrei Fandeev 2015.02.05 14:47  

Вангую : Работки фрилансерам прибавится резко )))

А по теме - Разработчикам как никому другому известны все нюансы подобного решения, и советоваться с юзерами не вижу смысла.

Nikolay Demko
12465
Nikolay Demko 2015.02.05 14:51  
AndreiFAN:

Вангую : Работки фрилансерам прибавится резко )))

А по теме - Разработчикам как никому другому известны все нюансы подобного решения, и советоваться с юзерами не вижу смысла.

Разработчики уже приняли решение, просто теперь хотят понять своевременное ли оно.
Dmitry Fedoseev
42887
Dmitry Fedoseev 2015.02.05 14:56  

очередной абзац

Дата отлично выбрана - 1-е апреля. Чтобы сразу и не осознать маштабность события. 

MetaQuotes
Админ
24946
Renat Fatkhullin 2015.02.05 15:00  
Myth63:
тоесть, все кто работает на терминалах МТ4 ниже 600 билда, использование программ станет не возможным? (просто не много не понял, уточняю )

Ниже 610 билда МТ4 уже никто не поддерживается с лета 2014 года.

Скорее всего с 1 апреля 2015 отключим поддержку серверов ниже 645 и терминалов 645.

Roman Busarov
5936
Roman Busarov 2015.02.05 15:02  
Renat:

Ниже 610 билда МТ4 уже никто не поддерживается с лета 2014 года.

Скорее всего с 1 апреля 2015 отключим поддержку серверов ниже 645 и терминалов 645.

всё, дошло до меня=) отключайте =)
Andrey F. Zelinsky
31307
Andrey F. Zelinsky 2015.02.05 15:11  

В опросе нет важного пункта: "не понимаю о чём речь".

Потому что читатели разделятся строго на две категории -- те кто понимает о чём опрос и им без разницы -- и те кто не понимает о чём опрос и им тоже без разницы.

Dmitry Fedoseev
42887
Dmitry Fedoseev 2015.02.05 15:13  
abolk:

В опросе нет важного пункта: "не понимаю о чём речь".

Потому что читатели разделятся строго на две категории -- те кто понимает о чём опрос и им без разницы -- и те кто не понимает о чём опрос и им тоже без разницы.

Еще одна категория - те кто думает, что поняли, но не поняли.
12345678...17
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий