Loading custom indicators failed

To add comments, please log in or register
Bilal Said
506
Bilal Said  

Hi guys,i'm having a new problem to load custom indicators.


when i try to add a new indicator to my chart,i get this error:

errors


i have no idea why i'm getting it ,previously it was working and now nothing is working,but i haven't did any modification.

This problem is with all metatrader 5 installed in my computer.

(Real account and demo account)


Thanks for help,someone have a idea ?

Nguyen Nga
14309
Nguyen Nga  
let check your code or your indicator expired.
DigiM29
25
DigiM29  

Same issue here, it fails even on included scripts with fresh install.

I tried three different builds (1586, 1583, 1571, 64-bit) on clean installs. I erased user settings and recompiled scripts, yet all scripts and EAs fail to load. Automatic trading and DLL loading are both enabled.

The issue appeared suddenly; I had made no changes on my regular install and all scripts just stopped working.

MT4 continues to work fine, though I'm on an old build 1065. It's worth noting this isn't the right forum for an MT5 issue.

I submitted a ticket to the service desk.

Peter Hristov
1988
Peter Hristov  

Hi fellows


i have the same problem


after the last windows 10 update cerators, fails MT5 to load indicators, advisors , experts, everything!

New fresh installation from difeferent Brokers have no effect, installation directly from MetaQuotes, all fail!

Do someone know what a hell is going on with this fu..ing windows and how we can fix the problem  ?


Ist not the code or something else, i have tried with advisors from example or indicators from standart isntallation or from download from here.

nothing is working! I have real accounts Im trading now and nothing is working


What a mess!

Sergey Golubev
Moderator
106163
Sergey Golubev  

The only announcement I found is this one:

Attention: Windows 10 Creators Update to make saved MetaTrader passwords invalid

On the 11th of April, Microsoft will release the Windows 10 Creators Update, after which the Windows version will be completely updated. In fact, this update is similar to installing a new operating system, because it will change configurations and encryption keys. The MetaTrader platform uses data binding to an operating system and hardware, in order to protect traders' data. This binding means that even if the platform files are stolen, thieves will not be able to connect to the trader's account or use products purchased from the Market.

Unfortunately, after the operating system change caused by the installation of the Windows 10 Creators Update, all the trading account passwords stored on your computer will become invalid. We highly recommend that you prepare for the new Windows release and save your passwords in a safe place, in order to be able to connect to your accounts after the update.

In addition, due to the change of encryption keys, one activation of applications purchased from the Market will be lost, because all products are bound to an operating system. We will automatically add one activation for each purchased product, regardless of the operating system, similar to the activations that we added after the Windows 10 update from version 1511 to 1607. It means that you will not lose your product activations after the release of the Windows 10 Creators Update.

Activations of demo products will also be lost, you will need to re-download such applications from the Market.

And this is the reply of the admin:

Forum on trading, automated trading systems and testing trading strategies

Attention: Windows 10 Creators Update to make saved MetaTrader passwords invalid

Rashid Umarov, 2017.04.10 18:03

For each activation on PC with Windows 10 will be added 1 free extra activation. So by that no one activation will be lost.
Peter Hristov
1988
Peter Hristov  
Sergey Golubev:

The only announcement I found is this one:

Attention: Windows 10 Creators Update to make saved MetaTrader passwords invalid

On the 11th of April, Microsoft will release the Windows 10 Creators Update, after which the Windows version will be completely updated. In fact, this update is similar to installing a new operating system, because it will change configurations and encryption keys. The MetaTrader platform uses data binding to an operating system and hardware, in order to protect traders' data. This binding means that even if the platform files are stolen, thieves will not be able to connect to the trader's account or use products purchased from the Market.

Unfortunately, after the operating system change caused by the installation of the Windows 10 Creators Update, all the trading account passwords stored on your computer will become invalid. We highly recommend that you prepare for the new Windows release and save your passwords in a safe place, in order to be able to connect to your accounts after the update.

In addition, due to the change of encryption keys, one activation of applications purchased from the Market will be lost, because all products are bound to an operating system. We will automatically add one activation for each purchased product, regardless of the operating system, similar to the activations that we added after the Windows 10 update from version 1511 to 1607. It means that you will not lose your product activations after the release of the Windows 10 Creators Update.

Activations of demo products will also be lost, you will need to re-download such applications from the Market.

And this is the reply of the admin:


The problem is, i dont have any purchased products, everything is free or writen from me !

The only thing that is working now is the login to my real account. I can log in with the credentials, so passwords are working.

But m ysystems are aoutomated and all indicators and exprets  are not working.

DigiM29
25
DigiM29  

I'm getting this issue on Windows 10 Creators Update, 64-bit.

Worth noting this issue does not occur for me on Windows 10 Anniversary Update (version 1607), the previous update from July 2016.

The other thread on the subject has more reports -- for whatever reason, it's moved to the Expert Advisors forum.

https://www.mql5.com/en/forum/190449

MT5 Build 1586 (19 April 2017) - Strategy Tester/Journal - Moving Average.ex5 failed
MT5 Build 1586 (19 April 2017) - Strategy Tester/Journal - Moving Average.ex5 failed
  • www.mql5.com
Hi there, I recently installed a new MT5 software and I am getting the following error messages: Toolbox/Experts - loading Moving Average failed St...
Bilal Said
506
Bilal Said  
DigiM29:

Same issue here, it fails even on included scripts with fresh install.

I tried three different builds (1586, 1583, 1571, 64-bit) on clean installs. I erased user settings and recompiled scripts, yet all scripts and EAs fail to load. Automatic trading and DLL loading are both enabled.

The issue appeared suddenly; I had made no changes on my regular install and all scripts just stopped working.

MT4 continues to work fine, though I'm on an old build 1065. It's worth noting this isn't the right forum for an MT5 issue.

I submitted a ticket to the service desk.

Peter Hristov:

The problem is, i dont have any purchased products, everything is free or writen from me !

The only thing that is working now is the login to my real account. I can log in with the credentials, so passwords are working.

But m ysystems are aoutomated and all indicators and exprets  are not working.


Exactly,same problem here !,if you find a solution please dont forget to help me.

Peter Hristov
1988
Peter Hristov  
Bilal Said:

Exactly,same problem here !,if you find a solution please dont forget to help me.

I think Meta Quotes must solve  the problem reading or loading files from those directories, something goes wrong with the folder rights or something else.

and the whole windows world can not load the experts right now :)

just a perfect joke from microsoft but unfortunately is not 1st april :)

Luciano Fagundes
25
Luciano Fagundes  
Same problem here... Any workaround or ideas on how to get it working again ?
Icham Aidibe
11286
Icham Aidibe  
Luciano Fagundes:
Same problem here... Any workaround or ideas on how to get it working again ?

Same. I tried to contact the service desk but error sending message too.

Files:
Capture.PNG 19 kb
Capture2.PNG 2 kb
To add comments, please log in or register