• 概述
  • 评论
  • 评论 (7)
  • 新特性

Multicurrency Candlesticks

Description

Candlesticks is a colored multicurrency/multy-symbol indicator. It shows a financial instrument as a candlestick chart in a separate window below the chart of the main financial symbo.

The indicator may be used with any broker, irrespective of the name of the financial instrument since it is necessary to manually enter the name as an input parameter. If you enter a non-existent or incorrect name of a financial instrument, you will receive an error message that this financial instrument is unknown (does not exist). 

You can set the number of displayed candlesticks, as well as select bullish and bearish coloring.


Purpose

The indicator may be used as a visual tool for the intermarket analysis (convergence and/or divergence), as well as for detecting quoting holes as illustrated in the attached screenshots.


Inputs

  1. Currency_Name - the name of the financial instrument.
  2. Bars_Number - the number of bars to be displayed in a separate window.
  3. Bars_Flag - a flag to allow display of the number of bars specified in the Bars_Number parameter:
    1. true - according to Bars_Number.
    2. false - maximum available bars in the history. 
  4. Bulls_Color - the color of the bullish candlestick.
  5. Bears_Color - the color of the bearish candlestick.
  6. Bid_Line_Color - color of the Bid line.


Limitations

Chart for each financial instrument can not be displayed more than once. Otherwise, you receive an error message related to its re-use and will be offered to select another financial instrument.


Recommendations

It is recommended to use the indicator with the parameter Bars_Number not exceeding the number of bars that can be shown in one window (about 250 bars).


Notes

In case of loss of connection with the trading server, when connection is restored and data is downloaded, the chart will be redrawn from the beginning to the number of bars specified by Bars_Number and Bars_Flag.

无评论
版本 1.25 - 2017.03.28
Update in accordance with requirements of the latest version of MetaEditor.
版本 1.24 - 2014.10.31
Update in accordance with requirements of the latest version of MetaEditor.