OpenCL: внутренние тесты реализации в MQL5 - страница 14

Andrey Dik
13255
Andrey Dik  
tol64:

Да, я видел... Там на вкладке "Поддерживаемые продукты" написано следующее:

То есть, не поддерживается... 

То есть, не поддерживаются почти все мобильные версии чипов? :D

Вы не правильно читаете, нужно читать так:

"Данный драйвер может быть установлен на следующих GPU за исключением некоторых ноутбуков, перечисленных в списке ниже:"

Похоже, забыли запятую поставить после слова GPU.

Anatoli Kazharski
34110
Anatoli Kazharski  
joo:

То есть, не поддерживаются почти все мобильные версии чипов? :D

Вы не правильно читаете, нужно читать так:

"Данный драйвер может быть установлен на следующих GPU за исключением некоторых ноутбуков, перечисленных в списке ниже:"

Похоже, забыли запятую поставить после слова GPU.

))) Вы так смело вычеркнули пол предложения, что мне всё таки придёться установить последний драйвер "напролом", чтобы окончательно выяснить этот вопрос.
Andrey Dik
13255
Andrey Dik  
tol64:
))) Вы так смело вычеркнули пол предложения, что мне всё таки придёться установить последний драйвер "напролом", чтобы окончательно выяснить этот вопрос.
В крайнем случае драйвер просто не захочет ставится, если не найдет подходящего устройства. Так что ставьте, ничего страшного не случится точно.
Anatoli Kazharski
34110
Anatoli Kazharski  
joo:
В крайнем случае драйвер просто не захочет ставится, если не найдет подходящего устройства. Так что ставьте, ничего страшного не случится точно.
У меня до этого стоял 280 драйвер. И когда я увидел в списке не поддерживаемых видеокарт этого драйвера свою карту, то нашёл самый последний драйвер (197), где моя карта не перечислена и переустановил драйвер думая, что это глюк неподдерживаемого моей картой драйвера. Не помогло.
Anatoli Kazharski
34110
Anatoli Kazharski  

Установил последний (285.62) драйвер. Все оказались правы кроме меня (не правильно трактовал список ограничений). :)

При загрузке MT5 вижу следующее: 

MN 0 Terminal 05:06:06 MetaTrader 5 x64 build 586 started (MetaQuotes Software Corp.)
QI 0 Terminal 05:06:11 GPU: NVIDIA Corporation GeForce 9600M GT with OpenCL 1.0 (4 units, 1250 MHz, 512 Mb, version 285.62)

Затем скачал и установил с сайта Intel вот такой софт:  http://software.intel.com/en-us/articles/download-intel-opencl-sdk/

Запустил файл iocgui64.exe. В меню заходим в Tools => Build и получаем такую информацию:

 

Далее с помощью утилиты OpenCl-Z убеждаемся, что процессор в выпадающем списке есть (до этого у меня не было):

 

Перезагружаю MT5 и вижу:

MN 0 Terminal 05:06:06 MetaTrader 5 x64 build 586 started (MetaQuotes Software Corp.)
QI 0 Terminal 05:06:11 GPU: NVIDIA Corporation GeForce 9600M GT with OpenCL 1.0 (4 units, 1250 MHz, 512 Mb, version 285.62) 

 Процессора нет. Пробую запустить скрипт представленный в начале ветки и также ничего. Не получилось. 

Dmitry Fedoseev
55115
Dmitry Fedoseev  
tol64:

Установил последний (285.62) драйвер. Все оказались правы кроме меня (не правильно трактовал список ограничений). :)

При загрузке MT5 вижу следующее: 

Затем скачал и установил с сайта Intel вот такой софт:  http://software.intel.com/en-us/articles/download-intel-opencl-sdk/

Запустил файл iocgui64.exe. В меню заходим в Tools => Build и получаем такую информацию:

 

Далее с помощью утилиты OpenCl-Z убеждаемся, что процессор в выпадающем списке есть (до этого у меня не было):

 

Перезагружаю MT5 и вижу:

 Процессора нет. Пробую запустить скрипт представленный в начале ветки и также ничего. Не получилось. 

 

У вас версия OpenCL 1.0. Обещали работать только начиная с 1.1. 

У меня тоже 1.0, не работает, нужно новую карту наверно.

Может кто порекомендует карту, чтобы с гарантией и без проблем? 

Anatoli Kazharski
34110
Anatoli Kazharski  
Integer:

У вас версия OpenCL 1.0. Обещали работать только начиная с 1.1. 

У меня тоже 1.0, не работает, нужно новую карту наверно.

Может кто порекомендует карту, чтобы с гарантией и без проблем? 

У Андрея (joo) работает 1.0. Вот, посмотрите здесь. Я почему надежду и не оставляю. Может ещё получится. :)
Ilyas
1400
Ilyas  
Если при компиляции EX5 явно была указана версия OpenCL как 1.0, то поддерживаться будет, без указания версии (по умолчанию) поддержка будет с 1.1

На данный момент контроля версии нет.
Ilyas
1400
Ilyas  
tol64:
У Андрея (joo) работает 1.0. Вот, посмотрите здесь. Я почему надежду и не оставляю. Может ещё получится. :)
Скорее всего Ваша карта не может работать с рабочим массивом 512*512, попробуйте уменьшить до 256*256
Vladimir Gomonov
8295
Vladimir Gomonov  
Integer:

У вас версия OpenCL 1.0. Обещали работать только начиная с 1.1. 

У меня тоже 1.0, не работает, нужно новую карту наверно.

Может кто порекомендует карту, чтобы с гарантией и без проблем? 

Если ориентирован на OpenCL - бери Radeon.  NVidia не торопится (и не будет торопиться) прогрессировать в разработке дров под последние версии OpenCL.

У них стимула нету - свою Куду продвигают.  Вечером (если надо) кину ссылку на обсуждение "етих безабразных фактаф".