New MetaTrader 4 Platform build 1090 - page 5

To add comments, please log in or register
whroeder1
17925
นวนิตย์ จุลนันทร์
9
นวนิตย์ จุลนันทร์  
DBLOUNT5:

I've noticed the folders have been moved around.

I downloaded mt4 from xm because it's the easiest way to get it for my Mac.

I cannot locate my MQL4 folder. I'm trying to add custom indicators. On Mac you cannot go to file - open data folder etc

I go to Finder > XM > show package contents > Contents > Resources > Wine Prefix > drive_c > Program Files >XM MT4   Then there's no MQL4 folder.


Anyone has insight about this? 

whroeder1
17925
whroeder1  
Se7enTrader
28
Se7enTrader  

Download fake file.
I tried to download the Metetrader4 platform several times from this link

https://download.mql5.com/cdn/web/metaquotes.software.corp/mt4/mt4setup.exe?utm_campaign=www.metatrader4.com

in this page -  https://www.metatrader4.com/en/trading-platform

and other one - https://www.metatrader4.com/en/download


Unfortunately the downloaded file is always the one of the MT5 although the file is called MT4setup.
Is all this normal or is it a mistake?

Where can i find the MT4's setup file?
Fernando Carreiro
4770
Fernando Carreiro  
Se7enTrader:

Download fake file.
I tried to download the Metetrader4 platform several times from this link

https://download.mql5.com/cdn/web/metaquotes.software.corp/mt4/mt4setup.exe?utm_campaign=www.metatrader4.com

in this page -  https://www.metatrader4.com/en/trading-platform

and other one - https://www.metatrader4.com/en/download


Unfortunately the downloaded file is always the one of the MT5 although the file is called MT4setup.
Is all this normal or is it a mistake?

Where can i find the MT4's setup file?
It has been stated here on the forum many, many times, that to download MT4 you have to download it from your broker and not from the MetaQuotes site.
aceTrad
9
aceTrad  

Sporadic error after upgrading to build 1090 from 1010 (on Windows 7): Cannot load custom indicator

I have been using an expert which invokes a custom indicator I have written. I run the expert on 20 different currency pairs within 1 instance of Metatrader on 1 minute chart. I have been running it for 2+ years, and it worked without a problem on build 1010. When I upgraded to build 1090 3 months ago, I recompiled the old MQL4 file in the new MetaEditor. The expert works smoothly for some time (from 3 hours to 2 days), but after that, starts showing an error 

"cannot load 'C:\Users\UserName\AppData\Roaming\MetaQuotes\Terminal\EC9D8D9041604A622918A76F04398973\MQL4\indicators\IndicatorName.ex4". If I restart Mt4, the expert again works smoothly for a few hours to a couple of days. 

Since the problem occurs only after running the expert for some time, one possibility I considered was that the error occurred on account of differences in memory management in build 1090 (versus build 1010). 

I also read here (https://www.mql5.com/en/forum/193992) that Windows 10 64 bit is strongly recommended - I am still on Windows 7. The documentation available for changes introduced between builds 1010 and 1090 is very sparse. I reached out to the Service Desk and also to Metaquotes via my broker (Oanda), giving specifics of the hardware I use as well,  but the responses received have not been specific enough to help me solve the problem. They did ask me to confirm that the processor supports SSE2, which it does, and to confirm that the hardware requirement was met. Response received from Metaquote also indicated that Windows 7 is supported. 

Please advise  if anyone else has encountered a similar error or faced other performance issues using build 1090 on Windows 7? Is switching to Windows 10 indeed 'strongly recommended'? 

Support for Windows XP/Windows 2003/Windows Vista to be discontinued after 01 October 2017
Support for Windows XP/Windows 2003/Windows Vista to be discontinued after 01 October 2017
  • 2017.06.01
  • www.mql5.com
Support for Windows XP/Windows 2003/Windows Vista to be discontinued after 01 October 2017 Windows XP was released almost 16 years ago, on 25th of...
AnthonyDavid
5
AnthonyDavid  

I was wondering how to use the Meta Trader 4 platform? It seems when I try to download the MT4 it gives me MT5 and I am not wanting MT5 is there someone who can help answer this question?

Fernando Carreiro
4770
Fernando Carreiro  
AnthonyDavid: I was wondering how to use the Meta Trader 4 platform? It seems when I try to download the MT4 it gives me MT5 and I am not wanting MT5 is there someone who can help answer this question?
Read two posts up from yours and you will find your answer!
BankRobbers
7
BankRobbers  

Ohhhh I'm so happy now, metatrader updated.... hahaha

aceTrad
9
aceTrad  
aceTrad:

Sporadic error after upgrading to build 1090 from 1010 (on Windows 7): Cannot load custom indicator

I have been using an expert which invokes a custom indicator I have written. I run the expert on 20 different currency pairs within 1 instance of Metatrader on 1 minute chart. I have been running it for 2+ years, and it worked without a problem on build 1010. When I upgraded to build 1090 3 months ago, I recompiled the old MQL4 file in the new MetaEditor. The expert works smoothly for some time (from 3 hours to 2 days), but after that, starts showing an error 

"cannot load 'C:\Users\UserName\AppData\Roaming\MetaQuotes\Terminal\EC9D8D9041604A622918A76F04398973\MQL4\indicators\IndicatorName.ex4". If I restart Mt4, the expert again works smoothly for a few hours to a couple of days. 

Since the problem occurs only after running the expert for some time, one possibility I considered was that the error occurred on account of differences in memory management in build 1090 (versus build 1010). 

I also read here (https://www.mql5.com/en/forum/193992) that Windows 10 64 bit is strongly recommended - I am still on Windows 7. The documentation available for changes introduced between builds 1010 and 1090 is very sparse. I reached out to the Service Desk and also to Metaquotes via my broker (Oanda), giving specifics of the hardware I use as well,  but the responses received have not been specific enough to help me solve the problem. They did ask me to confirm that the processor supports SSE2, which it does, and to confirm that the hardware requirement was met. Response received from Metaquote also indicated that Windows 7 is supported. 

Please advise  if anyone else has encountered a similar error or faced other performance issues using build 1090 on Windows 7? Is switching to Windows 10 indeed 'strongly recommended'? 


Apologies for following up on this. Has anyone faced issues using build 1090 on Windows 7? Windows 7 is officially supported, but per https://www.mql5.com/en/forum/193992 , Win 10 64 bit is strongly recommended. 

Thanks in advance

Support for Windows XP/Windows 2003/Windows Vista to be discontinued after 01 October 2017
Support for Windows XP/Windows 2003/Windows Vista to be discontinued after 01 October 2017
  • 2017.06.01
  • www.mql5.com
Support for Windows XP/Windows 2003/Windows Vista to be discontinued after 01 October 2017 Windows XP was released almost 16 years ago, on 25th of...
To add comments, please log in or register