Indicators with alerts/signal - page 975

Malle Simpson
150
Malle Simpson  
mrtools:
MWFstudent, not sure if i'll be much help here but the way I understand the mtf is for example if using the bands on a one hour chart, and say you are using bands period = 20 and set the mtf to H4 or 240, you are still looking at a 20 period band but on a 4 hour chart, that is why the difference.

Thanks I didnt relaize band length was equal to period on the standard bands.

This indicator will do wonders for me now.

alignat
56
alignat  

Dear mrTools, Mladen,

is it possible, add sound- and popup alert to arrows by this indicator on 0 and 1 bar separately, please.

Thanks in advance

William Snyder
9492
William Snyder  
Paul Atreides:
Dear mrTools, Mladen,

is it possible, add sound- and popup alert to arrows by this indicator on 0 and 1 bar separately, please.

Thanks in advance

Hello Paul Atreides, added the alerts on zero cross which is the same as when the arrows appear.

Albert Idrisov
734
Albert Idrisov  

Hello everyone, I'm a newbie here, I have a small request to the programmers, can you add arrows to these two indicators? when the arrow changes color indicators. Many thanks in advance and sorry for my English, I translate through translator)

SSL
27
SSL  

Hi mladen,

Greetings!

I have been noticing an issue with the indicator alerts for quite sometime now...

The indicators are missing to generate the alerts on the signals consistently... the signals come correctly, but the alerts on the signals are very inconsistent...(both, using current bar/closed bar)...! many a times there will be no alert even though a signal is generated...and especially when trading on reversals, the missing alerts leads to issues when trading live... meaning, the missing alerts are not doing what they are meant to on every signal/on a consistent basis...

I have extensively noticed this issue specially on the offline charts (range bars, renko-range bars, seconds charts)... and this issue is even more severe on faster moving markets/volatile times...

I have been testing & noticing this issue from previous build & current one/recent upgrade for a month now... the issue persists on as many instruments tested live/demo...

And to my surprise, EAs based on these indicators built using iCustom calls are also displaying the same issues...

To confirm this issue, I had put the indicator and the EA simultaneously, and whenever there is indicator signal & alert-the EA is taking trade instantly... and whenever there is indicator signal but NO Alert-the EA also is not taking trade...

and this issue is happening consistently with EA...

When using EAs based on these indis, this issue has to lead to many orphaned/unattended trades & losses and confusion on reversals and manual interventions...

Could this issue be fixed... so that there would be no missed alerts & trades on signals (manual trading)

And as for EAs based on these indis, I have no clue as to why this is a co-related issue...

please help fix this indicators with your experience & wisdom

Thanks a lot!

I have attached the indis that I tested...

Best Regards,

Mony

john jacob
135
john jacob  

hello mladen and mrtools,

you guys mind adding the alert on current option to this indi. thank you in advance.

rsi-alert.mq4

Files:
ayan2030
350
ayan2030  

mladen/mrtools can you please add an alert?

Files:
William Snyder
9492
William Snyder  
Alibydubby:
Hello everyone, I'm a newbie here, I have a small request to the programmers, can you add arrows to these two indicators? when the arrow changes color indicators. Many thanks in advance and sorry for my English, I translate through translator)

Alibydubby, this is the rsx with arrows.

William Snyder
9492
William Snyder  
johnjacob:
hello mladen and mrtools,

you guys mind adding the alert on current option to this indi. thank you in advance.

rsi-alert.mq4

Johnjacob, had to change it to our regular alerts to get it to work.

Files:
john jacob
135
john jacob  

thank you very much mrtools