Elite indicators :) - page 893

Mladen Rakic
151210
Mladen Rakic  
traderduke:
No it still doesn't change to next TF. I'm trying to use it in a dashboard with several TFs & I wanted it to be next TF from generated chart so if I pull a M15 chart the stoc would be M30 & I saw where you put the chart jump "+1" so I can even make a M15 chart "+2"for a M60. Neat concept. I have a "text comparison " program & I don't see any changes except for the> < for the trend, yes I know its backwards but it works better that way.

Thanks for trying

Ray

I was not changing that (but the way how it was displayed - since it was not OK)

For higher time frame simply comment out line 119

Hercs
2970
Hercs  

Hello Mladen,

I compiled another indicator into the latest Build only to find one Warning which is:

"arrays passed by reference only"

The code looks like this:

double FS30ver30(double ada_0[], int& ai_4) {

Please would you help me clearing this warning? The indicator is functioning, but I would prefer to have a clean code.

Thanking you most sincerely,

Mladen Rakic
151210
Mladen Rakic  
ValeoFX:
Hello Mladen,

I compiled another indicator into the latest Build only to find one Warning which is:

"arrays passed by reference only"

The code looks like this:

double FS30ver30(double ada_0[], int& ai_4) {

Please would you help me clearing this warning? The indicator is functioning, but I would prefer to have a clean code.

Thanking you most sincerely,

Change the line to this :

double FS30ver30(double& ada_0[], int& ai_4) {

But it is a benign warning (unlos the procedure/function changes data in the array and it should not - in that case, the function itself must be rewriten not to change the original array(s))

Kenneth Okalang
271
Kenneth Okalang  
mladen:
Boloti

This is the extended version of super trend that will alert you on trend change as well as ranging/trending periods : supertrend_nrp_alerts_nmc_2.mq4

____________________

You can set either of the alerts separately

Hi mladen

I wonder whether this can be corrected. sometimes the indicator alerts change in trend and yet the line remains horizontal. See attached eurusd chart. At 18.04 the message should have been 'started ranging'....in my opinion.

Thanks

Files:
Mladen Rakic
151210
Mladen Rakic  
Boloti:
Hi mladen

I wonder whether this can be corrected. sometimes the indicator alerts change in trend and yet the line remains horizontal. See attached eurusd chart. At 18.04 the message should have been 'started ranging'....in my opinion.

Thanks

Boloti

It happens when it is set to alert on a current (still opened bar) and when the price (and the slope of the super trend) reverts to horizontal. To avoid that, set the alertsOnCurrent to false, and it will alert on a closed bar where it can not happen (the slope of the closed bar can not be changed)

marijus321
71
marijus321  

Hello can u please add alarm on my chosen level alert please notification as well. ssrc.mq4

Files:
ssrc.mq4 7 kb
Kenneth Okalang
271
Kenneth Okalang  

mladen

Will try it out next week.

Have a nice weekend

Mladen Rakic
151210
Mladen Rakic  
MarioKam:
Hello can u please add alarm on my chosen level alert please notification as well. ssrc.mq4

MarioKam

That is a repainting version of Spearman rank correlation that uses centered TMA (snake force) for smoothing - if you try to use it in signaling mode, you will end up with a lot of false signals and almost sure will suffer significant losses

In my opinion it is much better to use "simple" Spearman rank correlation instead (which does not repaint) and gives signals that are useful (not a holly grail, but useful)

marijus321
71
marijus321  
mladen:
MarioKam

That is a repainting version of Spearman rank correlation that uses centered TMA (snake force) for smoothing - if you try to use it in signaling mode, you will end up with a lot of false signals and almost sure will suffer significant losses

In my opinion it is much better to use "simple" Spearman rank correlation instead (which does not repaint) and gives signals that are useful (not a holly grail, but useful)

Where can i get it please?

Mladen Rakic
151210
Mladen Rakic  
MarioKam:
Where can i get it please?

MarioKam

New mt4 compatible version you can download from here : https://www.mql5.com/en/forum/general

Also you will need the spearman.dll from this post : https://www.mql5.com/en/forum/general (it is in the spearman.zip file)