Новая версия MetaTrader 4 Client Terminal build 406 - страница 7

Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Vadim Zhunko
5136
Vadim Zhunko  
Scriptong:

Сходная ситуация была. Большой эксперт компилируется, в окне ошибок пишется, что процесс завершен, но советник не запускается по ошибке: "нет доступа к файлу ex4". Разобрался, в чем дело. Проблема в том, что процесс компиляции к этому времени не завершен - MetaLang висит в списке задач еще какое-то время (у меня порядка тридцати секунд при общем времени компиляции от около полутора минут) и ест все ресурсы. Если дождаться завершения MetaLang, не переходя в терминал, то советник становится "не сереньким" и запускается как положено.

Ещё раз посмотрел. Тот процесс, который Вы видите, который ещё не закончился, это второй запущенный процесс компилятора. На тот момент первый процесс закончился и выдал отсутствие ошибок.

Эксперт в списке серый после окончания второго процесса компилятора.

Renat:

С учетом того, что не было предоставлено ни воспроизводимых примеров, ни логов, кроме словесного описания, то ответы могут быть только гаданием.

Проверьте поведение своего антивируса в момент компиляции - наверняка он блокирует файл для анализа после каждого его изменения.

Отключите на время антивирус или поставьте каталог терминала в пропуск от греха подальше.

Всё сделано с отключеным антивирусом. Вот лог компиляции:

18:00:38 MetaTrader 4.00 build 406 started (MetaQuotes Software Corp.)
18:00:46 'XXXXXX': login
18:02:19 MetaTrader 4.00 build 406 stopped

Но!!! После перезагрузки МТ4 эксперт становится синим.

Надо видео снять...

http://youtu.be/dg3s58QxOfM

Вставил видео, но оно не видно почему-то. Там, где пустота выше, должно быть видео.

>

Евгений Панин
701
Евгений Панин  
Renat:

С учетом того, что не было предоставлено ни воспроизводимых примеров, ни логов, кроме словесного описания, то ответы могут быть только гаданием.


1. В примере чистый новый 406, без экспертов, антивирус отключён.
Если в терминале имеется множество счетов (в данном случае 21 демо-счёт от 3х брокеров), то время загрузки терминала ощутимо увеличивается. Похоже, что время загрузки пропорционально количеству счетов.
Легко воспроизводится (видео прилагается).

2. При удалении какого-либо счёта из середины списка: в момент удаления счёт из списка пропадает, но при последующем включении терминала удалённый счёт появляется в конце списка. Набюлюдается давно, ещё с 200-х билдов. В своё время таким способом я отсортировал счета, т.к. штатного способа изменения последовательности счетов не существует. Воспроизвести удаётся не всегда.

3. В случае множества счетов при переключении с одного счёта на другой: окно диалога с кнопкой Логин появляется с задержкой несколько секунд. Вслед за этим снова выдерживается пауза. Лишь после этого начинается фактическое откл. от текущего счёта и вкл. нового счёта. Легко воспроизводится.

ОЗУ 2Гб, 2.4 ГГц, Win 7

Файлы:
Ihor Herasko
22290
Ihor Herasko  
Zhunko:

Ещё раз посмотрел. Тот процесс, который Вы видите, который ещё не закончился, это второй запущенный процесс компилятора. На тот момент первый процесс закончился и выдал отсутствие ошибок.

Эксперт в списке серый после окончания второго процесса компилятора.

Возможно. Этот момент я не проверял. Просто видел, что после окончания компиляции висит MetaLang, который и блокирует доступ к ex4.
Vadim Zhunko
5136
Vadim Zhunko  
Scriptong:
Возможно. Этот момент я не проверял. Просто видел, что после окончания компиляции висит MetaLang, который и блокирует доступ к ex4.
Блокировку не проверял, но, наверняка, именно из-за неё МТ4 не видит или не может пользовать обновлённый файл эксперта. Почти нашли причину :-))
Vadim Zhunko
5136
Vadim Zhunko  

Есть предложение. Надо сделать отображение времени открытия в информации о баре при наведении курсора на цену закрытия бара с точностью до секунд.

Шкала секундная не очень смотреться будет. Зато во всплывающем окне наглядно. Это поможет без левых индикаторов ориентироваться в равнообъёмной таймсерии.

AlexPORT
158
AlexPORT  

Не уверен, связано ли именно с 406 билдом, но по времени появления примерно совпадает..

Суть вопроса - при переносе папки с установленным метатрейдером с компа на комп, при первом запуске на новой машине раньше он всегда спрашивал логин/пароль. Теперь этого не происходит, просто молча запускается и логинится. Насколько помню, когда то давно принудительно была введена такая фича, типа дополнительная защита и т.п. Там еще сообщения в почте стали отображаться, только полученные на той машине, где сейчас МТ4 запущен. Если не путаю, была привязка к файлу server.ini... Что-то изменилось в этом плане в 406-м?

Просто ношу МТ4 с работы домой и обратно на флешке (копирую на/с HDD) и стал замечать, что перестало запрашивать логин... В настройках галка "Сохранять личные настройки и данные при старте" стояла и раньше и сейчас (ничего не трогал).

Vadim Zhunko
5136
Vadim Zhunko  
AlexPORT:

Не уверен, связано ли именно с 406 билдом, но по времени появления примерно совпадает..

Суть вопроса - при переносе папки с установленным метатрейдером с компа на комп, при первом запуске на новой машине раньше он всегда спрашивал логин/пароль. Теперь этого не происходит, просто молча запускается и логинится. Насколько помню, когда то давно принудительно была введена такая фича, типа дополнительная защита и т.п. Там еще сообщения в почте стали отображаться, только полученные на той машине, где сейчас МТ4 запущен. Если не путаю, была привязка к файлу server.ini... Что-то изменилось в этом плане в 406-м?

Просто ношу МТ4 с работы домой и обратно на флешке (копирую на/с HDD) и стал замечать, что перестало запрашивать логин... В настройках галка "Сохранять личные настройки и данные при старте" стояла и раньше и сейчас (ничего не трогал).

Наверно пути одинаковые на обоих компах. У меня спрашивает логин/пароль.
AlexPORT
158
AlexPORT  
А ведь точно! Проверил - действительно совпадают сейчас на разных машинах. И на одном компе попробовал перемещать в другую папку - уже просит логин. Как это раньше не заметил и не додумался :)
Сергей
527
Сергей  

Не могу понять в чем дело :(

Тут понадобилось дописать немного советник в МТ4. Давно уже перешел на МТ5, но тут попросили кое-что сделать и вернулся опять к четверке.

Столкнулся с тем, что советник периодически перестает работать. Методом последовательного исключения :) дошел вот до такого советника для проверки:

int init() {
Print("--------> INIT !!");
return(0);
}
//-------------------------------------------------------------------------------------------------
int deinit() {
Print("--------> DE-INIT !!");
return(0);
}
//-------------------------------------------------------------------------------------------------
int start() {
Print("=============> Start!!");
return(0);
}
//-------------------------------------------------------------------------------------------------

Так вот, на свежезапущенном МТ4 все нормально. Если его не трогать, то работает.

Если навесить несколько индикаторов своих, то принты перестают. После этого можешь удалить все советники и опять навесить этот для проверки - пох, принты не идут.

Использую портабельный 406 билд. Win7Pro 64, в процессах смотрел, вроде все как обычно...

Может, попробовать 402 билд? Только где его найти?

poruchik
1921
poruchik  
387
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий