Some tools do not work with new 2265 build of MT5 - how to fix? - page 4

To add comments, please log in or register
Doerk Hilger
1369
Doerk Hilger  
It is not reproducable, thats the problem. Its just crashing the way i described it. I mean, there cannot be a logical explanation that a step over and walk through these simple lines of code create different results. And there is no logical explanation that it all takes 30-40 times longer than in the version before, I think the developers know what they changed and know where to have a look. 
Alain Verleyen
38716
Alain Verleyen  
Doerk Hilger:
It is not reproducable, thats the problem. Its just crashing the way i described it. I mean, there cannot be a logical explanation that a step over and walk through these simple lines of code create different results. And there is no logical explanation that it all takes 30-40 times longer than in the version before. 

I have an EA which crash, I just drag it, it displays some objects on the chart then MT5 crash. I think it's the same as what you have ?

Trying to debug...

Doerk Hilger
1369
Doerk Hilger  
And by the way, since 4 hours I am doing nothing else than trying to debug and figuring out where the problem comes from. Actually I wanted to get me something to eat but this is a massive problem which is coming up. And believe me, as soon as I am able to reproduce it, I will be the first one who provides a code. But I am absolutely sure, that I will never be able to reproduce it, cause this bug is somewhere else. 
Doerk Hilger
1369
Doerk Hilger  
But anyway, the delays are bugs themselves and I am sure everybody who has more than just a few lines of code can easily reproduce at least this. 
Alain Verleyen
38716
Alain Verleyen  
Doerk Hilger:
And by the way, since 4 hours I am doing nothing else than trying to debug and figuring out where the problem comes from. Actually I wanted to get me something to eat but this is a massive problem which is coming up. And believe me, as soon as I am able to reproduce it, I will be the first one who provides a code. But I am absolutely sure, that I will never be able to reproduce it, cause this bug is somewhere else. 

I know.

So in my side, the debugger is working well. AND the EA is working normally in debug mode.

That means the problem comes from the optimization of the compiler in normal mode.

Alain Verleyen
38716
Alain Verleyen  
Doerk Hilger:
But anyway, the delays are bugs themselves and I am sure everybody who has more than just a few lines of code can easily reproduce at least this. 

I don't think so, your EA is very complex.

Can you disable the optimization of the compiler, compile in normal mode and try ?

Doerk Hilger
1369
Doerk Hilger  
Currently the most time i used wasting until the debugging begins. 
Alain Verleyen
38716
Alain Verleyen  
Alain Verleyen:

I don't think so, your EA is very complex.

Can you disable the optimization of the compiler, compile in normal mode and try ?

I confirm that doing so, MT5 doesn't crash when the EA starts.
Alain Verleyen
38716
Alain Verleyen  
Doerk Hilger:
Currently the most time i used wasting until the debugging begins. 
Forget the debugging, if it's a compiler things you will never be able to debug it anyway. Please try what I suggested to confirm it or not.
Doerk Hilger
1369
Doerk Hilger  
Will try, but I also found something else. I am on it and keep you updated. 
To add comments, please log in or register