Can't Install MT5 Mac - Proxy Server

To add comments, please log in or register
imMapex
13
imMapex  

I have searched solutions for a solid hour now and I can't find anything to fix my issue.

Whenever I install MT5 on my mac, I get a pop up asking for proxy service information. I do not use a proxy server. Each time I hit cancel, MT5 tells me, "Something went wrong. Please try again later."

I have tried the following solutions:

- I've installed Mono and Gecko for Wine via PlayOnMac

- I've installed winetricks winhttp

- Using Windows 10 via PlayOnMac

Thanks for your help. 

Sergey Golubev
Moderator
107768
Sergey Golubev  

There are some information (I hope it will be usefull) - 

----------------

proxy server is asked during installation of Metatrader on Mac - read this small thread and this thread.

----------------

Forum on trading, automated trading systems and testing trading strategies

New MetaTrader 5 Platform Build 1755

MetaQuotes Software Corp., 2018.01.18 11:08

We recommend anyone who has long been using 32-bit Wine for MetaTrader 5 due to the past incompatibility with the 64-bit terminal to upgrade Wine to the latest 64-bit version and re-install MetaTrader 5 in 64 bits.

Besides, make sure to set the Wine compatibility mode to at least Windows 7 instead of the default Windows XP. No more updates for Windows XP/2003/Vista will be released.

We are also halting the development of the 32-bit versions of the MetaTrader 5 terminals. The updates for 32-bit MetaTrader 5 are to be completely stopped soon.

----------------

Forum on trading, automated trading systems and testing trading strategies

Get in touch with developers using Service Desk!

kypa, 2018.06.15 18:24

Update Wine to at least 3.0, if that doesn't solve the problem get winetricks and install winhttp library.

You could probably insert the winhttp from winecfg as well.

----------------

Forum on trading, automated trading systems and testing trading strategies

Error when installing Metatrader 4 or 5 in Mac HELP PLEASE!

Marco vd Heijden, 2018.03.24 08:39

Your wine is still in windows XP mode.

You need to go into settings and set it to windows 7 or higher.

Sergey Golubev
Moderator
107768
Marco vd Heijden
Moderator
8702
Marco vd Heijden  

Also read the latest info relating this issue for Linux users:

https://www.mql5.com/en/forum/10114/page3#comment_7845504

Discussion of article "MetaTrader 5 on Linux"
Discussion of article "MetaTrader 5 on Linux"
  • 2015.12.06
  • www.mql5.com
New article MetaTrader 5 on Linux is published: Author: MetaQuotes...
imMapex
13
imMapex  

Thanks for the help. Still can't get it to work. I have now tried:

- Re-downloading wine to allow for 64-bit. Tried installing MT5 using a 64 bit version and I still get the same proxy server issue.

- Tried different versions of wine. PlayOnMac keeps resorting back to an old version when I try installing MT5. Using version 3.0+ outside of PlayOnMac gives me the same proxy server issue. 

There doesn't seem to be a fix on this website or Google. I've been searching all night. 

Marco vd Heijden
Moderator
8702
Marco vd Heijden  

Have you read the discussion at the link i provided ?

sudo dpkg --add-architecture i386 
wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/
sudo apt-get update
sudo apt-get install --install-recommends winehq-staging
WINEARCH=win32 winecfg
RealMoneyTrader
6
RealMoneyTrader  

I had this problem with MetaTrader5 (it should work for MT4 too). The solution was to change the wine version from System to Wine 3.21 (the newest at the moment).

Click Configuration and select mt5setup file, the option I am talking about is in the first tab. I have found a screenshot of this tab here: http://f4bpp.raidghost.com/img/SDR-Sharp-Setup/074.png

To add comments, please log in or register