Stochastic Oscillator, the beginning - page 63

secretcode
898
secretcode  
mladen:
secretcode

Here you go : dss_of_adaptive_smoother.mq4

PS: it is already a multi time frame version

Interesting! Thanks a lot Mladen for this DSS version

Respectfully

secretcode

name
992
name  
mladen:
secretcode

Here you go : dss_of_adaptive_smoother.mq4

PS: it is already a multi time frame version

It seems to be identifying cycles - wouldn't expect it from dss

Mladen Rakic
154431
Mladen Rakic  
on my own:
It seems to be identifying cycles - wouldn't expect it from dss

In general dss works better on higher time frames (1 hour and higher). Especially on 1 hour charts : almost all dss versions somehow show some kind of cycles on 1 hour charts

Mladen Rakic
154431
Mladen Rakic  

Here is a dss of adaptive super smoother too. Since super smoother is more sensitive than the smoother, longer periods for it can be used without adding too much lag. The example is with default parameters except that super smoother period is set to 50

dss_of_adaptive_super_smoother.mq4
Boersenkater
58
Boersenkater  
mladen:
Here is a dss of adaptive super smoother too. Since super smoother is more sensitive than the smoother, longer periods for it can be used without adding too much lag. The example is with default parameters except that super smoother period is set to 50
dss_of_adaptive_super_smoother.mq4

hi mladen, the indi dont work for me. after compiling comes the message

"DSS of adaptive super smoother.mq4;314:43;')' - variable expected"

why?

Mladen Rakic
154431
Mladen Rakic  
Börsenkater1969:
hi mladen, the indi dont work for me. after compiling comes the message

"DSS of adaptive super smoother.mq4;314:43;')' - variable expected"

why?

Börsenkater1969

I tested it from the attached file right now and all seems to be OK

What is your build of metatrader (I am using build 628)? It will not work on old metatrader. In order to use it with with old metatrader you have to delete the "(double)" part from line 314

Boersenkater
58
Boersenkater  
mladen:
Börsenkater1969

I tested it from the attached file right now and all seems to be OK

What is your build of metatrader (I am using build 628)? It will not work on old metatrader. In order to use it with with old metatrader you have to delete the "(double)" part from line 314

hi mladen

I think the problem is my platform activetrades build 509. I have tested it with platform avatrades build 625 and worked. thank you, now I understand.

but what exactly is meant by "It will not work on old metatrader. In order to use it with with old metatrader you have to delete the "(double)" part from line 314"?

William Snyder
9492
William Snyder  

Stochastic_2SigMAs_mtf+histo from here: https://www.mql5.com/en/forum/177239/page31 made new mt4 compatible.

William Snyder
9492
William Snyder  

stochastic of rsx mtf from here: https://www.mql5.com/en/forum/177239/page35 updated to be compatible with new mt4 builds.

William Snyder
9492
William Snyder  

DSS of Rsx + arrows _ mtf from here: https://www.mql5.com/en/forum/177239/page36 updated to be compatible with new mt4 builds.