paullosilva  

 - Uma coisa que aprendi hoje, antes de clicar em MIGRAR na vps, deixe tudo ativado e prontinho na maquina local só depois clique em MIGRAR assim o MQL irá clonar seu MT5 para a vps e ao mesmo tempo irá desativar os robõs na maquina local, então CUIDADO para não se confundir e ficar ativando o EA na maquina local após ativado na VPS para não ficar com dois EAS ao mesmo tempo.

milafcruz  
Bom dia. Não estou conseguindo migra os robôs na conta hedger para a VPS, está dando esse erro: Falha na migração verifique o log da plataforma. Coloquei 4 robôs.

Leprechaun  
milafcruz:
Bom dia. Não estou conseguindo migra os robôs na conta hedger para a VPS, está dando esse erro: Falha na migração verifique o log da plataforma. Coloquei 4 robôs.

Estou com o mesmo problema, começou hj, ontem rodou normal.

Deve ser algum problema com o servidor deles, poderiam dar suporte sem ser pelo fórum.

Leprechaun  

Acabei de conseguir logar na vps.

Oq fiz foi clicar em migrar direto sem antes iniciar a vps, assim deu certo.

Flavio Javier Jarabeck  
Leprechaun:

Estou com um problema de latência no envio das ordens pela vps.

As ordens estão demorando mais de 400ms para serem validadas, colocadas em fila, executadas...

Rodando de casa na mesma conta, fica em torno de 12ms, logo o problema não é o servidor da corretora e sim a vps.

Alguém com problema parecido? Como conseguiu solucionar?

Se é a VPS da MEtaquotes, até onde eu sei eles não tem servidores no Brasil, portanto, essa latência é normal de servidores fora do continente... na verdade gira em torno de 200 a 300ms... mas, está dentro dos padrões de pings internacionais...
Leprechaun  
Flavio Jarabeck:
Se é a VPS da MEtaquotes, até onde eu sei eles não tem servidores no Brasil, portanto, essa latência é normal de servidores fora do continente... na verdade gira em torno de 200 a 300ms... mas, está dentro dos padrões de pings internacionais...

Olá Flavio Jarabeck!

Eles têm servidores na Equinix no Brasil, do lado da B3 em Santana do Parnaíba. A latência com a plataforma está bacana, 0,3ms o problema é o processamento das ordens que saltam de 3ms para mais de 500ms sem explicação nenhuma.

O duro é que a Metaquotes me retornou dizendo que o problema não é com eles, mas fiz teste com outra corretora com a mesma vps e o resultado foi o mesmo, inicia com média baixa e do nada salta para mais de 500ms.

Jonathan Pereira  
Leprechaun:

Olá Flavio Jarabeck!

Eles têm servidores na Equinix no Brasil, do lado da B3 em Santana do Parnaíba. A latência com a plataforma está bacana, 0,3ms o problema é o processamento das ordens que saltam de 3ms para mais de 500ms sem explicação nenhuma.

isso é com a sua corretora.

a latência que vc consegue medir é o tempo de comunicação entre a sua plataforma e o servidor meta trader que a corretora hospeda em algum lugar.

esse tempo de execução é possível acompanhar no log gerado na aba diário, se la constar que o tempo é menor, porem se vc pegou esse tempo monitorando no algoritmo, eu chuto que é problema de processamento do seu EA

Leprechaun  
Jonathan Pereira:

isso é com a sua corretora.

a latência que vc consegue medir é o tempo de comunicação entre a sua plataforma e o servidor meta trader que a corretora hospeda em algum lugar.

esse tempo de execução é possível acompanhar no log gerado na aba diário, se la constar que o tempo é menor, porem se vc pegou esse tempo monitorando no algoritmo, eu chuto que é problema de processamento do seu EA

Então, tanto no log quanto no monitoramento no EA o tempo bate, a lógica operacional do EA fica em torno 0.8 a 1.5 ms, isso rodando em um i5 2.2 ghz, no processador da vps pode ser que seja um pouco mais rápido.

Rodando da minha casa, o mesmo EA na mesma corretora, não ocorre o aumento no RTT das ordens, ficam sempre em media de 16ms.

Mas para o propósito do EA preciso de um RTT menor, em torno dos 3ms.

Vamos ver oq a corretora me responde, falei com eles novamente.


Vlw pelo comentário.

Razão: