Error al subir el fichero x4

Para añadir comentario, por favor Autorícese o regístrese
Georgian Gurita
299
Georgian Gurita  
Quiero subir el fichero X4 de un expert advisor y aparece error, sabéis como se puede solucionar eso?
Miguel Antonio Rojas Martinez
2276
Miguel Antonio Rojas Martinez  
Hola amigo, como estas?
A donde lo quieres subir? a codebase? al foro? al market?
Georgian Gurita
299
Georgian Gurita  
Miguel Antonio Rojas Martinez:
Hola amigo, como estas?
A donde lo quieres subir? a codebase? al foro? al market

Miguel Antonio Rojas Martínez:

Hola, LO quiero subir al market 

Miguel Antonio Rojas Martinez
2276
Miguel Antonio Rojas Martinez  
Georgian Gurita:

Miguel Antonio Rojas Martínez:

Hola, LO quiero subir al market 

Amigo, comparte una captura del error,
pero  empieza por confirmar que tiene la propiedad "strict" y, si mal no recuerdo, los productos del market no permiten DLLs, asi que revisa que  no contenga DLLs.

Georgian Gurita
299
Georgian Gurita  
Me dan esos errores @Miguel Antonio Rojas Martínez
Archivos adjuntos:
Miguel Antonio Rojas Martinez
2276
Miguel Antonio Rojas Martinez  
pues tienes errores desde la misma inicializacion,



cuando compilas tu codigo, aparecen errores aqui (o mas bien, alertas)?



quizas alli tengas alertas que debas corregir antes,

En caso de no ser asi, quizas estes usando un filtro de tiempo (Que no  funcione en previo tiempo)
o un filtro de digitos (qque no funcione en pares con X digitos)
o quizas estas usando un filtro de lotaje (minimo X lotaje)
Georgian Gurita
299
Georgian Gurita  

Hola Miguel, e hablado con el programador que lo izo, y me dice que tiene un chequeo inicial de seguridad de lotes, para asegurar que el usuario no pone un lote invalido y a lo mejor será eso .

aquí te adjunto en el probador los errores que me dan .

Archivos adjuntos:
Miguel Antonio Rojas Martinez
2276
Miguel Antonio Rojas Martinez  
Pero podes probarlo en el tester y termina el test ok? (por que en la imagen que adjuntas aparece que has parado el backtest  de manera voluntaria antes de terminar)
Entonces, debes confirmar si en el tester termina bien ese test

Pregunto de nuevo ¿al compilarlo en el editor de codigo, te da alguna advertencia?

Finalmente, me das a entender que no has hecho tu el codigo y por ende, es obvio que no sera facil que encuentres el error.
Normalmente hay que manejar bien la programacion, para poder resolver los "problemas" que el  sistema evidencia cuando queremos subir un archivo a la tienda
Georgian Gurita
299
Georgian Gurita  
Aquí te mando otra vez del código y también del test sin pararlo yo .
Archivos adjuntos:
Miguel Antonio Rojas Martinez
2276
Miguel Antonio Rojas Martinez  
Bueno, el codigo no da error,  asi que por ese lado parece que talvez no este el problema

lo que me doy cuenta es que parece que no abrio ninguna operacion,  (talvez solo tomaste una parte del resultado)
Pero esos resutados de "Error" (hablando de tu captura del backtest) no son los responsables del fallo, porque es error en la data, mas no en la ejecucion!
Georgian Gurita
299
Georgian Gurita  
Miguel Antonio Rojas Martinez:
Bueno, el codigo no da error,  asi que por ese lado parece que talvez no este el problema

lo que me doy cuenta es que parece que no abrio ninguna operacion,  (talvez solo tomaste una parte del resultado)
Pero esos resutados de "Error" (hablando de tu captura del backtest) no son los responsables del fallo, porque es error en la data, mas no en la ejecucion!
Si solo e buscado los errores  del test, lo demás va bien, por eso no entiendo porque no deja subir, solo aparece al arrancar el robot luego hasta el final va todo bien.
Archivos adjuntos:
12
Para añadir comentario, por favor Autorícese o regístrese