Error 532 MetaQuotes VPS

To add comments, please log in or register
AWer1001
56
AWer1001  

First of all, good day/night der fellow forum mebers.


The problem I have is the one stated on this topics title. It all began yesterday after a client tried to upload a new version of an EA i wrote for him, he told me that he constantly recieved this error so I uploaded the same EA into a VPS I rented for some hours to check this issue and indeed I could replicate the error.

My question is, the broker my client uses provides him with version 1860, same I possess on my laptop, but the MetaQuotes VPS has version 1831 installed, so is there a way to upload my EA to a server that possess version 1860 or I have to wait for someone to decide to upgrade the VPS terminal version?


Thanks a lot for all provided help.

Yours faithfully, Awer1001.

Sergey Golubev
Moderator
106753
Sergey Golubev  

"MetaQuotes VPS" means: MQL5 VPS for MT4 and MT5?
If yes so it is just a copy of your Metatrader in cloud.

As to the error so you can check the following posts which I collected (to find your case for example):

--------------------

Forum on trading, automated trading systems and testing trading strategies

How to Start with Metatrader 5

Sergey Golubev, 2014.11.07 14:46

Why Virtual Hosting On The MetaTrader 4 And MetaTrader 5 Is Better Than Usual VPS

Renting a virtual server right from the MetaTrader 4 and MetaTrader 5 terminals is the optimal way to ensure uninterrupted work of your trading robots and Signal subscriptions. Essentially, it is an analogue of a VPS though it is better and more suitable for addressing needs and challenges that a trader comes across. The server can be rented straight from your MetaTrader. It takes only a couple mouse clicks for Experts Advisors, indicators, scripts together with Signal subscriptions and settings to be transferred to the virtual server. The Virtual Hosting Cloud network was developed specially for MetaTrader and has all the advantages of a native solution.

Certainly, there are alternatives to virtual hosting but a closer look reveals that they do not compete. The first thing that comes to mind is using a home computer as a budget option. It could work, however a stable internet connection and uninterrupted power supply are not guaranteed. A VPS can be rented from a suitable provider found on the internet. That could be feasible but it implies a manual search for a server having minimum latency with the required Forex-broker's. Such a puzzle does not suit everyone.

Forum on trading, automated trading systems and testing trading strategies

Mt5 VPS

Slava, 2016.06.28 16:25

It must be 64-bit client terminal to use virtual hosting

2016.06.28 17:25:02.177 Terminal        MetaTrader 5 x64 build 1347 started (MetaQuotes Software Corp.)

Forum on trading, automated trading systems and testing trading strategies

Meta 4 Robot help

Sergey Golubev, 2018.04.05 18:18

MQL5 VPS is for Metatrader 4 and Metatrader 5 - Forex VPS for MetaTrader 4/5 
So, you can check only the following: your EA (robot) is using dll, or not (because dll is not supported by MQL5 VPS).

...

Sergey Golubev
Moderator
106753
Sergey Golubev  

And about synchronization - 

Forum on trading, automated trading systems and testing trading strategies

How to update/adjust EAs that are hosted on a VPS?

Eleni Anna Branou, 2017.07.18 12:58


You have to make your adjustments locally in your computer's MT4 platform and then synchronize with your VPS again.

MQL5 MT4 integrated VPS doesn't give you real/visual access to the MT4 platform that your EAs are loaded on.


Sergey Golubev
Moderator
106753
Sergey Golubev  
If you did not find your case on my posts above so write to the service desk.
Sergey Golubev
Moderator
106753
Sergey Golubev  

and finally (I found it now) - 

Forum on trading, automated trading systems and testing trading strategies

Is 'Allow DLL import' and 'Allow modification of signal setting ' in MQL4 Indicators dangerous?

Sergey Golubev, 2017.09.09 06:05

Rules of Using the Virtual Hosting Service MetaTrader (Forex VPS)

No DLLs are allowed on a Virtual terminal. There is no physical capacity to use DLLs there.

If a program launched on a Virtual terminal tries to call a function from any DLL, this EX4/EX5 program is immediately stopped due to a critical error. Any DLL calls are forbidden.


To add comments, please log in or register