Download MetaTrader 5
To add comments, please log in or register
Sell your CPU capacity and earn money!
Ali Akcaagac
169
Ali Akcaagac 2014.04.20 10:13 

Hello!

I would like to ask if there are plans to release a new MetaTrader 4 (Build after 628) that addresses the issues with new file structure issues ? I am not able to use MetaTrader (Build 625/628) anymore because of this.

Explaination found here under b): reference

Unfortunately I'm not able to trade for the past couple of weeks due to this and the "/portable" option is not working with wine. Bug has been reported by a couple of people here and some already filed it in the bugtracker.

Thanks

honest_knave
969
honest_knave 2014.04.20 18:15  
Build 610 working just fine under Wine for me... is this a problem specific to 625/628?
Ali Akcaagac
169
Ali Akcaagac 2014.04.20 18:50  

Can't tell. I re-installed from scratch going from 509 to 625,

Fact is, that the import somehow feels broken. Once you install metatrader with the setup using wine, you get the terminal.exe poping up as known. You enter your data or create a new demo account (which I did to test the new software). Once you close metatrader and start it again you are prompted with an empty terminal.exe

No charts open, the server files are missing, the mails are missing etc. So whatever happens it happened wrong. This can be re-produced all the time here and I already read about other people describing similar issues. I could live with that but sadly you can't run /portable on wine either. So I am stuck not being able to trade for some weeks now.

If you want to figure out whether 625/628 is affected then why don't you try it yourself ?

mv ~/.wine ~/.wine-old

wine mt4setup.exe

and see youself.

honest_knave
969
honest_knave 2014.04.20 19:52  

Just tried running Build 625 - works without any issue for me.

Wine set to XP so custom indicators and experts in the old file structure without needing the /portable switch.

Personally, I'd be looking to a problem with your wine installation.

Ali Akcaagac
169
Ali Akcaagac 2014.04.20 20:55  

Well I doubt this to be a Wine issue. Running Wine 1.7.16 here which is delivered by Fedora 20. It's not like I have a choice to install different versions here. Not that I want to do this either. Personally I belive that the entire Wine situation related to MetaTrader is a mess.

No one should be running MetaTrader with Wine. This is just plain wrong and bad hack. On the one side you spent a couple of thousand bucks on your trading account and on the otherside you are not able to spent a few bucks for a professional trading station. Which you can get back from taxes anyways. Nonetheless what Wine version are you running ?

And by the way I have no issues getting MetaTrader running with Wine. I have issues for MetaTrader not setting up the new structure properly. I don't even get a dialog about migrated settings or whatever. And by the way, my Wine setup is properly set up during update/installation process. I am not using Linux since yestrday. It's almost 20 years now.

honest_knave
969
honest_knave 2014.04.20 21:11  
aakcaagac:

No one should be running MetaTrader with Wine.


So why are we having this conversation?

I run Wine 1.4.1 without issue on Build 610 and Build 625 (you're welcome, by the way).

As far as I'm aware, MetaQuotes never claimed to support MetaTrader running through Wine. But if you feel sufficiently strong about it perhaps you should contact the Service Desk and ask why something they don't support doesn't work.

Good luck.

Ali Akcaagac
169
Ali Akcaagac 2014.04.20 21:21  
I don't know either why you replied to me. My question was more or less directed to the MetaQuotes people who should be aware of this situation because others have the same issues on their Windows X machines and a few opened a report in the tracker. If you had read the starting message then you should have been aware that I am not the only one reporting this. By the way: Wine 1.4.1 is not possible on Fedora 20. We are bound to releases provided packages, which is sent in by maintainers and follows distribution specific rules and guidelines. Wine 1.4.1 otoh is absolutely ancient by the way (release jun 2012). No one should be running and using it anymore.
honest_knave
969
honest_knave 2014.04.20 21:23  
aakcaagac:
Wine 1.4.1 otoh is absolutely ancient by the way (release jun 2012). No one should be running and using it anymore.


Yet I'm the one with a working version of MT4...

I shall leave you to your rant, seeing as even common courtesy is lost on you. Enjoy.

Ali Akcaagac
169
Ali Akcaagac 2014.04.20 21:30  

Please!

Would you be so kind and read carefully what I wrote!

There is NO issue in running MetaTrader 4 625 and beyond. There is a settings migration problem. Everything works here with the exception of proper migration of stuff. Please also try to understand that this issue has been reported by Windows users as well.

Please be so kind and stop getting personal. I wasn't attacking you. I only tried to point you to the core of the situation, which I feel you can't grasp.

Thanks.

honest_knave
969
honest_knave 2014.04.20 21:46  

The problems you have described, including those in your link, I have been unable to replicate.

I even went out of my way to install a newer build. Also unable to replicate your problems.

I didn't suggest that you attacked me. I said you lack common courtesy i.e. the generally accepted "thank you" for somebody that tried to help you for no benefit to themselves.

As before, good luck. I'm leaving you to it.

Ali Akcaagac
169
Ali Akcaagac 2014.04.20 21:57  

Wine 1.4.1 is NOT supported on Fedora 20 - not that I would want to install it anyways or plan to change my system. MetaTrader 4 up to 509 worked flawlessly here until the recent changes.

Thanks for your support.

/
To add comments, please log in or register