Bug: MT5 - laufende EAs werden automatisch willkürlich entfernt

Einloggen oder registrieren, um einen Kommentar zu schreiben
Agent_Mulder
33
Agent_Mulder  

- seit einiger Zeit (Zeitpunkt kann nicht exakt bestimmt werden aber vermutlich seit einem der letzten Updates) verschwinden laufende aktivierte Expert Advisors aus dem Chart
- meistens tritt das Problem direkt nach einem Re-Connect mit dem Broker auf (siehe Screenshot) und manchmal aber auch einfach so mitten drin ohne ersichtlichen Grund
- die EAs sind tatsächlich aus dem jeweiligen Chartfenster verschwunden und arbeiten nicht mehr
- ein erneutes manuelles Hinzufügen durch Hineinziehen des EAs ist notwendig
- die Anzahl der verschwundenen EAs bewegt sich in einem ca.-Rahmen von 2-6 pro auftretendem Bug
- Häufigkeit im Schnitt ca. aller 1-2 Tage

- MetaQuotes Support (ehemals Service Desk) anschreiben ist leider nicht mehr möglich, es wird nur noch auf finanzielle Anliegen geantwortet

Dateien:
journal.jpg 137 kb
amando
2886
amando  

bin beim gleichen Broker, kenne das Problem aber nicht.

eventuell eine Einstellung im EA?

Agent_Mulder
33
Agent_Mulder  
amando:

bin beim gleichen Broker, kenne das Problem aber nicht.

eventuell eine Einstellung im EA?

Hi Amando,

die EAs wurden nicht neu kompiliert und laufen in exakt gleicher Umgebung ohne Änderungen seit einem Jahr. Der oder die EAs verfügen nicht über solche Einstellungen, Funktionen bzw. wurde nichts dergleichen gescripted.

Christian
3171
Christian  
Agent_Mulder:

Hi Amando,

die EAs wurden nicht neu kompiliert und laufen in exakt gleicher Umgebung ohne Änderungen seit einem Jahr. Der oder die EAs verfügen nicht über solche Einstellungen, Funktionen bzw. wurde nichts dergleichen gescripted.

Neu kompelieren. Die letzten Mt5 Updates erfordern dass.

Siehe

Gruß

Agent_Mulder
33
Agent_Mulder  
Christian:

Neu kompelieren. Die letzten Mt5 Updates erfordern dass.

Siehe

Gruß

Moin Christian,

ich kompilier heute nochmal alles neu ... gebe euch Info ob es immer noch so ist die nächsten Tage.

Agent_Mulder
33
Agent_Mulder  
Agent_Mulder:

Moin Christian,

ich kompilier heute nochmal alles neu ... gebe euch Info ob es immer noch so ist die nächsten Tage.

- auch nach der Neukompilierung ist es immer noch so ... ich habe es auch sehr lange getestet ... es gibt einen Server-Re-Connect beim Broker und meistens (aber eben nicht immer) ist das der Anlass für MT5 vollkommen selbständig 2-6 EAs aus den Indikatorenfenstern zu entfernen
- aber selbst wenn es früher zur Auto-Trennung oder zu kurzen Abrissen kam, war das nie ein Grund dass sich die EAs einfach von selbst entfernt haben
- ich werde jetzt eine Virtual Box aufsetzen und nochmals dort alles neu installieren um zu sehen ob es in einem sauberen System läuft ... ist zwar nicht logisch aber ich habe keine andere Idee was ich probieren könnte
amando
2886
amando  
Agent_Mulder:
- auch nach der Neukompilierung ist es immer noch so ... ich habe es auch sehr lange getestet ... es gibt einen Server-Re-Connect beim Broker und meistens (aber eben nicht immer) ist das der Anlass für MT5 vollkommen selbständig 2-6 EAs aus den Indikatorenfenstern zu entfernen
- aber selbst wenn es früher zur Auto-Trennung oder zu kurzen Abrissen kam, war das nie ein Grund dass sich die EAs einfach von selbst entfernt haben
- ich werde jetzt eine Virtual Box aufsetzen und nochmals dort alles neu installieren um zu sehen ob es in einem sauberen System läuft ... ist zwar nicht logisch aber ich habe keine andere Idee was ich probieren könnte

Was sagt der reiter experten dazu? Hast Du eventuell eine Division durch 0 zu bestimmten zeiten das dies passiert?

Christian
3171
Christian  

 Ne passt nicht , würde im log stehen.


@Agent_Mulder poste mal BEIDE log Dateien . Dort wo der Fehler auftritt.


So viel wie möglich. Wenn zu groß dann als Datei anhängen.

Agent_Mulder
33
Agent_Mulder  
Christian:

 Ne passt nicht , würde im log stehen.


@Agent_Mulder poste mal BEIDE log Dateien . Dort wo der Fehler auftritt.


So viel wie möglich. Wenn zu groß dann als Datei anhängen.

Hallo Christian,

vielen Dank für deine Rückmeldung. Anbei eine txt-Datei mit Ausschnitten jeweils ein Stück vor und nach dem jeweiligen Remove.

Ich denke jetzt aber erörtert zu haben was zumindest die Ursache ist. Es sind schlicht und einfach mittlerweile zu viele MT5 Instanzen mit jeweils zu vielen Chartfenstern in denen jeweils zu viele EAs laufen mit zusätzlich zu vielen Indikatoren. Obwohl das Hostsystem nicht einmal annähernd ausgelastet ist, führt das aber dann sporadisch zu genau diesen EA Removes.

Bei einer Verringerung der Speicher/- und Prozessorauslastung durch Entfernung von Indikatoren, Instanzen oder Verhinderung von Prozessorspitzen des Hosts, verringert sich der Effekt bzw. verschwindet dann ganz.

Ich kann den Fehler kurzzeitig erzeugen in dem ich (zumindest auf meinem System: Windows 7 Service Pack 1 (build 7601) x64, IE 8, Intel Core i7-4790K  @ 4.00GHz (4 physische Kerne), Memory: 16GB) einfach 6 MT5 Instanzen mit jeweils der maximalen Anzahl an Chartfenstern inkl. einem in jedem Chartfenster geladenen EA zeitgleich über den Autostart starte. Das System ist zwar schnell, hat aber kurzzeitig eine Vollauslastung welche der Grund für MT5 ist sporadisch dann einige EAs willkürlich aus manchen Chartfenstern zu entfernen.

Kurzum ist es zwar in Gewisser Weise ein Bug, allerdings könnte man auch behaupten ich habe, zumindest auf diesem System, wohl unzweckmäßig die Grenze der maximal gleichzeitig offenen Instanzen inklusive der maximal gleichzeitig offenen Chartfenster und EAs ausgereizt ab der dann ein solches Verhalten auftritt. Das heisst, dass zwar technisch gesehen noch viel viel mehr geht aber der Effekt dann wieder auftritt bzw. sich verstärkt.

Die Log (Beispiele.txt) zeigt Ausschnitte an den Stellen wo der Remove Auftritt. Der Hostprozessor ist zu diesen Zeitpunkten zwar nicht annähernd ausgelastet, allerdings scheinen es schlicht und einfach dauerhaft zu viele threats zu sein. Falls dann während dessen ein Re-Connect zum Broker geschieht (aus welchen Gründen auch immer), müssen einfach zu viele Prozesse gleichzeitig auf einmal angeschoben werden was dann eben genau meistens bei dem Server-Reconnect ein Entfernen der EAs im MT5 verursacht.

Ein Wunsch wäre es wenn MetaQuotes dies vielleicht zukünftig noch irgendwie abfangen könnte. Eine alternative Lösung wäre natürlich auch meine Hardware aufzurüsten.

Dateien:
Beispiele.txt 19 kb
amando
2886
amando  
Agent_Mulder:

Hallo Christian,

vielen Dank für deine Rückmeldung. Anbei eine txt-Datei mit Ausschnitten jeweils ein Stück vor und nach dem jeweiligen Remove.

Ich denke jetzt aber erörtert zu haben was zumindest die Ursache ist. Es sind schlicht und einfach mittlerweile zu viele MT5 Instanzen mit jeweils zu vielen Chartfenstern in denen jeweils zu viele EAs laufen mit zusätzlich zu vielen Indikatoren. Obwohl das Hostsystem nicht einmal annähernd ausgelastet ist, führt das aber dann sporadisch zu genau diesen EA Removes.

Bei einer Verringerung der Speicher/- und Prozessorauslastung durch Entfernung von Indikatoren, Instanzen oder Verhinderung von Prozessorspitzen des Hosts, verringert sich der Effekt bzw. verschwindet dann ganz.

Ich kann den Fehler kurzzeitig erzeugen in dem ich (zumindest auf meinem System: Windows 7 Service Pack 1 (build 7601) x64, IE 8, Intel Core i7-4790K  @ 4.00GHz (4 physische Kerne), Memory: 16GB) einfach 6 MT5 Instanzen mit jeweils der maximalen Anzahl an Chartfenstern inkl. einem in jedem Chartfenster geladenen EA zeitgleich über den Autostart starte. Das System ist zwar schnell, hat aber kurzzeitig eine Vollauslastung welche der Grund für MT5 ist sporadisch dann einige EAs willkürlich aus manchen Chartfenstern zu entfernen.

Kurzum ist es zwar in Gewisser Weise ein Bug, allerdings könnte man auch behaupten ich habe, zumindest auf diesem System, wohl unzweckmäßig die Grenze der maximal gleichzeitig offenen Instanzen inklusive der maximal gleichzeitig offenen Chartfenster und EAs ausgereizt ab der dann ein solches Verhalten auftritt. Das heisst, dass zwar technisch gesehen noch viel viel mehr geht aber der Effekt dann wieder auftritt bzw. sich verstärkt.

Die Log (Beispiele.txt) zeigt Ausschnitte an den Stellen wo der Remove Auftritt. Der Hostprozessor ist zu diesen Zeitpunkten zwar nicht annähernd ausgelastet, allerdings scheinen es schlicht und einfach dauerhaft zu viele threats zu sein. Falls dann während dessen ein Re-Connect zum Broker geschieht (aus welchen Gründen auch immer), müssen einfach zu viele Prozesse gleichzeitig auf einmal angeschoben werden was dann eben genau meistens bei dem Server-Reconnect ein Entfernen der EAs im MT5 verursacht.

Ein Wunsch wäre es wenn MetaQuotes dies vielleicht zukünftig noch irgendwie abfangen könnte. Eine alternative Lösung wäre natürlich auch meine Hardware aufzurüsten.

wieviele Chartfenster kann man denn pro Instanz offen haben? hab das noch nie probiert.

und wieviele MT installationen hast Du gleichzeig laufen? ich sag mal, das muss ja schon eine Menge sein

Carl Schreiber
Moderator
9838
Carl Schreiber  

Wie sind die Optinen eingestellt: Ctrl-O => (Tab) Experten?

Dann sprich mal mit dem Broker, vielleicht hat der da etwas so eingestellt, dass Du das falsche Signal bekommst?

Du kannst auch versuchen, das bewusst herbeizuführen, wenn Du im Terminal unten rechts einen anderen Serve (mit anderem Ping) auswählst und beobachtest, ob auch dann der EA entfernt wird und dann spiel mit den gezeigten Optionen.

12
Einloggen oder registrieren, um einen Kommentar zu schreiben