Uzak aracılar optimizasyonda çalışmıyor (bir grup x86 bilgisayar): ne yapmalı?

 

Herkese hoş geldiniz.

Bugün terminalim güncellendi ve ne büyük bir sevinç, TS'yi optimizasyon için MT5'te başlattığımda, her zamanki birkaç düzine optimizasyon iş parçacığım yerine, yerel çekirdeklerimde yalnızca iki tane var.

"Bilişim endüstrisinin gelişimini takip etme ihtiyacını" anlıyorum, ancak eski bilgisayarların parkı hala çok geniş, onları kullanmak çok makul, ancak en isteksizce "kesildim", ve "64x'e geçmeyi" teklif ediyorlar ???

Burada bilgisayarım (Core 2Duo, Win7, x32) ve yalnızca bir bilgisayarın biraz daha güçlü olduğu bir ağ var ve geri kalanı çoğunlukla "dördüncü" kütüklerde ve WinHP'de bir grup bilgisayar. Önceden, bu küme optimizasyon konusunda iyi bir iş çıkardı. Şimdi, ortaya çıktı, sadece iki çekirdeğim var.

Geliştiricilere sormak istiyorum - bana nasıl olmayı teklif ediyorlar? Kullanılabilir bilgi işlem gücünü nasıl kullanabilirim?

Anladığım kadarıyla, tüm bilgisayarların hurdaya atılması öneriliyor mu?

Hala büyük bir yığın x32 bilgisayar varken, x32 mimarisini bu kadar ani bir şekilde terk etmek cesur bir karar değil mi?

 
Evet, uzak ve mql5 ağlarında 32 bit aracıları reddediyoruz.

32 bit test cihazları sadece yerel hesaplamalarda kullanılabilir.
 
Renat :
Evet, uzak ve mql5 ağlarında 32 bit aracıları reddediyoruz.

32 bit test cihazları sadece yerel hesaplamalarda kullanılabilir.

Yani, benim gibi insanlar için - karşılığında hiçbir şey teklif etmiyor musunuz?

Çok üzgünüm.

Ve eski terminal nereden indirilir ve terminalde otomatik güncelleme nasıl kapatılır?

 
Laryx :

...

Terminalde otomatik güncelleme nasıl kapatılır?

Zaten bir kereden fazla söylendi - otomatik güncellemeyi devre dışı bırakma fırsatı yok ve olmayacak. Bunun güvenlikle de ilgisi var.
 
barabashkakvn :
Kimse zaten söylemedi - otomatik güncellemeyi devre dışı bırakma fırsatı yok ve olmayacak. Bunun güvenlikle de ilgisi var.


Görünüşe göre dün mükemmel çalışan bir sistem aniden benim için çalışmayı bıraktı ve ben onu kullanamıyorum!

İlerlemeye karşı değilim ama x64'e geçme imkanım yok ve uzun bir süre de olmayacağım ve en önemlisi - ağ bilgisayarlarını bu platforma aktaramıyorum!

Lanet olsun, en azından beni uyarırlardı ... Ve şimdi - sanırım optimizasyon hızım büyük ölçüde azaldı ... Birkaç saat için optimize ettiğim şey şimdi bir hafta sürecek ve bilgisayarım korkunç olacak bunca zaman yavaş...

Kahretsin, yersiz... Henüz WLD'ye geçmedim, MT5'te çalışmak çok güzeldi... Eh...

 
Laryx :

Yani, benim gibi insanlar için - karşılığında hiçbir şey teklif etmiyor musunuz?

Çok üzgünüm.

Ve eski terminal nereden indirilir ve terminalde otomatik güncelleme nasıl kapatılır?

Yerel ayar çalışıyor, ana 64 bit var, dizüstü bilgisayar 32'de bağlanıyor ve yardımcı oluyor, terminal 1060
 
Laryx :

Herkese hoş geldiniz.

Şimdi kontrol ettim, terminal x64 ve aracı(lar) x86 ise, o zaman her şey yolunda gidiyor.
Aracı, güncellenmemesi ve (muhtemelen) çalışmayı reddetmemesi için "ağa yayınlamadı" (tüm bulut onay kutularını kaldırdı).

Yani sistemi sadece x64 terminali için güncellemeniz gerekiyor. Ve mutluluk olacak.

 
fyords :

Şimdi kontrol ettim, terminal x64 ve aracı(lar) x86 ise, o zaman her şey yolunda gidiyor.
Aracı, güncellenmemesi ve (muhtemelen) çalışmayı reddetmemesi için "ağa yayınlamadı" (tüm bulut onay kutularını kaldırdı).

Yani sistemi sadece x64 terminali için güncellemeniz gerekiyor. Ve mutluluk olacak.

Çözüm tamamen başarılı değil.

Örneğin, sistemi altı ayda bir yeniden kurarım. Şimdi x32 maliyeti. Ondan önce x64 idi.

Ve geliştiricilerin 32-bit sistemi terk etmesi iyi değil, daha doğrusu çok, çok kötü.

 
fyords :

Yani sistemi sadece x64 terminali için güncellemeniz gerekiyor. Ve mutluluk olacak.

Evet, bunu yapmak zorunda kalacaksın.

Ancak görünüşe göre geliştiriciler ve aracılar x64'e geçiş yapacaklar - ve bu zaten kötü.

En azından bazı istatistikler toplamayı öneriyorum, kaç kullanıcı yalnızca x64 kullanıyor?

Taşınabilir kodla ilgili pek bir sorun görmüyorum. 90'ların sonlarında, bir ofiste çalışıyordum ve kod gereksinimlerinin hem 16 bit hem de 32 bit sistemlerde çalışması gerektiği açıktı. Her şey normal yazıldı, sistemlerin çok farklı olduğu yerlerde - tanımlamalar kullanıldı... Şimdi hem MT5 hem de MT4 altında tamamen değişmeden derlenen kod yazıyorum... Geliştiricilerin gerçekten x64'e geçmeye bu kadar ciddi bir ihtiyacı var mı?

Kullanıcılar için faydaları nelerdir?

 

Sistemi güncellemek niyetinde değildim ama teorik olarak yapabilirim.

Ancak, ağ bilgisayarlarında - VinHP x32 uzun süre kalacaktır. Bilgi işlem güçlerini kaybetmek istemiyorum.

Bu nedenle, geliştiriciler için böyle bir soru - x32 aracıları ne kadar daha alakalı olacak?

 

Ne yazık ki, 32 bit test cihazları için destek, uyumluluk nedeniyle (geliştiricilerin) geleceğimizi açıkça sınırlandırmaktadır.

Şu anda 32 bit platformları desteklemenin bir anlamı yok. Evet, 32 istemci terminali desteklenmeye devam edecek, ancak gelişmiş hizmetler yalnızca modern platformlarda sunulacak.

2015'te x64 işletim sistemlerine geçmeniz ve hatta XP'yi unutmanız gerekiyor. Ciddi iş söz konusu olduğunda.

Neden: