Странная проблема Access violation read - страница 2

Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Alexander
3182
Alexander  
bensk:

Вчера на 842 билде получил ошибку один раз при тестирование основного советника, по своей оплошности не сохранил лог файл этого события. Повторно вызвать ошибку на 842 пока не удалось даже при одновременной работе 5 советников. На 840 билде от брокеров ошибка у основного советника возникала в 100 % . Советник Extza на 842 тоже работает без ошибке, проверил уже раз 7-8.

 

То есть на 842 билде поймали ошибку в тестере только ?  Тестировали Extza ?
Viktor Shpakovskiy
769
Viktor Shpakovskiy  
alexloz:
То есть на 842 билде поймали ошибку в тестере только ?  Тестировали Extza ?

Однажды, на демо счет (не в тестере). Думал что легко снова ее повторю и не сохранил лог. Продолжаю тестировать основной советник, но пока не получается снова ее вызвать. Испробовал все варианты пока все работает четко.

Extza вообще не разу на 842 билде не показала ошибку. 

Viktor Shpakovskiy
769
Viktor Shpakovskiy  

Только, что обновились терминалы брокеров до 842 билда. До этого тестировал на 842 от MetaQuotes там ошибка не возникала. Но на терминалах брокеров он снова появилась. На инсте сразу после обновления. Лог прилагаю. Удалил советники с графика и заново установил при первом прогоне пока ошибку не получил.

insta_842_error 

Файлы:
Viktor Shpakovskiy
769
Viktor Shpakovskiy  

Тоже самое на терминале Альпари правда там ошибка появилась только со второго раза после обновления.

alpari_842_error 

Файлы:
Viktor Shpakovskiy
769
Viktor Shpakovskiy  

В 842 билде похоже у ошибки появилась еще одна особенность - после быстрого появления при первом же тестирование, повторно ее вызвать уже сложнее. Во всяком случае на Extza, повторно, я вызвать ее пока не смог. Но самое неприятное, что при тестировании нашего основного рабочего советника ошибка вызывается, как и прежде. Получил одинаковый результат на терминалах двух брокеров (инста и альпари). 

 842_errorr1

 

842_error2 

Viktor Shpakovskiy
769
Viktor Shpakovskiy  

Сегодня опять легко получил ошибку на 842 билде (брокера) уже на советнике Extza.

bild842_1 

Viktor Shpakovskiy
769
Viktor Shpakovskiy  

Поскольку терминал брокера регулярно выдает ошибку пришлось перейти на терминал MetaQuotes найдя там сервер брокера. И там ошибка не возникает.  Проверил и на демо. и на реале. Проверил и других брокеров не возникает ошибка в терминалах 840 билда у FxPro и Roboforex. Странно это.

MT4_842 

Viktor Shpakovskiy
769
Viktor Shpakovskiy  

И еще одна странная проблема 842 билда, своеобразное удаление объектов с графика?  Нажимаю Удалить в Trendline  вместо нее удаляется: 1) Label - синего цвета; 2) нажимаю снова, удаляется стрелка синего цвета; 3) далее исчезает стрелка красного цвета; 4) следующее нажатие удаляется горизонтальная линия; 5) пятый раз нажимаю Удалить в Trendline - удаляется вертикальная линия; 6) с шестого раза удаляется Label - розового цвета; 7) и только после того как удалены все объекты удаляется трендовая линия (Trendline) ? Т.е. трендовую линию я удалил с седьмого раза!? Это ошибка или так и задумано? В 840 билде такого нет.

 metaquotes842_2

Vitalie Postolache
11980
Vitalie Postolache  
bensk:

И еще одна странная проблема 842 билда, своеобразное удаление объектов с графика?  Нажимаю Удалить в Trendline  вместо нее удаляется: 1) Label - синего цвета; 2) нажимаю снова, удаляется стрелка синего цвета; 3) далее исчезает стрелка красного цвета; 4) следующее нажатие удаляется горизонтальная линия; 5) пятый раз нажимаю Удалить в Trendline - удаляется вертикальная линия; 6) с шестого раза удаляется Label - розового цвета; 7) и только после того как удалены все объекты удаляется трендовая линия (Trendline) ? Т.е. трендовую линию я удалил с седьмого раза!? Это ошибка или так и задумано? В 840 билде такого нет.

 

Кстати да, это уже раздражать начинает...
Alexey Da
6669
Alexey Da  
bensk:

И еще одна странная проблема 842 билда, своеобразное удаление объектов с графика?  Нажимаю Удалить в Trendline  вместо нее удаляется: 1) Label - синего цвета; 2) нажимаю снова, удаляется стрелка синего цвета; 3) далее исчезает стрелка красного цвета; 4) следующее нажатие удаляется горизонтальная линия; 5) пятый раз нажимаю Удалить в Trendline - удаляется вертикальная линия; 6) с шестого раза удаляется Label - розового цвета; 7) и только после того как удалены все объекты удаляется трендовая линия (Trendline) ? Т.е. трендовую линию я удалил с седьмого раза!? Это ошибка или так и задумано? В 840 билде такого нет.

 

Спасибо за сообщение. Принято.
123
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий