Скачать MetaTrader 5

Не работает ME под XP

Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Продавай продукты прямо в MetaTrader. Миллионы трейдеров ждут этого!
mt4trade
399
mt4trade 2014.02.20 07:38 

Вчера переустановился сам MT4 до версии 600, после чего не работает MetaEditor. Вызываю его по F4 (ну не важно как), висит секунд 10 и сам закрывается. Соответственно, ничего откомпилировать невозможно! Как работать??

Vitalie Postolache
12140
Vitalie Postolache 2014.02.20 09:52  
А версия МЕ какая? Может обновился только МТ а МЕ остался старый, вот и дуркует.
mt4trade
399
mt4trade 2014.02.20 09:57  

MetaEditorr 5.0 Build 883. Это если успеешь посмотреть, пока он не закрылся. :)

Vitalie Postolache
12140
Vitalie Postolache 2014.02.20 22:35  
mt4trade:

MetaEditorr 5.0 Build 883. Это если успеешь посмотреть, пока он не закрылся. :)


Ну допустим посмотреть можно и правым кликом по файлу МЕ, выбирая свойства, а то и просто задержав курсор на файле дожидаясь пока хинт выскочит ;)

А так-то сейчас актуальные версии МЕ 887 и МТ 610. Обновляться с демо-счёта метаквотов.

mt4trade
399
mt4trade 2014.02.21 06:08  
evillive:

Ну допустим посмотреть можно и правым кликом по файлу МЕ, выбирая свойства, а то и просто задержав курсор на файле дожидаясь пока хинт выскочит ;)

А так-то сейчас актуальные версии МЕ 887 и МТ 610. Обновляться с демо-счёта метаквотов.

Спасибо. А на реале будет работать?
SURA
47
SURA 2014.02.21 06:32  
Качни с сайта своего брокера МЕ там наверняка уже 610 билд.
Vitalie Postolache
12140
Vitalie Postolache 2014.02.21 11:47  
mt4trade:
Спасибо. А на реале будет работать?
Торговля работает как и раньше, в частности ручная, изменения касаются только языка программирования. Если торговал бот и в нём были косяки, погрешности, к которым старый компилятор был равнодушен, то новый будет строже, сразу укажет на них как на ошибки. Так что ботов сначала проверить следует, потом уже допускать к своим капиталам.
Alexey Subbotin
4998
Alexey Subbotin 2014.02.21 16:42  
evillive:
Торговля работает как и раньше, в частности ручная, изменения касаются только языка программирования. Если торговал бот и в нём были косяки, погрешности, к которым старый компилятор был равнодушен, то новый будет строже, сразу укажет на них как на ошибки. Так что ботов сначала проверить следует, потом уже допускать к своим капиталам.


Если старый бот НЕ перекомпилировать новым компилятором, работать должен в точности также. Новый терминал поддерживает боты, скомпилированные в старой версии, причем под них, как говорят разрабы, выделяется отдельная виртуальная машина, аналогичная той, что была в 500- версиях.
Vitalie Postolache
12140
Vitalie Postolache 2014.02.21 16:45  
alsu:

Если старый бот НЕ перекомпилировать новым компилятором, работать должен в точности также. Новый терминал поддерживает боты, скомпилированные в старой версии, причем под них, как говорят разрабы, выделяется отдельная виртуальная машина, аналогичная той, что была в 500- версиях.
Поддержка эта через полгода закончится, по-любому придётся код править под новый билд, так что лучше начинать прямо сейчас.
Alexey Subbotin
4998
Alexey Subbotin 2014.02.21 17:01  
evillive:
Поддержка эта через полгода закончится, по-любому придётся код править под новый билд, так что лучше начинать прямо сейчас.

Рано или поздно закончится поддержка всего. Поэтому гроб лучше заказывать уже сейчас, со скидкой.
Alexey Viktorov
6923
Alexey Viktorov 2014.02.21 17:29  
evillive:
Поддержка эта через полгода закончится, по-любому придётся код править под новый билд, так что лучше начинать прямо сейчас.

Не закончится.

В 610ом билде работает советник написанный в 2005 году и использующий функцию CurTime() которую заменили ещё хз когда на TimeCurrent()

123456
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий