Erro Array apenas na MODAL

Para adicionar comentários, por favor Faça o login ou registrar
maronezzi
43
maronezzi  

Caros,

Venho mais essa vez compartilhar uma dúvida, coloquei o meu robô para rodar pela Modal, no segundo comando retornou o seguinte erro:

"array out of range in 'xxxx.mq5'"


Acontece que tenho o mesmo robô rodando na XP por mais de 2 meses e nunca apareceu esse erro.


Muito obrigado.

Daniel Andrejczuk
5698
Daniel Andrejczuk  
maronezzi:

Caros,

Venho mais essa vez compartilhar uma dúvida, coloquei o meu robô para rodar pela Modal, no segundo comando retornou o seguinte erro:

"array out of range in 'xxxx.mq5'"


Acontece que tenho o mesmo robô rodando na XP por mais de 2 meses e nunca apareceu esse erro.


Muito obrigado.

Bom dia,

O ideal é entrar em contato com o desenvolvedor do Robô, para ele poder depurar e corrigir o erro.

Esse erro as vezes pode ocorrer por falta de alguns dados nos ticks em conta demo que podem ser utilizados no EA.

Att.

Daniel

maronezzi
43
maronezzi  
Daniel Andrejczuk:

Bom dia,

O ideal é entrar em contato com o desenvolvedor do Robô, para ele poder depurar e corrigir o erro.

Esse erro as vezes pode ocorrer por falta de alguns dados nos ticks em conta demo que podem ser utilizados no EA.

Att.

Daniel

Bom dia Amigo,


O E.A. em questão fui eu que desenvolveu, como disse ele roda sem falhas a mais de dois meses na conta real da XP, mas na Modal, deu esse erro de Array e ontem o log indica claramente o envio da ordem, com retcode 10009, tudo correto, mas a ordem não apareceu, acho que a Modal ainda tem muito a melhorar.

Alguém já teve algo parecido?

Marcelo Rodrigo Basi
2614
Marcelo Rodrigo Basi  
maronezzi:

Bom dia Amigo,


O E.A. em questão fui eu que desenvolveu, como disse ele roda sem falhas a mais de dois meses na conta real da XP, mas na Modal, deu esse erro de Array e ontem o log indica claramente o envio da ordem, com retcode 10009, tudo correto, mas a ordem não apareceu, acho que a Modal ainda tem muito a melhorar.

Alguém já teve algo parecido?

na Modal as ordens tem que ser do tipo Return, talvez isso tenha alguma coisa a ver com o seu erro. 

maronezzi
43
maronezzi  
forgottenn:

na Modal as ordens tem que ser do tipo Return, talvez isso tenha alguma coisa a ver com o seu erro. 

Consegui executar a operação, fui no site, zerei as margens e habilitei novamente. Agora executaram as ordens.


Obrigado.

Arthur Albano
726
Arthur Albano  
maronezzi:

Caros,

Venho mais essa vez compartilhar uma dúvida, coloquei o meu robô para rodar pela Modal, no segundo comando retornou o seguinte erro:

"array out of range in 'xxxx.mq5'"


Acontece que tenho o mesmo robô rodando na XP por mais de 2 meses e nunca apareceu esse erro.


Muito obrigado.

A Modal apresenta volumes custodiados divergentes na plataforma do Metatrader e ordens fantasma (lixo). Logo, nenhum robô vai operar direito na Modal...
Para adicionar comentários, por favor Faça o login ou registrar