Virtual server - do not make trades when I went live

To add comments, please log in or register
Nufstad
170
Nufstad  

Hello.

 

I have been testing an EA on MT4 with success. Just demo account and 1 month virtual server. 

I have now gone live and now it does not make trades. Migrassion to the virtual server is OK. In the top of my charts on my PC is says, "EA is not available, make sure that experts are anabled (AutoTrading button and EA propeties)

Can it be a problem that I used 1-month virtual server and started 1 year virtual server live and not cancelled the 12 month?

When I turn on "Autotrading" it dissapears from the chart window and it trades. But not on the virtual server. 

Any suggestions?

 

Virtual hosting for MetaTrader 5
Virtual hosting for MetaTrader 5
  • www.mql5.com
Virtual hosting for MetaTrader 4/5 is the best VPS solution for Forex. It is cheap, it requires no configuration and it features minimum delays to the server. For only $10 per month, you obtain a virtual platform that works around the clock, saves your profit and pays off. Create a remote copy of the application directly from the platform...
Files:
chart.jpg 160 kb
Sergey Golubev
Moderator
116976
Sergey Golubev  
If you are talking about MQL5 VPS for MT4/MT5 so autotyrading is always ON in this VPS.
And it is better ti have autotrading to be off on your local Metatrader.
Because MQL5 VPS for MT4/MT5 is "the copy of your Metatrader in cloud" with autotrading ON (and your EA or signal subscription should trade on this VPS).
Virtual hosting for MetaTrader 5
Virtual hosting for MetaTrader 5
  • www.mql5.com
Virtual hosting for MetaTrader 4/5 is the best VPS solution for Forex. It is cheap, it requires no configuration and it features minimum delays to the server. For only $10 per month, you obtain a virtual platform that works around the clock, saves your profit and pays off. Create a remote copy of the application directly from the platform...
Sergey Golubev
Moderator
116976
Sergey Golubev  
Nufstad:...
In the top of my charts on my PC is says, "EA is not available, make sure that experts are anabled (AutoTrading button and EA propeties)
...

 

Autoitrading is always ON in VPS (and your EA should trade in VPS).
But your chart is on your home computer, right? It should be OFF in youir home computer (because it is ON in VPS).

Nufstad
170
Nufstad  

Chart is on my home computer. If I turn on Autotrading it trades. But if I turn computer off, then no trades are made. But VPS do not trade. It worked on demo account.


If I attach a standard EA from MT4 (which is delivered with the program) the message does not appear on the chart. 

Juvenille Emperor Limited
Moderator
13109
Eleni Anna Branou  
Nufstad:

Chart is on my home computer. If I turn on Autotrading it trades. But if I turn computer off, then no trades are made. But VPS do not trade. 


If I attach a standard EA from MT4 (which is delivered with the program) the message does not appear on the chart. 

Post a screenshot of your VPS journal (not your local MT4/5 Journal tab). Right click in your MQL5 VPS >> Journals.

When you use MQL5 VPS it doesn't matter what your local MT4/5 terminal setup you've got, but what you've migrated to the virtual server.

Nufstad
170
Nufstad  

Se attachment. 


When I search for errors, no errors occurs.

Files:
j.jpg 1081 kb
Juvenille Emperor Limited
Moderator
13109
Eleni Anna Branou  
Nufstad:

Se attachment. 


When I search for errors, no errors occurs.

Your synchronization looks OK, but I couldn't know of course if your settings and chart setups (timeframe etc.) are correct in order to make a trade.

The fact that you are trading on the H4 timeframe maybe is the reason for not so frequent trades (or not trading yet).

Your trading environment has been migrated correctly to the MQL5 VP server.
Nufstad
170
Nufstad  

As I said it worked with the demo account. So that is why I do not know what is wrong. I do not remember if the same message was in the chart on mye home computer with the demo.


I turned on autotrading and then synchronized agian. Then turned autotrade on so no dobble trades are made. 


But when I attach a default EA from MT4 to a chart. Only a sad face :( occurs up in the right corner. So I no not understand

Documentation on MQL5: Constants, Enumerations and Structures / Environment State / Account Properties
Documentation on MQL5: Constants, Enumerations and Structures / Environment State / Account Properties
  • www.mql5.com
, then each symbol positions will be closed in the same order, in which they are opened, starting with the oldest one. In case of an attempt to close positions in a different order, the trader will receive an appropriate error. There are several types of accounts that can be opened on a trade server. The type of account on which an...
Juvenille Emperor Limited
Moderator
13109
Eleni Anna Branou  
Nufstad:

As I said it worked with the demo account. So that is why I do not know what is wrong. I do not remember if the same message was in the chart on mye home computer with the demo.


I turned on autotrading and then synchronized agian. Then turned autotrade on so no dobble trades are made. 

Are you sure that your EA is MQL5 VPS compatible?

If it uses DLL, it will not work on MQL5 VPS for example.

Nufstad
170
Nufstad  
It worked on a demo account on a VPS so it should
Documentation on MQL5: Constants, Enumerations and Structures / Environment State / Account Properties
Documentation on MQL5: Constants, Enumerations and Structures / Environment State / Account Properties
  • www.mql5.com
, then each symbol positions will be closed in the same order, in which they are opened, starting with the oldest one. In case of an attempt to close positions in a different order, the trader will receive an appropriate error. There are several types of accounts that can be opened on a trade server. The type of account on which an...
Juvenille Emperor Limited
Moderator
13109
Eleni Anna Branou  
Nufstad:
It worked on a demo account on a VPS so it should

True, but somewhere there is a problem and as far as you say and we can see looks OK.

Anyway, I see your last synchronization was some hour ago and you are trading in H4, so maybe there aren't any trades to be opened yet, maybe you should just wait.
12
To add comments, please log in or register