Input values being reset when switching tabs.

To add comments, please log in or register
Yaroslav Troshchey
582
Yaroslav Troshchey  

Hi everyone :),


I've currently got a freelancer working on an EA for myself and there's one strange bug that I can recreate but they are unable to.


Basically when changing variables in the 'input' tab on the strategy tester I find that they get automatically reset if I tab out of the 'input' tab and go back in.


I'm not really sure what could be causing this issue but any help would be massively appreciated.


Cheers,

Yaroslav Troshchey
582
Yaroslav Troshchey  

Just to follow up on this, when values for variables have been changed any new backtests are done with the changed variables but the inputs tab still shows the old variables.


However, running a second backtest uses the original unmodified values in the inputs tab.

Yaroslav Troshchey
582
Yaroslav Troshchey  

After various testing I have found out that my instances of MT5 installation seem to reset the inputs for variables in EA's no matter which EA is running. I have never had this happen before so am unsure as to what the fix is.


Would massively appreciate any support as i'm unable to backtest anything at the moment.


I have tried multiple broker platforms and they all have the same issue, have even tried to set it up on a different PC but no luck there.

Yaroslav Troshchey
582
Yaroslav Troshchey  
Here is a gif showing the error at hand - https://imgur.com/a/buNFx7c 
Mark Flint
2172
Mark Flint  

I have seen this on some of my MT5 installations. Some do it, some don't.  

I switched all my testing to use a live broker account, and things seemed to have settled down with regard to the Inputs Tab problem.  I documented this and other issues here https://www.mql5.com/en/forum/305758 .

I found that MT5 latest build 2006 and build 2007 have many issues with the testing environment.  Looking the issues up is now a little difficult as it seems you can't search for 'build 2007' anymore. The MetaQuotes search engine now returns no forum articles for 'build 2007' or 'build 2006', which indicates they have blocked the search terms to prevent people looking up issues with these builds.  

I hope an improved release addressing these issues comes out very soon!

MT5 build 2007 - optimisation is broken. Rerun of tests silently fail. Often optimisation results give wildly different results when ‘Run Single Test’. Number of CPU cores affects results.
MT5 build 2007 - optimisation is broken. Rerun of tests silently fail. Often optimisation results give wildly different results when ‘Run Single Test’. Number of CPU cores affects results.
  • 2019.03.05
  • www.mql5.com
Having become quite frustrated with MT5 builds 2006 and 2007, I decided to create a reproducible case using MQL example code (Moving Averages EA) f...
Yaroslav Troshchey
582
Yaroslav Troshchey  
Mark Flint:

I have seen this on some of my MT5 installations. Some do it, some don't.  

I switched all my testing to use a live broker account, and things seemed to have settled down with regard to the Inputs Tab problem.  I documented this and other issues here https://www.mql5.com/en/forum/305758 .

I found that MT5 latest build 2006 and build 2007 have many issues with the testing environment.  Looking the issues up is now a little difficult as it seems you can't search for 'build 2007' anymore. The MetaQuotes search engine now returns no forum articles for 'build 2007' or 'build 2006', which indicates they have blocked the search terms to prevent people looking up issues with these builds.  

I hope an improved release addressing these issues comes out very soon!

Thank you for the reply! I thought I was the only one with this issue.

I will try a live account and if that fails just MT4.


I don't suppose you can download older builds of MT5, or does it automatically update?

Marco Scazzi
9
Marco Scazzi  
even with the update today 15 March 2019, the same problem.
Yaroslav Troshchey
582
Yaroslav Troshchey  
Marco Scazzi:
even with the update today 15 March 2019, the same problem.

Where is the new update? I still only have access to the February version of MT5

Yaroslav Troshchey
582
Yaroslav Troshchey  
Just a quick update, I tried using a live account but it made no difference, still not able to change input values.
Rexthedog
5
Rexthedog  

I'm also having the same issue. If I change an input variable on the inputs tab of the strategy tester then tab out of it and tab back in, all my metrics revert back to their defaults.


I believe I am running the latest MT5 on a windows 7 Machine.


Was anyone able to determine the fix? 

Yaroslav Troshchey
582
Yaroslav Troshchey  
Rexthedog:

I'm also having the same issue. If I change an input variable on the inputs tab of the strategy tester then tab out of it and tab back in, all my metrics revert back to their defaults.


I believe I am running the latest MT5 on a windows 7 Machine.


Was anyone able to determine the fix? 

Nothing yet, it seems to be hit or miss at the moment.


I've tried the latest version of MT4 and that seems absolutely fine and older versions of MT5 have been fine for me it's just the latest version.

To add comments, please log in or register