NonLag MA ver.7.1 slows the computer, pls help

psaini1973
32
psaini1973  

Hello Frnds. i am using nonlagma ver7.1email alert, i am using it on 5-6 pairs simultaneously, to my surprise it slows the pc too much even if i use it on 1-2 pairs, i must mention that i am using two nonlagma of diff. value on a single pair chart. Even if i switch from diff. TF it takes much much time to change. So can anybody help me, can anybody take a look inside the mql coding and make some changes so that it works fast. i would be really greatfull to the person, i am also attaching the nonlag ver7.1. I am using two brokers for the nonlagma to test nonlagma , one is Mt4 Ver. 409 and the other is MT4 ver. 419 The settings of nonlagma thet i am using are as follows, thanks

Price: 0

Length: 40

Displace: 0

Pcfilter:0.5

Deviation: 0

Mladen Rakic
200848
Mladen Rakic  

...

Why don't use one of igorads originals?

Here is a thread with a lot of versions https://www.mql5.com/en/forum/general (version 7.1 too) with alerts too (set the alert mode to > 0 and you will have alerts in igorads originals too)

psaini1973:
Hello Frnds. i am using nonlagma ver7.1email alert, i am using it on 5-6 pairs simultaneously, to my surprise it slows the pc too much even if i use it on 1-2 pairs, i must mention that i am using two nonlagma of diff. value on a single pair chart. Even if i switch from diff. TF it takes much much time to change. So can anybody help me, can anybody take a look inside the mql coding and make some changes so that it works fast. i would be really greatfull to the person, i am also attaching the nonlag ver7.1. I am using two brokers for the nonlagma to test nonlagma , one is Mt4 Ver. 409 and the other is MT4 ver. 419 The settings of nonlagma thet i am using are as follows, thanks

Price: 0

Length: 40

Displace: 0

Pcfilter:0.5

Deviation: 0
psaini1973
32
psaini1973  
mladen:
Why don't use one of igorads originals? Here is a thread with a lot of versions https://www.mql5.com/en/forum/general (version 7.1 too) with alerts too (set the alert mode to > 0 and you will have alerts in igorads originals too)

Sir thank you so much. i ll have a look at the link provided by you.

psaini1973
32
psaini1973  

Dear sir mladen, i have gonr thru the thread which u gave, i downloaded the original ver. of nonlagma and used it but it also slows down the pc. I suppose the nonlagma was created 5 years back by "igorad". At that time MT4 ver. 202 or 203 was being used and now MT4 ver. 409-419 is being used, wat i am trying to say is that may be the diff. between the ver. of MT4 is making nonlagma slow.. its the same ver. used for the last 5 years , the way MT4 compiles and decompiles an indicator has changed from the last 5 years, may be it requires re-coding according to the latest MT4 ver. to make work fast. I have no idea about the mql its just my guess, i just want nonlagma to work fast bcos it really slows down my pc..

Sir if their is a solution pls do let me know. Thank you

Mladen Rakic
200848
Mladen Rakic  

...

How many bars are you using on chart (in the tool->options->max bars in chart) ?

I am using 5000 for the last 3-4 years and I find it enough for any trading and any job I do on metatrader. Using more bars on chart can slow you down, but igorads indicator was made to recalculate only the bars changed since previous tick so 99.99% of time it is calculating only 1 or 2 bars which can not be a cause for slowing mt down. If you have a great number of bars on chart then when you change time frame or symbol you will have a slowdown (all the chart bars needed to be calculated) but other than that, with NonLagMA there should be no problem.

psaini1973:
Dear sir mladen, i have gonr thru the thread which u gave, i suppose the nonlagma was created 5 years back by "igorad". At that time MT4 ver. 202 or 203 was being used and now MT4 ver. 409-419 is being used, wat i am trying to say is that may be the diff between the ver. of MT4 is making nonlagma slow.. its the same ver. used for the last 5 years , the way MT4 compiles and decompiles an indicator has changed from the last 5 years, may be it requires re-coding according to the latest MT4 ver. to make work fast. I have no idea about the mql its just my guess, i just want nonlagma to work fast bcos it really slows down my pc.. Sir if their is a solution pls do let me know. Thank you
psaini1973
32
psaini1973  
mladen:
How many bars are you using on chart (in the tool->options->max bars in chart) ? I am using 5000 for the last 3-4 years and I find it enough for any trading and any job I do on metatrader. Using more bars on chart can slow you down, but igorads indicator was made to recalculate only the bars changed since previous tick so 99.99% of time it is calculating only 1 or 2 bars which can not be a cause for slowing mt down. If you have a great number of bars on chart then when you change time frame or symbol you will have a slowdown (all the chart bars needed to be calculated) but other than that, with NonLagMA there should be no problem.

I was using 20000 bars but now i changed to 5000 as u recommended, but still its slow... i am using two nonlagma on a single pair chart whose length values are 50 and 200,(total 6 charts being used simultaneously) could this be the factor for slowing down the computer while changing the time frames? thanks

Mladen Rakic
200848
Mladen Rakic  

...

Same settings as yours, see the terminal in the list (just above the darkened line) and the [percentage of CPU used by it

So, I really can not replicate the problem you have. Sorry

psaini1973:
I was using 20000 bars but now i changed to 5000 as u recommended, but still its slow... i am using two nonlagma on a single pair chart whose length values are 50 and 200, could this be the factor for slowing down the computer while changing the time frames? thanks
Files:
terminal.gif 89 kb
psaini1973
32
psaini1973  

Basically it slows down when i change in between the timeframes, it takes around 5-7 seconds to change from 15 min tf to 30 min tf or any other tf.

Sir thank you so much for the kind help and effort that u have put in for my problem, i guess may be i ll have to live with this problem...

secretcode
898
secretcode  
psaini1973:
Basically it slows down when i change in between the timeframes, it takes around 5-7 seconds to change from 15 min tf to 30 min tf or any other tf. Sir thank you so much for the kind help and effort that u have put in for my problem, i guess may be i ll have to live with this problem...

Hi Psaini

May be you have too much data in " LOGS " folder !!!

Clean your logs folder...

MT4 > logs

MT4 > experts > logs

Hope it helps

secretcode

psaini1973
32
psaini1973  

Hello secretcode. first of all thank you very much for telling me a new thing in MT4 which i didnt knew, from now on onwards i will be clearing the logs on regular basis. As for any positive effect this log clearing had in my nonlagma slowing down the computer.. no... when i change the TF its still slows or hangs the computer.. cant find any solution to this problem.. thanks