Download MetaTrader 5

Feature request: UTF-8 source file support

To add comments, please log in or register
micclly
189
micclly  

I will be happy if MT4 supports UTF-8 source files.

Currently, MT4 build 6xx supports system locale codepage encoding and UTF-16LE.

UTF-16LE is locale-independent encoding, but has the following problem:

  • Some tools recognize UTF-16LE files as binary (ex. git).
  • Not only tools but also some of web services treat UTF-16LE files as binaries (ex. GitHub).

I hope MetaEditor supports UTF-8, additionaly, use it as default encoding.

To say again, UTF-16LE is not de facto.

iJSmile
211
iJSmile  
micclly:

I will be happy if MT4 supports UTF-8 source files.

Currently, MT4 build 6xx supports system locale codepage encoding and UTF-16LE.

UTF-16LE is locale-independent encoding, but has the following problem:

  • Some tools recognize UTF-16LE files as binary (ex. git).
  • Not only tools but also some of web services treat UTF-16LE files as binaries (ex. GitHub).

I hope MetaEditor supports UTF-8, additionaly, use it as default encoding.

To say again, UTF-16LE is not de facto.

I have the same problem. Can't add my sources to git, it says that my .mq4 files are binary files. Even adding .gitattributes file doesn't help.. Does anyone have the same issue? Maybe there is a workaround?

UPDATE: Didn't find anything better and my quick workaround was: open mq4 in notepad++  and change encoding to UTF-8 (Encoding Tab).
Stanislav Korotky
20335
Stanislav Korotky  
micclly:

I will be happy if MT4 supports UTF-8 source files.

Please create an issue in the service desk and let us know how it goes. This is very important issue. Personally, I'm also interested in this feature.

As this is a MetaEditor problem, it affects both MT4 and MT5.

Meanwhile, could you please tell us which wide symbols do you use in your sources? Actually, UTF-16 is enabled (automatically) only if you use a non-latin symbol in the source. If it's an occasional symbol, you can remove it and get plain text.
whroeder1
15576
whroeder1  
iJSmile: I have the same problem. Can't add my sources to git, it says that my .mq4 files are binary files. Even adding .gitattributes file doesn't help.. Does anyone have the same issue? Maybe there is a workaround?
There must be something, since Metaquotes says GitHub now supports the MQL5 and MQL4 languages - General - MQL5 programming forum

To add comments, please log in or register