Скачать MetaTrader 5

комментарии кода: "//??????????"

Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий
Mamma
308
Mamma  
У меня компьютер заточен под English и в MetaEditor комментарии к коду на русском выглядят так: "//??????????". Могу менять язык кнопок программы на русский через меню View > Language, но комментарии всё равно "???". Искал инфу на сайте metaquotes, но лишь нашел, что: 1. есть такой MultiLanguage Pack, которым это, вроде, можно отрегулировать; 2. начиная с билда 200 он убран из программы; 3. не вижу его отдельно для скачивания. Может кто сталкивался?
Mamma
308
Mamma  

С трудом верится, что никто не сталкивался с этим... Помогите pls, а то извращаюсь - открываю броузером .mq4 чтоб каменты увидеть :)

Petr
49
Petr  

Приветсвую, Вас!

Благодарю за архив. Отвечал письмом вчера, да только оба вернулись. Ну да ладно.

Я сталкивался с подобной проблемой, когда винда была 95-ой и нерусифицированной. Приходилось в нее руками прописывать 866 кодировку и фонты системные добавлять.

Где-то в этом месте собака порылась.

Вы напишите какая у Вас винда и разработчикам будет проще Вам подсказать.

Удачи.

Mamma
308
Mamma  

Здравствуйте!
Спасибо за отклик!
Вот такая Винда:

Действительно нерусифицированная. В Regional&Language Settings>Advanced tab все Russian/Cyrillic шрифты отмечены. Что еще надо добавить?

Victor Nikolaev
Модератор
15315
Victor Nikolaev  
mamma писал (а) >>

Здравствуйте!
Спасибо за отклик!
Вот такая Винда:

Действительно нерусифицированная. В Regional&Language Settings>Advanced tab все Russian/Cyrillic шрифты отмечены. Что еще надо добавить?

Возможно проблема с кодовой страницей 1252. Но для этого надо в реестр лезть

kombat
3278
kombat  

REGEDIT4

;Файл реестра для устранения проблем с отображением русских шрифтов в Windows 2k/XP/2k3

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"
"1253"="c_1251.nls"
"1254"="c_1251.nls"
"1255"="c_1251.nls"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontMapper]
"ARIAL"=dword:000000cc

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
"Arial,0"="Arial,204"
"Comic Sans MS,0"="Comic Sans MS,204"
"Courier,0"="Courier New,204"
"Courier,204"="Courier New,204"
"MS Sans Serif,0"="MS Sans Serif,204"
"Tahoma,0"="Tahoma,204"
"Times New Roman,0"="Times New Roman,204"
"Verdana,0"="Verdana,204"

Вдруг поможет. ;)

Блокнот. Сохранить как file_rus.reg

Запустить, сказать ок...

Ещё вариант:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"
"1253"="c_1251.nls"
"1254"="c_1251.nls"
"1255"="c_1251.nls"

Mamma
308
Mamma  
Я посмотрел в registry - там кодировка 1252 упоминается в нескольких ключах. Знать бы что править. Вы не в курсе?
Mamma
308
Mamma  
Упс! Спасибо, попробую.
Mamma
308
Mamma  
сделал, перезагрузил, но не сработало
Евгений
63
Евгений  
Установите MUI, точно поможет.
Mamma
308
Mamma  
у меня ХР НОМЕ - на неё МUI нe ставится...
спасибо за идею
12
Авторизуйтесь или зарегистрируйтесь, чтобы добавить комментарий