Problemas ao executar teste pelo MetaEditor

victorsena98  

Bom dia pessoal,

Estou com o seguinte problema, ao clicar no ícone executar teste direto pelo MetaEditor, o testador de estratégias abre e executa um código diferente do que eu estava executando. Percebi que na pasta Tester não foi criado um arquivo para o meu código, mesmo eu  mandando compilar o código repetidas vezes. Alguém tem alguma ideia do que pode estar acontecendo?


Desde já agradeço !

Jonathan Pereira  
victorsena98:

....

Isso aja me aconteceu umas duas vezes,  e estranhamente meu meta editor se bagunçou todo...solução foi reiniciar a maquina.

victorsena98  
Rogerio Giannetti Torres:

Olá boa tarde,

acho que vc está falando desses dois botões do MetaEditor (ver abaixo), pois bem a função principal desses botões é para depurar o fonte que está sendo editado. Vc está dizendo que não está depurando o fonte que está sendo editado ?  Tem certeza?


É exatamente esse ícone azul Rogério, uso ele pra depurar meu código colocando pontos de parada, porém assim que aciono o botão, ele começa a executar um outro código. Na imagem 1 que anexei o arquivo que mando executar é o bandasBollinger, porém meu  testador de estratégia já abre executando o arquivo Moving Average. Não é a primeira vez que isso acontece, tive que reinstalar o Metatrader da ultima vez por causa desse mesmo problema

Arquivos anexados:
victorsena98  
Jonathan Pereira:

Isso aja me aconteceu umas duas vezes,  e estranhamente meu meta editor se bagunçou tudo...solução foi reiniciar a maquina.

Menos mal Jonathan, o meu nem reiniciando voltou ao normal. Já estou pensando em reinstalar a plataforma 
Rogerio Giannetti Torres  
victorsena98:

É exatamente esse ícone azul Rogério, uso ele pra depurar meu código colocando pontos de parada, porém assim que aciono o botão, ele começa a executar um outro código. Na imagem 1 que anexei o arquivo que mando executar é o bandasBollinger, porém meu  testador de estratégia já abre executando o arquivo Moving Average. Não é a primeira vez que isso acontece, tive que reinstalar o Metatrader da ultima vez por causa desse mesmo problema

Antes de reinstalar, tente o seguinte,  vá para a pasta ....\MQL5\Cofig e delete os arquivos terminal.ini e metaeditor.ini.

victorsena98  
Rogerio Giannetti Torres:

Antes de reinstalar, tente o seguinte,  vá para a pasta ....\MQL5\Cofig e delete os arquivos terminal.ini e metaeditor.ini.

Pode até parecer brincadeira, mas eu reinstalei e continua o mesmo problema. Depois de verificar que o problema continuava eu fiz isso que você falou Rogerio mas sem sucesso. O engraçado é que quando eu seleciono o arquivo direto pelo testador de estratégias ele roda normalmente, o problema é que assim fica mais difícil de encontrar falhas 
Ruy Christian Hoffmann  
victorsena98:
Pode até parecer brincadeira, mas eu reinstalei e continua o mesmo problema. Depois de verificar que o problema continuava eu fiz isso que você falou Rogerio mas sem sucesso. O engraçado é que quando eu seleciono o arquivo direto pelo testador de estratégias ele roda normalmente, o problema é que assim fica mais difícil de encontrar falhas 

Victor,

Você está com mais de uma instância no seu computador?

Se sim, você deve seguir os passos acima do rogério em todas as instâncias... bem como atualizar pelo live update todas também.

victorsena98  
Ruy Christian Hoffmann:

Victor,

Você está com mais de uma instância no seu computador?

Se sim, você deve seguir os passos acima do rogério em todas as instâncias... bem como atualizar pelo live update todas também.

Estou usando apenas uma instância mesmo, dei uma pesquisada no fórum em inglês e encontrei outras pessoas que estão com o mesmo erro, mas infelizmente ninguém conseguiu resolver ainda. Espero que na próxima atualização já tenha corrigido esse problema. Mas se tiver mais alguma suposição iria ajudar muito, porque é muito ruim ficar sem a opção de debug 
Razão: