Problemas de conexion metatester y agentes locales

 
Hola, he creado una red con varios ordenadores, usando los agentes locales, el caso es que se desconectan continuamente y no hay manera de tener una conexión estable. Tengo los puertos abiertos tanto en router como en firewall, pero aun asi, se conecta pero al instante se vuelve a desconectar sin lograr que terminen de funcionar correctamente.
 
Daniel Polo Pradanos:

Las causas pueden ser muchas....usualmente por problemas de falta de memoria o por utilizar cores lógicos y no físicos. Tenga también en cuenta que el antivirus debe estar correctamente configurado.

Haga pruebas siempre de menos a más usando un solo core y alguna tarea sencilla y vaya incrementando el número de cores a razón de los recursos libres. Por ejemplo, cada agente/core puede llegar a emplear 2 GB por agente, lo que utilizando 8 cores ya requeriría una RAM de 16 GB, a eso súmele sistema operativo, etc.

Mucha gente conecta muchos ordenadores pensando solamente en tener un gran número de cores sin tener en cuenta la RAM (portátiles con 2, 4 u 8  GB de RAM).

 
Gracias por la respuesta, en mi caso mi ordenador tiene 32GB de ram, y si, he probado a usar un solo agente, pero ni con esas consiguen conectar entre sí, el caso es que si podemos usarlo para vender las potencias computacionales para la cloud network, pero entre nuestros ordenadores no terminan de conectar. 
 
Daniel Polo Pradanos #:

Mire los registros de los agentes, hay mucha información allí.

Ejemplo:

Ej

 



Aparece esto todo el tiempo.. 

 
Daniel Polo Pradanos #:

Pruebe esto:

1. Marque "Cortafuegos avanzado" -> sección "Reglas de entrada" -> "Agente probador de estrategias de MetaTrader 5", haga clic en la pestaña "Avanzado", marque todos los tipos de "Perfiles", también vaya a "Tipos de interfaz", marque "Todas las interfaces".

2. Marque "Permitir una aplicación a través de la opción de firewall" -> "Cambiar configuración" -> "Permitir otra aplicación" -> "Agregar" y busque "MetaTrader 5 Strategy Tester Agent" para que pueda finalmente trabajar. (MT5 no agrega esto automáticamente)

Como dije anteriormente el problema puede estar en cualquier punto, antivirus, cortafuegos, router, direcciones IP, puertos TCP, etc. Revise cada paso detenidamente.

Normalmente este tipo de problemas que solo reporta un usuario (no he encontrado ninguna otra queja en otros foros como el inglés o ruso con mucha más actividad), suelen ser problemas de una mala configuración por parte del usuario.

 

Perfecto, ya está solucionado, el problema estaba en los Tipos de perfiles! Muchas Gracias !!! 

 
Daniel Polo Pradanos #:

Me alegro de que lo haya solucionado. ;)

Razón de la queja: