Download MetaTrader 5

Cannot install Metatrader 5

To add comments, please log in or register
anupshinde
35
anupshinde 2012.03.07 07:16 

Cannot install Metatrader 5. Once I execute mt5Setup it shows me the window attached asking for proxy server. If I click cancel it ends with an error. Attached both snapshots. I am using Windows 7 64 bit but I have tested it on other machine with Windows 7 32 bit.

I don't use a proxy server - connected through a router. Only have a I have tried both 64 bit and 32 bit installers, tried with combination of compatibility modes, tried with admin permissions - but no help. MT4 works fine and most other internet-consuming applications are working fine.

Am I missing something obvious? since I searched over Google and I cant find anything related.

Thanks. 

Files:
Capture.PNG 47 kb
Capture2.PNG 32 kb
Amit Suryakant Jamuda
1182
Amit Suryakant Jamuda 2015.05.02 15:04  

I am facing the same problem while installing MT4 and MT5 in my new laptop. The OS is Ubuntu Linux.

 While installing it asks for a proxy server details. I don't have a proxy server, I am connected via wifi. 

ScienziatoBesti
13
ScienziatoBesti 2015.06.17 04:36  
Amit Suryakant Jamuda:

I am facing the same problem while installing MT4 and MT5 in my new laptop. The OS is Ubuntu Linux.

 While installing it asks for a proxy server details. I don't have a proxy server, I am connected via wifi. 

same problem. Someone can help?
BobTastic9000
33
BobTastic9000 2015.06.18 00:55  

I'm getting the same problem too (Kubuntu Vivid 15.04 & Wine 1.7.38 from the Ubuntu PPA).  I have a proxy server set-up (and working with Linux Firefox) but even putting that into the proxy details box in the installer doesn't help.  I can see from my proxy server's log files that it is connecting, and then attempting to connect to some addresses like api<number>.mql5.com:443, then the app just asks for the proxy details again...

When running the app (wine mt5setup.exe), the only error that wine appears to give is:

err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.

I'm quite sure libgnutls is installed on my system, so my assumption is that the installer isn't able to make a secure connection to the mql5 servers.

I also did some searching on the net, but couldn't find any other solutions to this, so maybe this is only a problem with the most recent installer (build 1150).

I have MT5 running on my Windows box, but ideally I'd like to switch it over to Linux at some point.

Widy Prasetyo
473
Widy Prasetyo 2015.06.19 05:29  

MetaTrader 4 and MetaTrader 5 installer need to download all files (Online Installer) and it check whether user are using proxy or not.

If you connect internet using proxy, then you should fill that proxy address, but if you didn't connect using proxy, just click cancel.

It's often result with cross (red), meaning can not connect to MetaTrader server and can not download complete installer. The solution is keep trying over and over again, usually it will succedd after 3 or 4 times re-run installer.

I don't know for Linux user, buat I think it's same.

nophelpin
5
nophelpin 2015.09.13 20:25  
Widy Prasetyo:

MetaTrader 4 and MetaTrader 5 installer need to download all files (Online Installer) and it check whether user are using proxy or not.

If you connect internet using proxy, then you should fill that proxy address, but if you didn't connect using proxy, just click cancel.

It's often result with cross (red), meaning can not connect to MetaTrader server and can not download complete installer. The solution is keep trying over and over again, usually it will succedd after 3 or 4 times re-run installer.

I don't know for Linux user, buat I think it's same.

alx5
5
alx5 2016.02.27 18:34  
Same problem here. I'm not behind proxy, running Ubuntu Linux 14.04. Reattempting and hitting Cancel button did not change the result
japrogramer
33
japrogramer 2016.03.02 00:36  
I also have the same problem, hitting Cancel multiple times has not help...
err:winediag:schan_imp_init Failed to load libgnutls, secure connections will not be available.
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

,

i found a soultion tho, the 32 bit version of gnutls needs to be installed.. on my platform the command was

sudo pacman -S lib32-gnutls


you have to make sure that multilibs are enabled

Danyel80
6
Danyel80 2016.03.30 16:24  

Right now, Metatrader5 doesn't work in my Debian and Mint. It keeps endlessly asking my login, server and password when I try to install it. Wine is update on both. It worked well for more than 3 months. Now it's very dead. Its very frustrating. I think MT5 is a lovely yet unstable backup alternative for Linux when it decides its to work. 

Marco vd Heijden
Moderator
4732
Marco vd Heijden 2016.03.30 16:36  

the problem is that wine is up to date.

please downgrade Mono and Gecko to earlier ver.

Stuart Browne
5885
Stuart Browne 2016.03.30 16:51  
Dare I say it......install a genuine Windows OS as that's what it is designed to run on

*Ducks for cover*
123
To add comments, please log in or register