MT5 doesn't allow me to setup my proxy address - automatically puts incorrect instead

Grzegorz Korycki  

I have an issue with MT5 on my dedicated server. Even though I've been using this setup with MT4 (around 45 terminals in total) for years, recently, since the beginning od the year, they keep causing machine to crash (files are being saved slower and slower until the machine has a series of errors and finally freezes and requires hard reset - tried different machines and windows versions already), so I wanted to give mt5 a try for that before I drop metatrader completely and write my solution it on other language. (a lot of work)

The problem is I have setup 32 proxy servers with squid at let's say addresses: (changing the first 3 numbers)

1.2.3.32:55001
1.2.3.32:55002
[...]
1.2.3.32:55032

The main IP address to the machine is: 1.2.3.27, but it has total of 36 ip addresses, accessible to use by above HTTP proxies and few more

Whenever I enable proxy MT5 itself changes the address to 1.2.3.27:3128 (there is no proxy at that address) and that causes an error in connection. Whenever i try to change it, I click ok, i come back to option, the address is still there. I tried setting proxy on my local machine (works) and copy common.ini file there, but there is an error and when I enter options, the addess is back to incorrect 1.2.3.27:3128.  I tried stopping squid service thinking it may be suggesting metatrader that incorrect address, but the result is the same - i am unable to modify the proxy address to anything else.

What the heck? Even if I change the type to SOCKS4, it reverts to that address and HTTP. What the heck is happening.

I can bypass that by sending WebRequest via my local site and make a PHP file that will handle all the calls, (GET, POST) because I already do that with DELETE method, that is absent in MetaTrader, but first I wanted to ask if anybody has encountered a strange problem like this and knows what to do with it?!

MT5 version: 5.00 build 3429 15 Sep 2022
Machine: Windows 2016 Server, 32 GB ram, 2x E5-2620 @ 2.40 GHz

Grzegorz Korycki  

I already figured part of it out.

This is a bug of MT5 - because if you enter proxy in the system and EVEN if it is off, it will always force you to use the proxy entered there.

Turned system proxy on, deleted the address and pressed save. Then turned it back off and pressed save. 

The problem is now i get auto-fill empty address and i cannot change it from empty field... Trying machine restart.

Machine restart did not help.
Still getting empty filed. I need different proxy in every terminal, so setting one address in the system will not solve my problem.

Anybody encountered problem like this using system proxy? How to completely turn it off, so that MT5 doesn't look at it, copy it and force me to use it instead of custom proxy?


EDIT: EVEN if i put correct address to System proxy settings and MT5 copies it, the Terminal is unable to use it and connect. The only way my connection works is without is without a proxy.

Farzad Sadeghishahrestanak  

This problem still happens for me. I have searched a lot but found no solution.

After I open a proxy app like V2rayN and add the local proxy to MT5 and press test button, I see nothing, just a ding voice and MT doesn't connect. Also, when I come back again, I see it changes the proxy! How this bug didn't fix yet?!

(that proxy setting is working on MT4, so the problem is from MT5 not proxy)

Farzad Sadeghishahrestanak  

I found a solution

1- Go to windows "Safe Mode with networking"

2- Type proxy IP:Port etc. Click test and you see "test passed ok".Press OK and close MT5.

3- Restart Windows to normal mode

4- Open MT5 and it will connect to the proxy without doing anything from you (MT5 seems to save what you have done in Safe Mode).

5- Go to proxy settings in MT5 and you see it's empty! Yes, empty but connected! If you try to type proxy again, it will not work! Interesting!

So this is not the proxy problem, this is not an Antivirus or Firewall issue. This is MT5 bug and I hope someone follow this to fixing this bug by MetaQuotes

Regards

Reason: