Cannot load custom indicator [4802] MetaTrader VPS

 

Hello, good afternoon guys! I hope you are all well.

I'm only getting error 4802 when I put my robots on the VPS. Location they run normally and the custom indicator runs just fine, however, when going up to VPS it gives the error and they don't work

Has anyone gone through this? I tried to change the location of the custom indicator , I made changes that I found in other posts, but I still haven't been successful because the problem only occurs in the VPS.

Thank you in advance for your attention.

abs

 
I have same problem but no solution yet.  I think something happened with latest metatrader 5 build 2980
 
i have de same problem, somebody help?
 

Hello guys, 


This error 4802 occurs just in some indicators, not all. I believe that the cause of this error is into the specific indicator. It must be some detail in code. 

 
Geez, I've been struggling with this problem for hours.  I have three custom indicators.  All working fine in desktop terminal.  I wanted to migrate to VPS.  1 indicator works, 2 generates "cannot load custom indicator '<indicator name>' [4802]" error message.  I've tried everything I could think of.  Rewritten the indicators, because there seems to be a programming error.  Removed them in various stages.  Nothing worked.  But then I've noticed a strange thing:  Even though I've commented out the iCustom() function calls, that specific indicator which was working fine on the VPS every time, it still loaded and was working fine after migrating.  Although it shouldn't have because it wasn't in the code anymore.  And that phenomemon lead me to the solution: it is not enough to use iCustom() in the EA.  If you want to use a custom indicator on VPS you have to attach that custom indicator to the chart before migrating.
Reason: