Migration failed

pgc255
1713
pgc255  
Hey, I have a bunch of EA´s running on my 8 MQL VPS´s and one of them stopped working. I´ve tried migrating it again and I keep getting an error message that sais "migration failure, check the platform log". That has been going on since Saturday night and there is no way around it. I´ve tried pretty much everything from stopping the  VPS and starting over, migrating a different version of the EA and nothing seems to work. I´ve checked other forums and I see that other people had the same issue but I haven't found anyone who fixed it... the suggestions I got were to simply hire another service from another company but I still have a long time of paid for service here at MQL. (I run Vilela.One on the VPS) MQL VPS Fail
Juvenille Emperor Limited
Moderator
14634
Eleni Anna Branou  
pgc255:
Hey, I have a bunch of EA´s running on my 8 MQL VPS´s and one of them stopped working. I´ve tried migrating it again and I keep getting an error message that sais "migration failure, check the platform log". That has been going on since Saturday night and there is no way around it. I´ve tried pretty much everything from stopping the  VPS and starting over, migrating a different version of the EA and nothing seems to work. I´ve checked other forums and I see that other people had the same issue but I haven't found anyone who fixed it... the suggestions I got were to simply hire another service from another company but I still have a long time of paid for service here at MQL. (I run Vilela.One on the VPS)

From what we can see, the problem lies with your EA.

Check the MQL5 VPS journal/experts logs and contact the author/seller for help.

Trusow
229
Trusow  
Hello I deleted my gmail account and I restored my email but when I went to log back in with my email it says your email is already registered. It will not let me log in bc it wants me to register. So there no way I can recover this? This is madness!!! I wasted so much money!!! I have over $400 in indicators I paid for that I cannot recover! I want my money back or at least to have the indicators I paid for back. 
Juvenille Emperor Limited
Moderator
14634
Eleni Anna Branou  
Trusow:
Hello I deleted my gmail account and I restored my email but when I went to log back in with my email it says your email is already registered. It will not let me log in bc it wants me to register. So there no way I can recover this? This is madness!!! I wasted so much money!!! I have over $400 in indicators I paid for that I cannot recover! I want my money back or at least to have the indicators I paid for back. 

Why are you trying to login into your MQL5 account with your email?

Login with your trusow login and NOT your email.

I don't understand why you put your email, where you are asked for your login, the login YOU have chosen when you registered with MQL5.com.

pgc255
1713
pgc255  
The failed migration issue happened after an MT5 update. Now I need to go back to the old MT5 version or MQL needs to fix this issue. Anyone knows how to downgrade to an older MT5 version? Since last sunday that I keep getting the failed migration issue and it seems to be happening to a lot of people... not cool MQL, not cool at all..
Juvenille Emperor Limited
Moderator
14634
Eleni Anna Branou  
pgc255:
The failed migration issue happened after an MT5 update. Now I need to go back to the old MT5 version or MQL needs to fix this issue. Anyone knows how to downgrade to an older MT5 version? Since last sunday that I keep getting the failed migration issue and it seems to be happening to a lot of people... not cool MQL, not cool at all..

Your EA needs updating, when an update of MT4/5 happens, many times some older EA files needs updating to comply with the latest changes.

pgc255
1713
pgc255  
Eleni Anna Branou:

Your EA needs updating, when an update of MT4/5 happens, many times some older EA files needs updating to comply with the latest changes.

I tried older versions. I tried all 8 versions I have, some of them from before the update and some of them from after MT5 update and still there is no way to upload my  EA. Keep getting the message "migration failed". I wish it was as easy as you suggest, and I could fix it simply by running a different version of my EA. People are suggesting I run my EA´s on other VPS services but I like the service a lot so far. This is the 1st time I have any kind of trouble... 

Juvenille Emperor Limited
Moderator
14634
Eleni Anna Branou  
pgc255:

I tried older versions. I tried all 8 versions I have, some of them from before the update and some of them from after MT5 update and still there is no way to upload my  EA. Keep getting the message "migration failed". I wish it was as easy as you suggest, and I could fix it simply by running a different version of my EA. People are suggesting I run my EA´s on other VPS services but I like the service a lot so far. This is the 1st time I have any kind of trouble... 

Are you the coder of your EA?

If not, you (or I) couldn't know what is wrong and I strongly suggest to contact the author/seller of your EA to check and update it.

There is nothing else you can do, since its impossible for Metaquotes to change/update MT5 again to make your EA work, I believe you can see that.

xthomasm
1410
xthomasm  
pgc255:
Hey, I have a bunch of EA´s running on my 8 MQL VPS´s and one of them stopped working. I´ve tried migrating it again and I keep getting an error message that sais "migration failure, check the platform log". That has been going on since Saturday night and there is no way around it. I´ve tried pretty much everything from stopping the  VPS and starting over, migrating a different version of the EA and nothing seems to work. I´ve checked other forums and I see that other people had the same issue but I haven't found anyone who fixed it... the suggestions I got were to simply hire another service from another company but I still have a long time of paid for service here at MQL. (I run Vilela.One on the VPS)

Did you find a solution to this? I'm facing the same issue.


I'm the creator of my EA though, I simply don't know what to look for in my code to fix this.

xthomasm
1410
xthomasm  
xthomasm:

Did you find a solution to this? I'm facing the same issue.


I'm the creator of my EA though, I simply don't know what to look for in my code to fix this.

Nevermind. I was using a custom indicator and the VPS service doesn't like that (or DLLs). Just refactored my code to work without this indicator and it worked.

pgc255
1713
pgc255  
xthomasm:

Nevermind. I was using a custom indicator and the VPS service doesn't like that (or DLLs). Just refactored my code to work without this indicator and it worked.

Still cant find a solution. I try migrating every day but my problem here is with the hilo indicator I suppose but there wasn't an issue until the MT5 update last weekend so I don't really know what to do... just wait and pray I suppose.