MT5 freezing using custom symbols

To add comments, please log in or register
Fernando Souza
43
Fernando Souza  

Hi Guys.

I posted it in the PT-BR forum but it still not answered, then, I`m sending here hopping that somebody can help on this.

I have an expert advisor for Long & Short working in brazilian stock market.

When i have custom symbols on the charts after build 2537 MT5 stop working on every restart, it looks like a problem loading the historic data to build candles on the chart.

To have it working again is necessary to go to the terminal folder and delete Custom folder and broker's folder.

Someone is facing the same sort of problem? Is there a way to contact MetaQuotes and report this?

Best Regards, Fernando Souza

XDiavel
78
XDiavel  
Looks like I've got the same problem, MT5 freezes on the startup, started to happen after the last update happened this weekend
Sergey Golubev
Moderator
118407
Sergey Golubev  
No problem for me: I have 3 MT5 instances, and everything is fine (for different brokers).
But I do not have custom symbols sorry (so - I can not check it with custom symbols).
XDiavel
78
XDiavel  
Sergey Golubev:
No problem for me: I have 3 MT5 instances, and everything is fine (for different brokers).
But I do not have custom symbols sorry (so - I can not check it with custom symbols).

It only happens with custom symbols. MT5 freezes on startup. Once I delete folder with custom symbols as per Fernando's post MT5 launches fine. This happens on 3 of my computers after the last update, kindly ask you to investigate and fix this ASAP

Fernando Souza
43
Fernando Souza  

One of my customers suggest to change formula of custom symbols, adding the symbols between quotes, like this: "PETR4"/"PETR3" instead of PETR4/PETR3.


I made some tests but after a few restarts MT5 freeze again.  I had to remove some features that just make sense if it is running over the custom symbol until it is fixed by MetaQuotes.


When the chart is not running a custom symbol I have zero problems, just running over a custom symbol. Is there any channel that I can contact MetaQuotes or the moderators here are the bridge with them?


@XDiavel are you from Brazil too?

Keith Watford
Moderator
25593
Keith Watford  
Comments that do not relate to this topic, have been moved to "Off Topic Posts".
XDiavel
78
XDiavel  
Fernando Souza:

One of my customers suggest to change formula of custom symbols, adding the symbols between quotes, like this: "PETR4"/"PETR3" instead of PETR4/PETR3.


I made some tests but after a few restarts MT5 freeze again.  I had to remove some features that just make sense if it is running over the custom symbol until it is fixed by MetaQuotes.


When the chart is not running a custom symbol I have zero problems, just running over a custom symbol. Is there any channel that I can contact MetaQuotes or the moderators here are the bridge with them?


@XDiavel are you from Brazil too?

I can't start MT5 unless any of the custom symbols are present. This is definitely a bug introduced by the latest update.

Sergey Golubev
Moderator
118407
Sergey Golubev  
XDiavel:

It only happens with custom symbols. MT5 freezes on startup. Once I delete folder with custom symbols as per Fernando's post MT5 launches fine. This happens on 3 of my computers after the last update, kindly ask you to investigate and fix this ASAP

I look at Russian forum (the users of this language part of the forum are using custom symbols during the long time and in everyday discussion on the threads) - no one reported this issue.
I am not sure that this issue will be reproduced by the service desk (because in general - it is not a bug, but in particular - no any technical information from you to reproduce this possible bug).

Fernando Souza
43
Fernando Souza  
Sergey Golubev:

I look at Russian forum (the users of this language part of the forum are using custom symbols during the long time and in everyday discussion on the threads) - no one reported this issue.
I am not sure that this issue will be reproduced by the service desk (because in general - it is not a bug, but in particular - no any technical information from you to reproduce this possible bug).

Hi,

I understand that maybe in the Russian forum are not facing the problem but it can't be ignored as it is happening so much.


I made a change in the EA to do not force to run under a custom symbol and it works perfect fine. However, even if not using my EA, just running a custom symbol in the chart, MT5 frozen at starting just returning to life after deleting the Custom folder and the broker folder (server folder in fact) inside bases.


Is there anything that MetaQuotes can do in order to fix this problem that looks like was introduced after build 2530, until 2530 it was working pretty fine.

Sergey Golubev
Moderator
118407
Sergey Golubev  
Fernando Souza:
...

...

Is there anything that MetaQuotes can do in order to fix this problem that looks like was introduced after build 2530, until 2530 it was working pretty fine.

There are two or 3 posts in Russian forum where the users are having same issue with custom symbols.
I hope it will be improved in the future for example.

Forum on trading, automated trading systems and testing trading strategies

New version of the MetaTrader 5 platform build 2560: Improvements in the built-in training system

Renat Fatkhullin , 07/20/2020 01:03 AM

Indicate the synthetics formulas, please.

There will be zero chances of resolving the issue without any details to reproduce it.


We automatically convert the old synthetics databases to the new format in the new release, and it can take time in the first time. This is if there is a database of old synthetic symbols on disk.


Sergey Golubev
Moderator
118407
Sergey Golubev  

About custom symbols - reply from MetaQuotes (thanks to @Limons who made a post in Russian forum in English with issue evidence/proof), so finally the admins were able to reproduce the bug related to the custom symbols:

12
To add comments, please log in or register