to mt5 support , bug news releases mt5 (1940+) - page 4

To add comments, please log in or register
Slava
Moderator
7568
Slava  
zemo:

Mr.Alain,


Since april/2018  with new mt5 releases and windows 10 64 bits with falls creator update the ontick  freeze my machine.. same problems with anothers friends in brazil that are using windows 10 64 bits..

but I'm want to relate a new bug while optimizing , I called it "the OnInit bug with the last "build 1950"


I'm optimizing using OHLC (well this the only "mode" that works without hang my windows 10 with amd octare processor)

ok,

how reproduce it.
=================
my EA has a routine in the OnInit to "exclude" bad values using return(INIT_FAILED) on the "OnInit" of the EA
to economize time in the optimization, this works with the old version but now it's breaking the optimization.

I started the optimization OHLC, 
and I go to the "diary" Tabs and see the messages , that are normal... because I'm excluding the bad values from the OnInit



but while it is in  the pass 512 (or a little more) the mt5 stopped the optimization without conclude it (it doesn't complet at the end) 

and the agents are hanged with 0% cpu usage, the optimization is "forced to end" and the "start" but still GRAYED...

I have to go to the windows taskmanager

and I kill manually the 8 agents hanged, and after it the "START" button in the in the mt5 comes "ENABLED" again...


Fixed
Mladen Rakic
114246
Mladen Rakic  
Mladen Rakic:
OnDeinit() is not called when indicator is removed from the chart now (build 1947) or it is called with a huge delay (sometimes it is executed after some random pause, sometimes it is not executed at all when the indicator is removed from the chart)
In the latest build (1955) that issue (along with the similar issue with destructors not triggered when they should have) is solved
Mladen Rakic
114246
Mladen Rakic  
Now (build 1958) the profiler does not show any of the profiler results
Alain Verleyen
37188
Alain Verleyen  
Mladen Rakic:
Now (build 1958) the profiler does not show any of the profiler results
You don't need it, your code is always fast ;-)
Mladen Rakic
114246
Mladen Rakic  
Alain Verleyen:
You don't need it, your code is always fast ;-)

It was not (like that) always.

Only in the last 4-5 months I stopped counting on (assumed) mt5 speed, and started optimizing code line by line and changing almost all the algos used, and frankly I think that the profiler is one of the best additions of the whole thing - without it it is rather - strange at the least.

Alain Verleyen
37188
Alain Verleyen  
Mladen Rakic:

It was not (like that) always.

Only in the last 4-5 months I stopped counting on (assumed) mt5 speed, and started optimizing code line by line and changing almost all the algos used, and frankly I think that the profiler is one of the best additions of the whole thing - without it it is rather - strange at the least.

I know, was just kidding :-)
Alain Verleyen
37188
Alain Verleyen  
Mladen Rakic:
Now (build 1958) the profiler does not show any of the profiler results
Not sure what you did, but I just use it and it seems to work as expected (with an indicator).
Mladen Rakic
114246
Mladen Rakic  
Alain Verleyen:
Not sure what you did, but I just use it and it seems to work as expected (with an indicator).

Didn't do anything

Just allowed the usual update (to build 1958)

Build 1955 works correctly

Alain Verleyen
37188
Alain Verleyen  
Mladen Rakic:

Didn't do anything

Just allowed the usual update (to build 1958)

No I mean, what you did to see "the profiler does not show any of the profiler results". How to reproduce it ?


Mladen Rakic
114246
Mladen Rakic  
Alain Verleyen:

No I mean, what you did to see "the profiler does not show any of the profiler results". How to reproduce it ?


See these :

The profiler - after the test is finished (it displays OK while testing)


And this is the editor - when the run ends


Ie: nothing displayed

PS: as I mentioned - all works OK in build 1955

To add comments, please log in or register