Download MetaTrader 5

MQL5 MetaTester 5 Agents Tests passed 0

To add comments, please log in or register
jeenz
18
jeenz  

Hello all,

I downloaded and installed the MetaTester 5 Agents Manager build 1643 a few weeks ago and setup agents. I have the scheduler enabled to allow cloud networks tasks anytime as well as checking the box on the MQL5 Cloud Network tab to sell computing resources via an MQL5.community account. My account is active and I see my agents listed on the agents page. Agents report they are connected to the cloud, however after several weeks nothing seems to be happening.


I believe my configuration is correct, but if there is something else I need to setup to get this working please let me know. I have a very powerful desktop system that I build recently and I was hoping to sell computing time to the cloud to make some extra money to offset the costs of the equipment. If the cloud network is no longer functional or if this does not work anymore please let me know.


Thank you

Fernando Carreiro
3391
Fernando Carreiro  
jeenz: I downloaded and installed the MetaTester 5 Agents Manager build 1643 a few weeks ago and setup agents. I have the scheduler enabled to allow cloud networks tasks anytime as well as checking the box on the MQL5 Cloud Network tab to sell computing resources via an MQL5.community account. My account is active and I see my agents listed on the agents page. Agents report they are connected to the cloud, however after several weeks nothing seems to be happening.

I believe my configuration is correct, but if there is something else I need to setup to get this working please let me know. I have a very powerful desktop system that I build recently and I was hoping to sell computing time to the cloud to make some extra money to offset the costs of the equipment. If the cloud network is no longer functional or if this does not work anymore please let me know.

Have a look at the following:

There are more threads on the subject, but unfortunately the Search facility on the site is not functioning correctly, so use a Google search to find more (see below for example):

1 year of Cloud's agents providing
1 year of Cloud's agents providing
  • 2014.03.01
  • www.mql5.com
Just 1 year today. See this topic for more information https://www.mql5.com/en/forum/13542#cloud...
jeenz
18
jeenz  
Fernando Carreiro:

Have a look at the following:

There are more threads on the subject, but unfortunately the Search facility on the site is not functioning correctly, so use a Google search to find more (see below for example):

  • "site:mql5.com/en/forum metatester agents"
    Fernando Carreiro:

    Have a look at the following:

    There are more threads on the subject, but unfortunately the Search facility on the site is not functioning correctly, so use a Google search to find more (see below for example):

    • "site:mql5.com/en/forum metatester agents"

    Thank you for the response, however I did not find anything in the article relevant to my problem. I can create the service agents successfully, they show connected, and they have values for Traffic in and out. I have a Core I7 4 Ghz system with 32GB of RAM, so I know my system is more than capable of running the agents but I'm not seeing anything happen.

Fernando Carreiro
3391
Fernando Carreiro  
jeenz: Thank you for the response, however I did not find anything in the article relevant to my problem. I can create the service agents successfully, they show connected, and they have values for Traffic in and out. I have a Core I7 4 Ghz system with 32GB of RAM, so I know my system is more than capable of running the agents but I'm not seeing anything happen.

Don't just assume that the your system is fast enough. Instead, look at the actual PR (Performance Ratio) reported on your profile for each node of the agents. Unless they are higher than a value of 100, you will not get much activity on it!

The main bottleneck is hard-drive speed, and unless you are using very fast drives, such as an SSD, your PR value may just be borderline.

Marco vd Heijden
Moderator
5763
Marco vd Heijden  

And realize that you didn't mentioned an operating system.

jeenz
18
jeenz  

Here is my full system specs:

Intel Core I7 Ghz

32GB DDR4

Dual SSD running in RAID 0

Windows 10 Pro

From the agents screen I only see a PR value of 30 for my agents, so maybe that explains why I'm having the issue. Any suggestions as to what could be responsible for such a low performance rating even with the hardware I have?

Fernando Carreiro
3391
Fernando Carreiro  
jeenz: From the agents screen I only see a PR value of 30 for my agents, so maybe that explains why I'm having the issue. Any suggestions as to what could be responsible for such a low performance rating even with the hardware I have?

A PR of 30 is extremely low. Even my old dual core with only 8GB and running on old mechanical 3Gb/s SATA drives gives me higher PR (see below).

Maybe you have too many processes running at the same time or consuming too many resources?

Maybe you have a BitTorrent client running on it too and its sucking on the network bandwidth?


jeenz
18
jeenz  
Fernando Carreiro:

A PR of 30 is extremely low. Even my old dual core with only 8GB and running on old mechanical 3Gb/s SATA drives gives me higher PR (see below).

Maybe you have too many processes running at the same time or consuming too many resources?

Maybe you have a BitTorrent client running on it too and its sucking on the network bandwidth?



That is very interesting, so the PR is definitely my problem. Any idea how this is calculated or how it can be updated?


I do have other processes that are running on my system, but none are CPU / Memory / Disk / Network intensive at all. At any given time this is the normal stats from Task Manager on my system:

Task Manager

Fernando Carreiro
3391
Fernando Carreiro  
jeenz: That is very interesting, so the PR is definitely my problem. Any idea how this is calculated or how it can be updated?

I do have other processes that are running on my system, but none are CPU / Memory / Disk / Network intensive at all. At any given time this is the normal stats from Task Manager on my system:

CPU and RAM seem fine, but I notice that you are using a RAID configuration - is hardware or firmware/software?

Firmware or software based ones can be quite "slow", so run some benchmarks to see the real speed.

However, the size is 5.5TB on Drive D: which is quite large for SSD as they very expensive. Is it really SSD or is it Hybrid?

Also, what is your Internet bandwidth?

Marco vd Heijden
Moderator
5763
Marco vd Heijden  

Thats a $100.000 worth of SSD Harddrives.

Quite the system.

To add comments, please log in or register