Windows 7: Custom Indicators appear in the lsit but cannot be dragged to chart

fractalfreak
22
fractalfreak  

Hi guys,

please be so kind to help.

I use MT4 for a long time now, but I struggle with an issue I did not find described anywhere.

I have a lot of custom indicators, but since 2 days, when I add new custom indis to MT4, these appear in the "indicator list" but when I double-click on these or drag them, nothing happens............I re-installed MT4, no solution, I re-compliled the indis, no solution.

I use Windows 7 (I tried disabling UAC, no solution).

Any ideas what it could be? The custom indis I am trying to use work fine on another machine.

Thanks a lot!

William Snyder
9581
William Snyder  
fractalfreak:
Hi guys,

please be so kind to help.

I use MT4 for a long time now, but I struggle with an issue I did not find described anywhere.

I have a lot of custom indicators, but since 2 days, when I add new custom indis to MT4, these appear in the "indicator list" but when I double-click on these or drag them, nothing happens............I re-installed MT4, no solution, I re-compliled the indis, no solution.

I use Windows 7 (I tried disabling UAC, no solution).

Any ideas what it could be? The custom indis I am trying to use work fine on another machine.

Thanks a lot!

Hi Fractalfreak,

It could be you have to many indicators in your servers indicator folder.

Mladen Rakic
226586
Mladen Rakic  
fractalfreak:
Hi guys,

please be so kind to help.

I use MT4 for a long time now, but I struggle with an issue I did not find described anywhere.

I have a lot of custom indicators, but since 2 days, when I add new custom indis to MT4, these appear in the "indicator list" but when I double-click on these or drag them, nothing happens............I re-installed MT4, no solution, I re-compliled the indis, no solution.

I use Windows 7 (I tried disabling UAC, no solution).

Any ideas what it could be? The custom indis I am trying to use work fine on another machine.

Thanks a lot!

How did you recompile the indicators?

Usually if you see it in a list and it does not work when you try to attach it to the chart it means that there is no valid ex4 file (it was not successfully compiled). Try starting metaeditor (and terminal) with administrators rights and then try compiling it from metaeditor and check if there are compilation errors.

fractalfreak
22
fractalfreak  

hi mrtools,

I tried a different server, same issue.....

mladen, I did what you said, not solved yet, however after compiling I always get a mq4 and not the exe file

fractalfreak
22
fractalfreak  

"Hi Fractalfreak,

It could be you have to many indicators in your servers indicator folder."

How could I delete some from the server?

"Try starting metaeditor (and terminal) with administrators rights and then try compiling it from metaeditor and check if there are compilation errors."

No compilation error message, however I cannot see any ex4 file.

Any suggestions guys?

William Snyder
9581
William Snyder  
fractalfreak:
"Hi Fractalfreak,

It could be you have to many indicators in your servers indicator folder."

How could I delete some from the server?

"Try starting metaeditor (and terminal) with administrators rights and then try compiling it from metaeditor and check if there are compilation errors."

No compilation error message, however I cannot see any ex4 file.

Any suggestions guys?

Fractalfreak, I have a extra folder on my desktop and I remove all the indicators and EA's I don't use from my servers experts and experts/indicators folder and transfer them to the extra folder.Doing what we do here on the forum have found, need to do this at least once a week.

William Snyder
9581
William Snyder  

Fractalfreak,something else was reminded of,

That windows 7 problem : see these posts https://www.mql5.com/en/forum/179698/page2

Check those posts maybe they will help (as far as I know if you install it in program files in Windows 7 you will have problems like his)

So I usually instal it somewhere completely else : D: partition E: partition anything but program files (I even avoid C: partition - you never know what will windows 7 do there to "protect" you from yourself)

fractalfreak
22
fractalfreak  
mrtools:
Fractalfreak,something else was reminded of,

That windows 7 problem : see these posts https://www.mql5.com/en/forum/179698/page2

Check those posts maybe they will help (as far as I know if you install it in program files in Windows 7 you will have problems like his)

So I usually instal it somewhere completely else : D: partition E: partition anything but program files (I even avoid C: partition - you never know what will windows 7 do there to "protect" you from yourself)

Hi, I did that, does not make a difference.............I will now try to move all unused indis and eas ina different folder......however, I tried that before, that does not help........how could I change indis on the server?

William Snyder
9581
William Snyder  
fractalfreak:
how could I change indis on the server?

Not sure I understand your question.

Mladen Rakic
226586
Mladen Rakic  
fractalfreak:
Hi, I did that, does not make a difference.............I will now try to move all unused indis and eas ina different folder......however, I tried that before, that does not help........how could I change indis on the server?

fractalfreak

Read this post : https://www.mql5.com/en/forum/179698/page2

It will probably solve your problem (and that is what mrtoolds was trying to tell - install metatrader somewhere else not in the default "C:\Program Files\" folder - best to move it to some other partition than C: in case that you have to make a clean install on your windows at any time : your other partition will be intact, and you will be able to run metatrader as if nothing happened)

fractalfreak
22
fractalfreak  
mladen:
fractalfreak

Read this post : https://www.mql5.com/en/forum/179698/page2

It will probably solve your problem (and that is what mrtoolds was trying to tell - install metatrader somewhere else not in the default "C:\Program Files\" folder - best to move it to some other partition than C: in case that you have to make a clean install on your windows at any time : your other partition will be intact, and you will be able to run metatrader as if nothing happened)

Hi guys,

I tried the solution proposed in the link (installing wihin different folder etc.), I deleted a lot of indis, still the problem remains....starts to drive me nuts....please help.....is there nobody who had similiar problems before?