Download MetaTrader 5
To add comments, please log in or register
Have you just installed MetaTrader 5? Learn it in details!
researchpro
57
researchpro 2014.10.09 00:20 

Hi, suddenly after update yesterday the print out log is messed up, I'm getting rows of numbers on the far left, and now it won't even print out to log except for some of the lines

Access violation read to 0x2456F000

Version 4 Build 711 sep 27

I didn't see too many solutions or explanations to these access violation issues on the threads.

Any ideas what happened or what I can do to fix it?

Thanks

John 

researchpro
57
researchpro 2014.10.09 00:23  

 

This is a pic of the printout screen 

researchpro
57
researchpro 2014.10.09 01:26  

This is something (below) new being printed up in the log. Is it telling me anything that can help identifiy the problem? I contacted Oanda, and they just blamed on EA's. I guess they think all my EA's went bad at the same time...

Any suggestions appreciated.



\Newtest.10.04.600.EURUSD1.0" found and can be used for further optimization

3    19:30:27.756    TestGenerator: actual tick file "C:\Users\john\AppData\Roaming\MetaQuotes\Terminal\FFFA485E68CFA6A38B50A4B6C7FD8585\tester
Ilyas
1183
Ilyas 2014.10.09 07:25  
researchpro:

Hi, suddenly after update yesterday the print out log is messed up, I'm getting rows of numbers on the far left, and now it won't even print out to log except for some of the lines

Access violation read to 0x2456F000

Version 4 Build 711 sep 27

I didn't see too many solutions or explanations to these access violation issues on the threads.

Any ideas what happened or what I can do to fix it?

Thanks

John 

Thank you for your message.

Do you use any DLL in the your MQL program?
Please create new task in the Service desk and provide MQL source code there.
researchpro
57
researchpro 2014.10.09 11:14  
mql5:
Thank you for your message.

Do you use any DLL in the your MQL program?
Please create new task in the Service desk and provide MQL source code there.

Thanks mql5,

I'm not sure if I do. I didn't write one in, but I'm not sure what is done automatically. It's all of my EA's that are affected. Even the EA that comes with the platform won't perform a simple print function. This is some of the log print out. I would think it has some info in it that could shed light on what is occurring. Note the weird column of numbers on the left,(new since update, that was the first clue I saw that something isn't right. A day later it stopped testing altogether).

\Newtest.9.22.600.EURUSD1.0" found and can be used for further optimization

3 20:00:56.135 TestGenerator: actual tick file "C:\Users\john\AppData\Roaming\MetaQuotes\Terminal\FFFA485E68CFA6A38B50A4B6C7FD8585\tester\history\EURUSD1_0.fxt" found

2 20:00:56.135 Newtest.9.22.600: optimization started

2 20:00:56.135 Newtest.9.22.600: optimization finished, 1 cache records were used

0 20:00:56.135 There were 1 passes done during optimization 

It has to be platform, or a compatibility issue with my computer.  I will do as you suggest.

Thanks for taking the time to respond.

John 

researchpro
57
researchpro 2014.10.09 23:22  

FYI: For those that may be interested, see note below from a brokerage source.

We have been receiving reports from customers regarding the MT4 update 711. There seems to be some issues with this update and Metaquotes is planning to release an update shortly (scheduled on October 10th)

Ilyas
1183
Ilyas 2014.10.10 06:56  
researchpro:

...

I'm not sure if I do. I didn't write one in...

So, if you don't use DLLs directly in your code, this error should not appear in the log. Please write to the
ServiceDesk and provide your source code (minimal required for reproducing the error) so that we could investigate this issue.
/
To add comments, please log in or register