Download MetaTrader 5
To add comments, please log in or register
Find out how to add a video in the messages editor
gleneroo
21
gleneroo 2014.02.10 17:05 

Hello

On my VPS I always had nine MT4 terminals running.

Each has its own installation (different folder).

All terminals are started with the scheduler progressively (every minute or two).

Since build 600, it doesn't work anymore. Terminals are hanging, not responding. CPU is 100%. Of course it worked fine before.

I tried reinstalling everything, putting more time between each terminal start => it didn't help.

Is it that build 600 use much more resources ? Any way to solve this issue ?

Thanks and regards

Simon Gniadkowski
Moderator
17963
Simon Gniadkowski 2014.02.10 17:07  
gleneroo:

Hello

On my VPS I always had nine MT4 terminals running.

Each has its own installation (different folder).

All terminals are started with the scheduler progressively (every minute or two).

Since build 600, it doesn't work anymore. Terminals are hanging, not responding. CPU is 100%. Of course it worked fine before.

Is it that build 600 use much more resources ? Any way to solve this issue ?

Thanks and regards

Are they trying to update to a newer Build ?
Michele Lazzarini
470
Michele Lazzarini 2014.02.10 17:14  
gleneroo:

On my VPS I always had nine MT4 terminals running.

Since build 600, it doesn't work anymore. Terminals are hanging, not responding. CPU is 100%. Of course it worked fine before.

Which windows version is running on the VPS?

To reduce the RAM usage I recommend to set the minimum bars (needed by the EA) in history and chart.

Menu -> Tools -> Options -> Charts

Make sure they make the update separately, each one running alone on the VPS.

gleneroo
21
gleneroo 2014.02.10 17:18  

No, it is all the time, not due to stations upgrading.

I already reduced the minimum bars in history and chart, respectively, to 5000 and 2000. It is very little.

Also done other things like turning off news, hidden all pairs and closed the market watch, etc.

I also uninstalled the stations and reinstalled. Didn't help. :-(

It seems the issue is only for people running multiple terminals

Michele Lazzarini
470
Michele Lazzarini 2014.02.10 17:20  
gleneroo:

No, it is all the time, not due to stations upgrading.

I already reduced the minimum bars in history and chart, respectively, to 5000 and 2000. It is very little.

Also done other things like turning off news, hidden all pairs and closed the market watch, etc.

I also uninstalled the stations and reinstalled. Didn't help.

Check the Task manager to see how much RAM they are using.
gleneroo
21
gleneroo 2014.02.10 17:23  

In the task manager I have only roughly 1/3 of RAM used.

Resource problem seems to be on CPU.

Simon Gniadkowski
Moderator
17963
Simon Gniadkowski 2014.02.10 17:26  
gleneroo:

In the task manager I have only roughly 1/3 of RAM used.

Resource problem seems to be on CPU.

It sound like you have an Indicator running at high CPU in your terminals, perhaps as part of the template?
gleneroo
21
gleneroo 2014.02.10 17:28  

No I don't. My EAs use only indicators already coded by default in the terminal (CCI, MA).

I want to underline again everything run smoothly with previous build, for several years.

Thank you for the fast answers ! I am very impressed by the support !

Simon Gniadkowski
Moderator
17963
Simon Gniadkowski 2014.02.10 17:35  
gleneroo:

No I don't. My EAs use only indicators already coded by default in the terminal (CCI, MA).

I want to underline again everything run smoothly with previous build, for several years.

Thank you for the fast answers ! I am very impressed by the support !

I guess your EA is added to the template ? try one terminal with the default template removed so you can atleast get it to start in a controlled way, if you can do this you can then add your EA to a chart to see if it's your EA causing the issue.
gleneroo
21
gleneroo 2014.02.10 17:44  

I am not sure what you call templates.

To me, a template is something with indicators, nice colors, giving traders some signals about decisions they should take.

In my case I have only multiple graphs, on which EA are attached.

Each terminal has multiple graphs, and I have multiple terminals.

Still, before the update, it has run fine.

I guess I am more looking for a way to reduce CPU usage and/or to turn off some new features that may use some CPU in addition versus before

Regards

Simon Gniadkowski
Moderator
17963
Simon Gniadkowski 2014.02.10 17:53  
gleneroo:

I am not sure what you call templates.

To me, a template is something with indicators, nice colors, giving traders some signals about decisions they should take.

In my case I have only multiple graphs, on which EA are attached.

Each terminal has multiple graphs, and I have multiple terminals.

Still, before the update, it has run fine.

I guess I am more looking for a way to reduce CPU usage and/or to turn off some new features that may use some CPU in addition versus before

Regards

You can attach your EA to a chart save the template and then when you apply the template to a chart the EA will automatically applied too.

First you need to understand what is causing the CPU to be used, is it MT4 or is it MT4 running your EA ? Can you run MT4 without your EA running ?
/ /12
To add comments, please log in or register