Download MetaTrader 5
To add comments, please log in or register
Unable to find the right application? Order it!
karlie4nia
124
karlie4nia 2014.02.06 10:32 

PLEASE I JUST GOT A NEW SET OF CUSTOM INDICATORS BUT THEY ARE NOT ON THE LIST OF CUSTOM INDICATORS EVEN AFTER APPLYING THEM CORRECTLY

IN THE EXPERTS-INDICATORS FOLDER.

PLEASE I NEED HELP TO GET THESE INDICATORS ON MY CHARTS. SEEMS THERE IS SOME CHANGES ON THE MT4 PLATFORM THAT AFFECTS THIS INSTALLATION. THANKS.

whroeder1
13982
whroeder1 2014.02.06 14:11  
  1. Please stop SHOUTING AT US.
  2. If the file is a .mq4, you need to compile it.
  3. If the file is a .ex4, you need to restart the platform so it sees the new file.
  4. If it the new build 600+, the location has changed. You said you put them in the correct place but we are not mind readers. Where EXACTLY did you put them.
karlie4nia
124
karlie4nia 2014.02.06 16:41  

Am sorry. Didn't mean to shout at anyone.

I put them in Expert-Indicator folder of my instaforex mt4 platform. Its an exe4 file and i have done all that to restart platform but its still not listed.

Cant say if its new build but with the new build, what is the new location? Besides noticed certain changes in the other indicators on platform with the usual yellow icon showing now dark for my other custom indicators. I would greatly appreciate any help.

backdoc
21
backdoc 2014.02.06 16:42  

It seems I am having the same problem in build 600. It appears the folders string has changed for imputing custom indicators from Experts / indicators to MT4/MQL4/Indicators. When pasting indicators to this file they are present but I have compiled as well as restarted the platform and indicators are not there.

Any suggestions would be appreciated.

Thanks.

Alain Verleyen
Moderator
29649
Alain Verleyen 2014.02.06 17:52  
backdoc:

It seems I am having the same problem in build 600. It appears the folders string has changed for imputing custom indicators from Experts / indicators to MT4/MQL4/Indicators. When pasting indicators to this file they are present but I have compiled as well as restarted the platform and indicators are not there.

Any suggestions would be appreciated.

Thanks.

  1. Start your platform, if not ready open.
  2. On the File menu, click on Open Data Folder.
  3. An Explorer window opens.
  4. It's all the data for your platform, open MQL4 folder.
  5. In this folder you can find Experts, Indicators and Scripts sub-folders,
  6. Copy your mq4 or ex4 file in the appropriate folder.
  7. Restart your MT4 platform.

P.S. It's not the only way, but it's simplest for non technical person I think.

ericnov
36
ericnov 2014.02.06 18:33  

I copy 20 time on the good folder, but the platform cannot open the indicator, it find an error that it was not before with old MT4 version " invalid integer number of parameter 2 for 'iCustom' order but I can put it on the chart (very comic) and 0 error copiling it

I use this indicatore since more then 5 yaers without any problem, so the problem is not the indicator but the build 600, now I need to spend hours and money to find solution, and rebackest all during days before trading live. moreover I did'nt ask any update MT4 was updated along

Thank you

backdoc
21
backdoc 2014.02.06 20:29  
angevoyageur:
  1. Start your platform, if not ready open.
  2. On the File menu, click on Open Data Folder.
  3. An Explorer window opens.
  4. It's all the data for your platform, open MQL4 folder.
  5. In this folder you can find Experts, Indicators and Scripts sub-folders,
  6. Copy your mq4 or ex4 file in the appropriate folder.
  7. Restart your MT4 platform.

P.S. It's not the only way, but it's simplest for non technical person I think.

Thank you angevoyageur for the help. It worked.
karlie4nia
124
karlie4nia 2014.02.07 10:49  
Yeah i got it figured out. Thanks yall. There is been a slight modification on mt4 and as such the usual location for the custom indicators changed and can be found in the folder MQL4 then - indicators. Once i placed my custom indicators in there they worked.
forex_tebet
7
forex_tebet 2014.02.07 15:45  


angevoyageur:

  1. Start your platform, if not ready open.
  2. On the File menu, click on Open Data Folder.
  3. An Explorer window opens.
  4. It's all the data for your platform, open MQL4 folder.
  5. In this folder you can find Experts, Indicators and Scripts sub-folders,
  6. Copy your mq4 or ex4 file in the appropriate folder.
  7. Restart your MT4 platform.

P.S. It's not the only way, but it's simplest for non technical person I think.



hello angevoyageur,

im from indonesia..i've tried your suggestion, but still i cant add my new indicator to my 'custom indicator'..

its icon color is brown (not work) while my others new indicator is yellow (its work)..could you help me,please?


Alain Verleyen
Moderator
29649
Alain Verleyen 2014.02.07 16:38  
nurakhman78:


angevoyageur:

  1. Start your platform, if not ready open.
  2. On the File menu, click on Open Data Folder.
  3. An Explorer window opens.
  4. It's all the data for your platform, open MQL4 folder.
  5. In this folder you can find Experts, Indicators and Scripts sub-folders,
  6. Copy your mq4 or ex4 file in the appropriate folder.
  7. Restart your MT4 platform.

P.S. It's not the only way, but it's simplest for non technical person I think.



hello angevoyageur,

im from indonesia..i've tried your suggestion, but still i cant add my new indicator to my 'custom indicator'..

its icon color is brown (not work) while my others new indicator is yellow (its work)..could you help me,please?


There is probably some errors due to change in mql4. Can you post the code ?
ffoorr
996
ffoorr 2014.02.07 17:06  

show the path please

editor > open data folder and copy the path

/ /123
To add comments, please log in or register