Diferença entre o sinal do indicador do robô e do gráfico.

 

Será que existe alguma diferença entre o sinal do indicador do gráfico e do robô? tem vezes que meu robô ele entra abaixo da banda normalmente, tem vezes que ele se atola lá em baixo e não entra, isso acontece muito no começo quando coloco o robô para rodar. 

Uma amostra do código, então entendo o porque no backtest faz isso.

iBands_buffer_02[1] <= gl_Price.bid

Estou pensando aqui em por um candle.low[1] no lugar do tick. 

Arquivos anexados:
entrou.PNG  13 kb
 
Diego Wozniak:

Será que existe alguma diferença entre o sinal do indicador do gráfico e do robô? tem vezes que meu robô ele entra abaixo da banda normalmente, tem vezes que ele se atola lá em baixo e não entra, isso acontece muito no começo quando coloco o robô para rodar. 

Uma amostra do código, então entendo o porque no backtest faz isso.

Estou pensando aqui em por um candle.low[1] no lugar do tick. 

Do que você está falando criatura??

Ponha um contexto em sua pergunta...

Cada um...

 
Flavio Jarabeck:

Do que você está falando criatura??

Ponha um contexto em sua pergunta...

Cada um...

Olha as imagens que você vai entender.
 
Diego Wozniak:
Olha as imagens que você vai entender.

Não, não entendi...


Boa sorte!

 
Diego Wozniak:

Será que existe alguma diferença entre o sinal do indicador do gráfico e do robô? tem vezes que meu robô ele entra abaixo da banda normalmente, tem vezes que ele se atola lá em baixo e não entra, isso acontece muito no começo quando coloco o robô para rodar. 

Uma amostra do código, então entendo o porque no backtest faz isso.

Estou pensando aqui em por um candle.low[1] no lugar do tick. 

Especifique onde no seu código pode ter alguma divergência.. O erro pode estar em 1 milhão de lugares. Mas com certeza a culpa não é do indicador
Razão: